Announcement

Collapse
No announcement yet.

Log syncing entry

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Log syncing entry

    What exactly does this log entry mean?

    Code:
    Legacy-Plugin OMNI Synchronizing OMNI devices with HomeSeer...
    Because I'm assuming it means it's syncing the status of devices but every time I do a restart and I have lights on, the omni P-I does not show them as on.

  • #2
    Is this Hs4?
    HS3Pro Running on a Raspberry Pi3
    64 Z-Wave Nodes, 168 Events, 280 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #3
      HS3 and HS4

      Comment


      • #4
        Because I'm assuming it means it's syncing the status of devices but every time I do a restart and I have lights on, the omni P-I does not show them as on.
        Does the Omni panel show them as on? The plugin probably only shows the status that the Omni reports, and if lights are changed while the Omni is "off" you would have to have the Omni do a get status. For example, using UPB, if I were to unplug the PIM and then manually turn some lights on, the Omni would not know about it, plugging the PIM back in would not update the status, you would have to tell the omni to do a get a status for each light.

        Comment


        • #5
          Yes. It's when I restart HS. Nothing to do with the Omni itself.

          So the lights are on. I restart HS. Omni plugin says syncing. Then shows no lights on. But they are.

          Comment


          • #6
            I'll check the code when I get a chance, but it basically traverses the units and gets the current status. I'll report back.
            HS3Pro Running on a Raspberry Pi3
            64 Z-Wave Nodes, 168 Events, 280 Devices
            UPB modules via OMNI plugin/panel
            Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
            HSTouch Clients: 3 Android, 1 Joggler

            Comment


            • #7
              Yes - that section of code is updating HS from the OMNI status. It sounds like yours is not working? I'll need to investigate further.
              HS3Pro Running on a Raspberry Pi3
              64 Z-Wave Nodes, 168 Events, 280 Devices
              UPB modules via OMNI plugin/panel
              Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
              HSTouch Clients: 3 Android, 1 Joggler

              Comment


              • #8
                Does yours work?
                Turn on a light.
                Verify it's on in PC Access.
                Restart Homeseer.
                Does the light show as on in Homeseer? in PC Access?

                Comment


                • #9
                  Ah - I see that now. I think it is a timing issue. Querying the panel takes quite a while and I think the process to synchronize needs to take place later in the startup process.
                  I'll see what I can do.

                  Thanks for finding this. I dont restart often, so I wasnt aware.
                  HS3Pro Running on a Raspberry Pi3
                  64 Z-Wave Nodes, 168 Events, 280 Devices
                  UPB modules via OMNI plugin/panel
                  Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                  HSTouch Clients: 3 Android, 1 Joggler

                  Comment

                  Working...
                  X