Announcement

Collapse
No announcement yet.

UltraM1G3 HSPI and Alexa Thermostat Support

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UltraM1G3 HSPI and Alexa Thermostat Support

    UltraM1G3 HSPI version 3.0.6225.23941 was released to fix an issue causing Alexa not to recognize a connected thermostat. Please follow these instructions to update:
    1. Stop the UltraM1G3 HSPI plug-in from PLUG-INS by clicking the Enable button next to the UltraM1G plug-in.
    2. Click the "Update Listing" button.
    3. Click the checkbox in the update column, then under "Pending Updates/Installs", select Download and Install.
    4. Once the install completes, start the UltraM1G3 HSPI plug-in from PLUG-INS by clicking the Enable button next to the UltraM1G plug-in.
    5. Wait until the plug-in has fully initialized. This may take up to 5 minutes on a slower system. If you see UltraM1G3 in the PLUG-INS menu, then the plug-in is fully initialized.
    6. Restart HSTouch Server (may not be required)


    Then tell Alexa to "Discover Devices", then once complete you can control the thermostat by saying "Alexa, set the thermostat to 70 degrees"

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

  • #2
    Awesome!!!! Thanks for this.

    A few questions on implementation.

    For me, I have 2- Omnistat II 2000 thermostats tied in via serial to the Elk M1.

    This works with Alexa with you latest release but for me is far more complicated the "Alexa, set Kitchen to 68 degrees".

    I have to use the command, "Alexa, set Thermostat Oh One Heat to 68 degrees" and it works.

    As soon as I add in the 2nd thermostat, automatically named Thermostat 02, neither will work as I think the names are too close for Alexa to properly separate them.

    If I change the name of the thermostat, Alexa no longer can find a device by that name or the typical "I found multiple devices by that name, which one did you want?"

    I have told Alexa app to Forget all Devices and then discover all devices each time I made changes.

    Any ideas on what I am doing wrong so I can try to make both thermostats work for me?

    Thanks!
    Attached Files

    Comment


    • #3
      I have two RCS RS-485 thermostats. I believe I followed the instructions per the the first post. Alexa discovers the thermostats (one Alexa device per thermostat), but when I tell Alexa to change the heat setpoint, it says it can only change the value between 0 and 0 -- what have I done wrong?

      BBB

      Comment


      • #4
        Are you running the latest version of the plug-in? If no, install the latest version. If yes, delete and re-create the thermostat devices.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment

        Working...
        X