Announcement

Collapse
No announcement yet.

Repeating Errors in Log

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Repeating Errors in Log

    Hi,

    The following is repeated in the log.

    Any ideas to solve this would be welcome.

    -Philip


    Feb-06 4:13:15 PM Informational Elk Real Time Clock reports: 06/02/2017 16:13:14, dd/mm format, 24 hour format, DST is Active
    Feb-06 4:13:15 PM Error Data that caused error in ProcessCommand() subroutine: Len=19, Cmd=KC, Data=0000000001000000000, Reserved=00
    Feb-06 4:13:15 PM 1 Error System.NullReferenceException: Object variable or With block variable not set. at Microsoft.VisualBasic.CompilerServices.Symbols.Container..ct or(Object Instance) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.Object LateIndexSetComplex(Object Instance, Object[] Arguments, String[] ArgumentNames, Boolean OptimisticSet, Boolean RValueBase) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateIn dexSetComplex(Object Instance, Object[] Arguments, String[] ArgumentNames, Boolean OptimisticSet, Boolean RValueBase) at HSPI_ULTRAM1G3.hspi_plugin.ProcessCommand(String strLen, String strCmd, String strData, String strReserved)
    Feb-06 4:13:15 PM 1 Error System.NullReferenceException

  • #2
    Hello Philip,

    Can you please restart HomeSeer, then let me know if you still see those errors written to your log?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Hi,

      Thanks - I'm seeing the previous one as well as:

      Feb-18 1:49:23 PM 1 Error System.FormatException: Additional non-parsable characters are at the end of the string. at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos) at System.Convert.ToInt32(String value, Int32 fromBase) at HSPI_ULTRAM1G3.hspi_plugin.ProcessReceived(String strDataRec)
      Feb-18 1:49:23 PM 1 Error System.FormatException

      I believe I have solved the continual disconnection/reconnection issue to a bad XEP card (specifically the power regulator).

      But the log errors are not part of this issue.

      Thanks!!

      -Philip

      Comment


      • #4
        Hello philipi,

        Are you using your Elk M1XEP to send custom ASCII data via Elk M1 rules?

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          I am using the ELK to send some emails.

          But no other custom data.

          Thanks!

          Comment


          • #6
            Hi Philip,

            I'll need to see the debug output that includes the log errors you are referring to. Please use these instructions: https://forums.homeseer.com/showthread.php?t=130803

            Regards,
            Ultrajones
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Log has been sent - Thanks!

              Comment


              • #8
                Hi,

                I reviewed the logs. They show your Elk M1XEP quit sending data and the watchdog timer reconnected the plug-in to your Elk M1XEP. That was the only error/warning in the log you sent. From your HomeSeer system, try sending a few thousand ICMP pings to your Elk M1XEP to see if you're getting any packet loss.

                Launch the command prompt with admin privileges, then run:

                ping -c 2500

                The results should show 0 packet loss with latency less than 100.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment

                Working...
                X