Announcement

Collapse
No announcement yet.

Update to 3.0.6551.16372 and plug-in keeps crashing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Its only been 2 hours since I found how to disable Defender AV via local GPO on Windows 10, but in that time I have had ZERO errors logged by the plugin, and HS3 is seeing Elk zone status changes within seconds.

    I'm going to have to leave it a few days before I call it, but it looks initially like the problem is/was actually the Windows Defender AV service consuming excessive CPU cycles. This would have been introduced with the Winblows updates that occurred at around the same time I updated the plugins.

    Will update in a few days, but so far, looks good.......

    Comment


    • #32
      howdy,
      it looks like geodemtia is on to something here i disabled windows defender and installed another antivirus program and all of the com problems disappeared log looks normal now

      Comment


      • #33
        I can now confirm the same as the others! It seems to be Microsoft Security Essentials that was causing my warnings as well! Even though the CPU on MSE was zero, it still seemed to mess with the UltraM1G Plugin when it comes to the communication over the network. Once I removed Microsoft Security Essentials, I have not gotten a single warning from the UltraM1G Plugin.

        I will try a different AV solution and let you know what I find.

        Very strange!
        ---------------------------------------------------
        Jean-Marie G. Vaneskahian
        jean@vaneskahian.com
        ---------------------------------------------------

        Comment


        • #34
          Can someone point me in the right direction on how to remove Windows Security Essentials? I had tried turning it off in the security settings in the past and didn't notice any improvement.

          Now I tried disabling it in the Group Policies (gpedit.msc) and it seems to not be running, but I am still getting the errors.

          Maybe I need to completely uninstall it?

          Marty
          iCore5 Win 10 Pro x64 SSD

          HS3 Pro Edition 3.0.0.435 Windows

          BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

          Comment


          • #35
            I just completely uninstalled it
            ---------------------------------------------------
            Jean-Marie G. Vaneskahian
            jean@vaneskahian.com
            ---------------------------------------------------

            Comment


            • #36
              Yep - several reboots of the windows host and more than 36 hours later, still no errors and the M1G plugin is performing perfectly. So, I'm going to call this one solved, but still curious as to WHY the windows AV would be upset with the comms between the plugin and the M1G.

              Comment


              • #37
                Agreed, I see the same thing here. After 2 days not one single error or warning with UltraM1G Plugin after uninstalling Microsoft Security Essentials!

                I would never have figured that out given ZERO CPU consumed by MSE. Thank you!
                ---------------------------------------------------
                Jean-Marie G. Vaneskahian
                jean@vaneskahian.com
                ---------------------------------------------------

                Comment


                • #38
                  Originally posted by jeanv View Post
                  I just completely uninstalled it
                  When you say "just completely uninstalled it", how exactly did you do that? Are you running Windows 10? In which case it's supposed to be called Windows Defender.......as opposed to MSE. I can't find any guides on the web other than how do disable it.
                  iCore5 Win 10 Pro x64 SSD

                  HS3 Pro Edition 3.0.0.435 Windows

                  BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                  Comment


                  • #39
                    To disable Windows Defender - Virus scan
                    start menu -> search bar -> type "security"
                    choose Windows Defender Security Center
                    click on Virus & Threat
                    add and exclusion -> your HS3 folder (probably c:\Program Files\HS3) or something similar
                    Should do the trick
                    If not, disable virus protection and install Sophos home edition it works well for me!
                    Thanks to all of your digging I probably saved a couple of hours of debugging!

                    Comment


                    • #40
                      I found this one and disabled via GPO...

                      https://www.ghacks.net/2015/10/25/how-to-disable-windows-defender-in-windows-10-
                      permanently/

                      On my system it's actually under Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Defender Antivirus > Real-time Protection: Turn off real-time protection = Enabled

                      Comment


                      • #41
                        So I disabled windows Defender are per geodementia's instructions and the frequency of checksum errors has dropped significantly but I still get a few:

                        Feb-10 4:59:31 AM Warning Invalid checksum 64 for command PC as data I100
                        Feb-10 4:59:31 AM Warning Raw data was: 0BPCI1000100

                        So not completely solved in my opinion.

                        Did you guys also turn off all firewalls? I'm very reluctant to run a server without any firewalls.
                        iCore5 Win 10 Pro x64 SSD

                        HS3 Pro Edition 3.0.0.435 Windows

                        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                        Comment


                        • #42
                          I did have firewalls disabled whist trying to figre it out, but have since re-enabled them without incident. I was not getting the specific checksum errors though, I suspect my issue was the 'no comms' rather than the 'invalid data' scenario.

                          Cheers,
                          Geoff

                          Comment


                          • #43
                            Hi Ultra,
                            I am still trying to fix these checksum errors. I have tried several different DB9 cables, including shielded and with RF suppressors.
                            It's a bit of a problem as often devices (like lights) don't turn on due to these errors. I think these errors resulted in out pool pump running the whole night once.

                            Can you please tell what the checksum formula is so that I can verify if the errors are coming from the M1G itself, or the C-Bus board, or the plugin? It would really help with fault finding.

                            May-10 1:05:28 PM Warning Raw data was: 0BPCO20010B9
                            May-10 1:05:28 PM Warning Invalid checksum 0 for command PC as data O200
                            May-10 12:59:25 PM Warning No response/improper response from Elk M1 to command 'az00'
                            May-10 12:59:23 PM Warning Raw data was: 0BPCN1521103
                            May-10 12:59:23 PM Warning Invalid checksum 80 for command PC as data N152
                            May-10 12:59:23 PM Warning No response/improper response from Elk M1 to command 'az00'
                            iCore5 Win 10 Pro x64 SSD

                            HS3 Pro Edition 3.0.0.435 Windows

                            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                            Comment

                            Working...
                            X