Announcement

Collapse
No announcement yet.

No change in Area Current Alaram State

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No change in Area Current Alaram State

    UJ:

    Forgive me if this is known behavior, but,

    This past weekend, one of the water sensors tied to my M1 (under a sink) detected a water leak and shut the main water OFF - so that was good!

    BUT --

    I didn't get any notice of the Water Alarm other than from the M1 itself; the HS3 Event I wrote to notify me via email and text did not do anything. The event was looking for a change in state of Area 1's AreaStatus 03 [Area 1 Current Alarm State]. Just to see if this was a fluke, tonight I disabled the UltraM1G3 plugin, power cycled the M1 and re-enabled the plugin; then I intentionally made one of the water sensors "fire up". The M1 responded as it should. As you can see from the HS3 screen snippet below, the UltraM1G3 plug-in is getting some indication of the activity because it shows up in the LOG tab of the plugin:

    Click image for larger version

Name:	Elk M1 Log at UltraM1G3.PNG
Views:	1
Size:	14.8 KB
ID:	1211996

    But the Area 1 AreaStatus 03 did not change. What am I doing wrong? I would think that status field/device would change whenever there is an alarm. I'm running version 3.0.6551.16372 of the plugin on Ubuntu Linux 16.04 LTS. Any help / guidance would be much appreciated.

    Regards,
    BBB
    Last edited by BigBadBuzz; March 8th, 2018, 09:04 AM.

  • #2
    Difficult to see what is going on without seeing how you have set up the event.

    But does the event trigger with other types of alarm status?

    M
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

    Comment


    • #3
      U.J. :

      Okay, so here is the simple event for notifying when there is a water alarm:

      Click image for larger version

Name:	Inked Water Alarm Event.jpg
Views:	1
Size:	107.3 KB
ID:	1195134

      What I'm seeing is that device AreaStatus 03 [Area 1 Current Alarm State] only seems to only ever be set to one the first two values - either "No Alarm Active" or "Entrance Delay is Active". (I wrote another event to send me a text whenever the value changes) It doesn't change when the water alarm is triggered. Sure, I could change the event so that it triggers whenever any of the water sensor zones are violated, but what fun is there in that? Is there a limitation in which of the status values the plugin actually recognizes?

      BBB

      Comment


      • #4
        That is weird.

        I have a similar script for when Area01 changes to Burglar Alarm. I works flawlessly.

        Have you tried rebuilding existing devices in the options tab of the plugin. Not sure if this will issue new device references though. I assume you checked the 'Status Graphics' of AreaStatus to make sure all those values exist.

        Sounds like you need some input from UltraJones.
        iCore5 Win 10 Pro x64 SSD

        HS3 Pro Edition 3.0.0.435 Windows

        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

        Comment


        • #5
          I almost have my spare M1 up and functional allowing me to test this without impacting my own home security. Please give me until Sunday so I can duplicate this. In the meantime, can you provide details of how you have the water zone configured in the M1?

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            UJ:

            Sure -- 3 of the 4 zones assigned to Water Alarm are wireless (via GE compatible M1XRFEG at the Elk and Resolution Products transmitters at the potentially wet places), and one is wired to the Main Board. Here is what ElkRP shows for Zone 17, the one that caused the M1 to indicate a Water Alarm (oof, what a way to be awakened on a weekend morning!) last week:

            Click image for larger version

Name:	Zone_17_Setup_ElkRP.JPG
Views:	1
Size:	40.4 KB
ID:	1195139

            When I don't end up waking the grumpy teenager, I'll try setting off the alarm at the wired sensor, just to see if that makes any difference.

            Regards,
            BBB

            Comment


            • #7
              I set off the water alarm via the hardwired sensor - there was no difference in behavior compared to the wireless water sensors -- i.e., UltraM1G3 does not report the water alarm.

              BBB

              Comment


              • #8
                Is there any other information you need?

                Regards,
                BBB

                Comment


                • #9
                  Hi BBB,

                  I started investigating but didn't have a spare zone to test with. I had to order a battery for my spare sensor. It will arrive Monday.
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #10
                    Have rebooted my HS3 server and the M1 a few times in the interim - the behavior is still the same.

                    BBB

                    Comment


                    • #11
                      U.J. :

                      Any update on this? The system behaves as if some alarms are passed on to HomeSeer (e.g., Burglar), and some are not (e.g., Water)...

                      Regards,
                      BBB

                      Comment


                      • #12
                        This is a confirmed bug. I am fixing it now and will post the update soon.

                        Regards,
                        Ultrajones
                        Last edited by Ultrajones; May 6th, 2018, 04:22 PM.
                        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                        Comment


                        • #13
                          The issue you reported was fixed. Please download UltraM1G3 HSPI version 3.0.6700.37439 or later.

                          Regards,
                          Ultrajones
                          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                          Comment


                          • #14
                            I now see water alarms come through to HomeSeer with the .37439 version of the plugin. Thanks!

                            BBB

                            Comment

                            Working...
                            X