Announcement

Collapse
No announcement yet.

UltraM1G3 and UltraHTDAudio3 Re-Enables HS Voice command On Every Startup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UltraM1G3 and UltraHTDAudio3 Re-Enables HS Voice command On Every Startup

    I have every device disabled to HomeSeer's "Voice Command" except those I want controlled via voice (Alexa). Every time both UltraM1G3 and UltraHTDAudio3 both start up, they re-enable HomeSeer's "Voice Command" on SOME of the devices that they control.
    • In the case of UltraM1G3, it seems to be the "Elk M1 Connection" device (Even after I turn off the "Rebuild Existing Devices" in the options menu)
    • In the case of UltraHTDAudio3, it seems to be the "HTD AudioZone Source" devices
    I wrote an ASPX web page to go find all the HS Voice Enabled devices and these come back after every HS restart.

    Click image for larger version

Name:	Screenshot_2018-10-29_10-42-29.png
Views:	42
Size:	38.9 KB
ID:	1255930
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

  • #2
    As you can see, when the plug-in restarts and voice enables some of the devices it creates these now end up in the Amazon Alexa list of controllable devices. I can disable the voice control, but it then re-added when HomeSeer restarts.

    Click image for larger version

Name:	Screenshot_2018-10-29_16-02-58.png
Views:	26
Size:	177.3 KB
ID:	1256009
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

    Comment


    • #3
      Ultra, can I please get an update on this? Every time I restart HomeSeer, these two plugins I got from you update some of their devices as being voice enabled as I stated back on October 29th.
      ---------------------------------------------------
      Jean-Marie G. Vaneskahian
      jean@vaneskahian.com
      ---------------------------------------------------

      Comment


      • #4
        Hello Ultra? I opened this issue over a month ago... You mentioned a month ago that you would update the code for but I have not heard anything back. Can you please give me a status update?
        ---------------------------------------------------
        Jean-Marie G. Vaneskahian
        jean@vaneskahian.com
        ---------------------------------------------------

        Comment


        • #5
          Originally posted by jeanv View Post
          Hello Ultra? I opened this issue over a month ago... You mentioned a month ago that you would update the code for but I have not heard anything back. Can you please give me a status update?
          Try sending a problem report to his email .

          ultrajones@hotmail.com


          Sent from my iPhone using Tapatalk

          Comment


          • #6
            I will try that... It is odd in that I see that he had recent posts in the forums. Not sure what is going on. He is usually responsive.
            ---------------------------------------------------
            Jean-Marie G. Vaneskahian
            jean@vaneskahian.com
            ---------------------------------------------------

            Comment


            • #7
              jeanv Hi Jean, would you mind showing us how your ASPX page works?
              I am trying to find a way of getting a list of all devices with 'voice control' enabled. I am just in the process of playing with Google Home and would like to be able to tidy up the voice controlled device.
              Marty
              iCore5 Win 10 Pro x64 SSD

              HS3 Pro Edition 3.0.0.435 Windows

              BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

              Comment


              • #8
                Sure.. I actually posted the code for this for others to use. The problem is with the crappy ASPX processing of HomeSeer 3. It will sometimes hang HS3 and you have to restart HS3. I posted asking about this problem and I was told basically just not to use ASPX. For the few times I need to cleanup, it work though... Here is the posting:

                https://forums.homeseer.com/forum/de...nabled-setting
                ---------------------------------------------------
                Jean-Marie G. Vaneskahian
                jean@vaneskahian.com
                ---------------------------------------------------

                Comment


                • #9
                  jeanv Hi Jean, that script worked a treat. Thanks so much. Marty.
                  iCore5 Win 10 Pro x64 SSD

                  HS3 Pro Edition 3.0.0.435 Windows

                  BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                  Comment


                  • #10
                    I am glad it worked! I use it quite a bit to keep my devices clean from being voice activated. It does hang on me from time to time simply because it is ASPX. Even the simplest ASPX page will hang on HS3. I wish they would fix it. Also, why does HS3 default to voice enabling EVERY NEW device by default? Why not give the user the option rather than after the fact cleanup.
                    ---------------------------------------------------
                    Jean-Marie G. Vaneskahian
                    jean@vaneskahian.com
                    ---------------------------------------------------

                    Comment

                    Working...
                    X