Announcement

Collapse
No announcement yet.

ELK M1G firmware upgrade and UltraM1G cannot set alarm?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ELK M1G firmware upgrade and UltraM1G cannot set alarm?

    I recently upgraded my Elk Firmware to 5.3.10 and I cannot set the alarm in the Area. I can disabled the alarm okay but I cannot set it. I tried to rekey in password on the Area setting in UltraM1G and that did not work.

    I am current using the following versions below.
    Elk M1G 5.0.32.0
    Main Program ELRP2 2.0.34
    UltraM1G 3.0.6020.17037
    Status connection - Ok
    M1G firmware 5.3.10

    Let me know what I need todo to get UltraM1g to set the alarm working again.

    Thanks
    James

  • #2
    If I recall correctly, you cannot arm your system from the plug-in when there is a zone violated. Can you double-check to make sure no zones are violated before you attempt to arm up your system?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Guys,

      I had the same issue as I updated M1G firmware 5.3.10 today.

      It turns out (for me) that somehow my arm/disarm code hade been blanked out in the UltraM1G/Area screen. I re-added it and now it is fine.

      I only had this issue on my production (home) system. It did not occur on my Dev (office) system.

      The other thing (relating to Ultra's comment about violated zones) is that if you are using wireless zones, they report as violated after firmware updates (or power cycling) until all the devices report in on their supervisory cycle OR when manually triggered (e.g. open the door, test the smoke alarm, etc.). You can see this on the panel. On my system it takes a couple of hours for everything to report in.

      Hope that helps.

      Regards,
      Vector

      Comment


      • #4
        I checked all the zones and they are in normal position. I don't use the wireless in the Elk system. I did rekey the password in the area position and the alarm still will not set? I can disable it but cannot set it?

        Help

        Thanks

        James

        Comment


        • #5
          James,

          I am far from an expert but have been using this for a while now. Some other things to check just as part of a normal troubleshooting process:

          1. What is the HomeSeer log telling you? You should be seeing something like:
          <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateLong LogDateTime0" style="WHITE-SPACE: nowrap" align=left>Oct-30 8:11:35 PM </TD> <TD class=LogPri0 align=left></TD> <TD class=LogType0 colSpan=3 align=left>Informational </TD> <TD class=LogEntry0 colSpan=8 align=left>Area 1 was armed by HomeSeer on Sunday, October 30, 2016 at 8:11:00 PM </TD></TR></TBODY></TABLE> <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateLong LogDateTime1" style="WHITE-SPACE: nowrap" align=left>Oct-30 8:11:34 PM </TD> <TD class=LogPri1 align=left></TD> <TD class=LogType1 colSpan=3 align=left>Device Control </TD> <TD class=LogEntry1 colSpan=8 align=left> Device: Elk M1 Area UltraM1G3 Plugin Area 01 [Main House] to Disarmed (1) by/from: CAPI Control Handler


          </TD></TR></TBODY></TABLE>
          If you are not seeing anything the log, go into UltraM1G Plugin/Options and set Write to HomeSeer Log to YES and Logging Level Informational, then restart HomeSeer and try it again. You should be seeing Something in the log. They way I do these troubleshooting processes is to have two browser windows open - One showing the log with Autoupdate checked, and the other on devices so I can make the change and immediately see what is showing in the log.

          2. If you still don't see anything in the log, you might try setting logging level to Debug and do it again.


          I know this wont solve your problem but maybe help you get to the root cause.

          Regards,
          Vector

          Comment


          • #6
            PS

            You should see something like this image below in your devices. If not go into UltraM1G plugin and check the appropriate items to create those devices so you can see that:
            1. You are in Ready to Arm state
            2. You should be able the see the transition to "Armed with Exit Timer working", and then "Armed Fully" if all is working right.

            Regards,
            Vector
            Attached Files

            Comment


            • #7
              Hi Victor,

              I tried setting the logging level to informational and debug and all I get is this message below when changing the status from "Disarmed" to "Arm Away"

              Nov-01 5:51:02 PM Informational Access keypad 01 by James on Tuesday, November 01, 2016 at 5:51:00 PM

              I shutdown the HS3 and startup the ELKRP2 software and created a rule to set the "Arm Away" at 6:04pm and it worked so that proves that all the zones were normal.
              I got a message in the ERKRP2 log that shows 1172 - Area Armed and the Extended data shows "No Code" User (203).
              Does this might have something to do with not setting the "Arm Status" in HS3?

              Thanks

              Comment


              • #8
                Can anyone help me on this? I need to get my system working again.

                Thanks

                James

                Comment


                • #9
                  Can you take a screenshot of the same devices I showed? Create them if needed. I think you still need to figure out what HS thinks is happening.


                  You are trying to infer what the Arm up state is when you can see it directly on the devices I mentioned OR on the UltraM1G/Areas Tab as shown below (this is just a cut/paste - not a screen image)

                  <TABLE cellSpacing=0 width="100%"> <TBODY> <TR> <TD class=tablecolumn>Area #</TD> <TD class=tablecolumn>Name</TD> <TD class=tablecolumn>Arming Status</TD> <TD class=tablecolumn>Arm Up State</TD> <TD class=tablecolumn>Current Alarm State</TD> <TD class=tablecolumn>HomeSeer Device <INPUT title="Check/Uncheck All" type=checkbox></TD> <TD class=tablecolumn>Arm/Disarm Code</TD></TR> <TR> <TD class=tablecell>01</TD> <TD class=tablecell>Main House</TD> <TD class=tablecell>Disarmed</TD> <TD class=tablecell>Ready To Arm</TD> <TD class=tablecell>No Alarm Active</TD> <TD class=tablecell><INPUT disabled CHECKED type=checkbox value=01 name=chkAddArea></TD></TR></TBODY></TABLE>
                  The fact that disarm works suggests that it is not really in Ready To Arm State.

                  Regards,
                  Vector

                  Comment


                  • #10
                    Have you looked at the User in the ElkRP application to confirm the user has the Arm checkbox checked under "User Authorizations?
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • #11

                      Comment


                      • #12
                        James,

                        Sorry, but I have exhausted my ideas. I think Ultra is going to have to figure this one out.

                        Regards,
                        Vector

                        Comment


                        • #13
                          UltraJones,

                          Can you help me resolve this issue? Is there any print screen that I need to show you or logs to help you diagnose the problem? I have been working on this for 3 weeks now trying all scenario which does not allow me to set the alarm in your app. I can disable the arm though.

                          Thanks for your support.

                          James

                          Comment


                          • #14
                            James,

                            I am not sure what state the firmware upgrade left your Elk M1 in. Can you try creating a new user, then see if that code works?

                            Regards,
                            Ultrajones
                            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                            Comment


                            • #15
                              I was looking to upgrade the firmware on my Elk M1 to see if I could duplicate the issue you reported, but cannot because I have the ELK-M1XRF2G Wireless Receiver which isn't compatible with 5.3.10. It looks like I need to upgrade my ELK-M1XRF2G to an ELK-M1XRFEG.

                              Anyway, were you able to create a new user to determine if the code from a newly created user allows you to arm/disarm your system?

                              Regards,
                              Ultrajones
                              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                              Comment

                              Working...
                              X