Announcement

Collapse
No announcement yet.

HS3-Linux Beta plugin install issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3-Linux Beta plugin install issue

    I've been evaluating HS3 on Linux (Raspberry Pi). When installing Vista Alarm BETA 3.0.0.38, following errors appear in log and installation is incomplete.

    Code:
    Sep-12 10:33:39 PM           Updater     Error, package file not found: /opt/HomeSeer/Updates3/Vista AlarmBETA 3.0.0.38/Question.png
    Sep-12 10:33:39 PM           Updater Error     Installation of package Vista Alarm failed. Try disabling the plugin first, then re-try the update.
    Sep-12 10:33:39 PM           Updater     Install/Update of package Vista Alarm failed.
    Contents of installer archive:
    Code:
    $ unzip -l HSPI_VistaAlarm_3.0.0.38.zip
    Archive:  HSPI_VistaAlarm_3.0.0.38.zip
      Length      Date    Time    Name
    ---------  ---------- -----   ----
       195072  05-07-2018 08:58   HSPI_VistaAlarm.exe
        70656  08-04-2012 23:01   FTD2XX_NET.dll
          407  03-30-2015 12:56   install.txt
            0  01-12-2016 17:55   html/images/
            0  01-12-2016 17:55   html/images/vistaalarm/
         5760  12-28-2013 15:30   html/images/vistaalarm/alarm.png
         5014  12-28-2013 14:04   html/images/vistaalarm/alert.png
         4345  12-28-2013 15:05   html/images/vistaalarm/disabled.png
         1620  12-28-2013 14:14   html/images/vistaalarm/lowbat.png
         5196  12-28-2013 14:06   html/images/vistaalarm/normal.png
         6820  04-30-2010 17:42   html/images/vistaalarm/pik2.gif
         2383  12-28-2013 14:10   html/images/vistaalarm/question.png
         4888  12-28-2013 14:11   html/images/vistaalarm/warning.png
            0  01-12-2016 17:55   html/vistaalarm/
        20072  03-19-2012 12:28   html/vistaalarm/VistaAlarmHelp.htm
    ---------                     -------
       322233                     15 files
    install.txt contents:
    Code:
    HSPI_VistaAlarm.exe,.,0
    FTD2XX_NET.dll,.,16
    alarm.png,.\html\images\vistaalarm,16
    alert.png,.\html\images\vistaalarm,16
    disabled.png,.\html\images\vistaalarm,16
    lowbat.png,.\html\images\vistaalarm,16
    normal.png,.\html\images\vistaalarm,16
    pik2.gif,.\html\images\vistaalarm,16
    Question.png,.\html\images\vistaalarm,16
    warning.png,.\html\images\vistaalarm,16
    VistaAlarmHelp.htm,.\html\vistaalarm,0
    Note case mismatch "question.png" in HSPI_VistaAlarm_3.0.0.38.zip vs. "Question.png" in install.txt.

    question.png, warning.png and the help file don't get installed. I don't see anything wrong with the last two entries, but perhaps the install aborts at the error on question.png.

    Further note, the stable release installer doesn't have the issue. So a fix is to install the stable first, then update to the Beta.

  • #2
    Thanks for posting the issue

    I updated the install.txt file in the 3.0.0.38 beta version. i didn't update the version number since i only changed the installation.

    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      Great - verified it now installs cleanly. Thanks!

      Comment


      • #4
        David,
        would you mind installing the latest vista alarm beta and reporting back about the installation.

        functionally its the same as.38, i just moved the FTDxxx.dll to the bin/vistaalarm directory during the installation

        i wanted to make sure its working in linux before i release the version
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #5
          Hi Mark, just tested and all looks good.

          I deleted FTD2XX_NET.dll from the root before installing. After install FTD2XX_NET.dll is living in bin/vistaalarm/ sub folder as expected and absent from the root.

          I reconfigured the AD2USB from my primary (Windows) system and enabled the plugin. Everything worked as expected. I verified that opening a door caused a fault to appear as it should.

          Comment


          • #6
            Originally posted by zwolfpack View Post
            Hi Mark, just tested and all looks good.

            I deleted FTD2XX_NET.dll from the root before installing. After install FTD2XX_NET.dll is living in bin/vistaalarm/ sub folder as expected and absent from the root.

            I reconfigured the AD2USB from my primary (Windows) system and enabled the plugin. Everything worked as expected. I verified that opening a door caused a fault to appear as it should.
            Thanks for testing and reporting back.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment

            Working...
            X