Announcement

Collapse
No announcement yet.

New install loads and shows status, but won't arm/disarm from device page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New install loads and shows status, but won't arm/disarm from device page

    moved houses and set this up again. Have a 20p panel, config'd through putty for keypad address 18 (per alarm company).

    installed PI, and it came in perfectly. Set security code and interface address as 18.

    In partitions, set P1 device address as 18, and user code same as the security code.

    saved all.

    if I arm/disarm from the actual panel, it shows immediately. but if I try to arm/disarm, nothing happens,. Here's what the debug log shows:
    Sep-05 10:04:52 AM Vista Alarm MessageKey=ARMED ***STAY*** 1
    Sep-05 10:04:43 AM Vista Alarm 0383797,84
    Sep-05 10:04:42 AM Vista Alarm [0010000100000000----],008,[f72000ff1008008c08020000000000],"ARMED ***STAY*** "
    Sep-05 10:04:42 AM Vista Alarm Processing msg on Partition 1
    Sep-05 10:04:42 AM Vista Alarm MessageKey=ARMED ***STAY*** 1
    Sep-05 10:04:38 AM Vista Alarm !Sending.done
    Sep-05 10:04:37 AM Vista Alarm Sending [code]+1
    Sep-05 10:04:37 AM Device Control Device: Vista Alarm Alarm Partition 1 Status to Disarm (101) by/from: CAPI Control Handler
    Sep-05 10:04:32 AM Vista Alarm [0010000100000000----],008,[f72000ff1008008c08020000000000],"ARMED ***STAY*** "
    Sep-05 10:04:32 AM Vista Alarm Processing msg on Partition 1
    Sep-05 10:04:32 AM Vista Alarm MessageKey=ARMED ***STAY*** 1
    Sep-05 10:04:23 AM Vista Alarm [0010000100000000----],008,[f72000ff1008008c08020000000000],"ARMED ***STAY*** "
    Sep-05 10:04:23 AM Vista Alarm Processing msg on Partition 1
    Sep-05 10:04:23 AM Vista Alarm MessageKey=ARMED ***STAY*** 1
    Sep-05 10:01:38 AM Z-Wave Device: Great Room Audio/Visual kW Hours Set to 0.238 (0.238 kW Hours)
    Sep-05 9:59:40 AM Vista Alarm Sending Disarm command to alarm
    Sep-05 9:59:40 AM Device Control Device: Vista Alarm Alarm Partition 1 Status to Disarm (101) by/from: CAPI Control Handler
    Sep-05 9:59:26 AM Vista Alarm ARMED ***STAY***

    Maybe I don't have an unused keypad address?

    #2
    i believe the ad2usb needs to be on its own keypad address. this must be setup in the panel programming
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Originally posted by mnsandler View Post
      i believe the ad2usb needs to be on its own keypad address. this must be setup in the panel programming
      yeah... did that. but looks like 18 was taken. tried 16 and all is good now.

      remind me why the dupe partition. so i have two rows (system status and partition 1 status) that are the same? seem to remember just hiding one if it bugs me?

      Comment


        #4
        for a single partition system, system status and partition 1 status are going to be the same. for a multi-partition system they could be different. to keep things simple i use the same logic for a single and multi-partition setup.

        you can hide the partition 1 devices.
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment

        Working...
        X