Announcement

Collapse
No announcement yet.

Roll back to previous version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roll back to previous version

    Hello,

    I recently updated and was having an issue where zones that would be faulted would clear to normal when other zones were faulted even though they were actually still faulted, I updated to the latest beta and it no longer does that but now if one zone is faulted another zone will stay normal even if it is actually faulted. I apologize that i do not have any version numbers that i updated to along the way but right now I am on the current beta (3.0.1.5)

    looking back though some saved backup logs it looks like I was on 3.0.0.15 for the longest time without this problem. is it possible to roll back to that version or any idea why I'm seeing this behavior with the current versions?

    thanks

  • #2
    I can post any old version you want. 3.0.0.15 was from May 2015.

    can you describe your alarm setup? what model panel? how many partitions? and the steps i can follow to try to reproduce the problem

    Mark

    HS3 Pro 3.0.0.435
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      It's a adt branded vista 15p, one partition. zone one is fire and the other zones are door, and one motion sensor. i have updated the ad2usb to the latest firmware as well

      thanks

      Comment


      • #4
        thanks. and can you tell me the steps that cause the problem so i can repeat it
        Mark

        HS3 Pro 3.0.0.435
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #5
          So right now I'm on the current beta 3.0.1.5, here is my situation. if my front door is open the zone reports faulted as normal, if I open my garage door while the front door is faulted it does not report on home seer but i can see on the keypad that it is faulted. also if the front door is open and i walk past one of the pir sensors it faults but also the front door goes back to normal and then back to fault all while open, during this whole time the garage door was open and not shiowing up faulted, as soon as I close the front door and it goes normal the garage door then goes faulted. its all working correctly if only one zone is faulted at a time, if more then one zone is faulted it acts odd.

          frontdoor is zone 02
          garage door is 03
          pir is 06

          I hope that makes sense, thanks for looking into

          Comment


          • #6
            this sounds like a typical scenario. can you check the timeout setting on the config page. you might increase it a few seconds
            Mark

            HS3 Pro 3.0.0.435
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #7
              Timeout was set for 10 seconds, just tried 13 and then 15 and doesn't seem to make any difference.

              Comment


              • #8
                can you enable debug mode, run your scenario and post the log of the transactions
                Mark

                HS3 Pro 3.0.0.435
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • #9
                  Will do, I'm gone for the weekend I will do Monday, thanks again for your help

                  Comment


                  • #10
                    Here ya go, hopefully you can make sense of it, the garage door doesn't show up faulted in the log until the front door is closed and returns to normal

                    Oct-14 5:49:46 PM Vista Alarm Setting System to Disarmed-Ready
                    Oct-14 5:49:46 PM Vista Alarm MessageKey=****DISARMED**** Ready to Arm 1
                    Oct-14 5:49:46 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:49:46 PM Vista Alarm [10000001000000003A--],008,[f700000f1008001c08020000000000],"****DISARMED**** Ready to Arm "
                    Oct-14 5:49:46 PM Vista Alarm Zone changed. Set device Vista Zone 6 to Value=Normal
                    Oct-14 5:49:46 PM Vista Alarm Zone changed. Set device Vista Zone 3 to Value=Normal
                    Oct-14 5:49:46 PM Vista Alarm Setting Partition 1 to Disarmed-Ready
                    Oct-14 5:49:46 PM Vista Alarm Clearing all zones for Ready mode.
                    Oct-14 5:49:03 PM Vista Alarm MessageKey=FAULT-3
                    Oct-14 5:49:03 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:49:03 PM Vista Alarm [00000001000000000A--],003,[f700000f1003000008020000000000],"FAULT 03 GARAGE DOOR "
                    Oct-14 5:49:00 PM Vista Alarm Zone changed. Set device Vista Zone 2 to Value=Normal
                    Oct-14 5:49:00 PM Vista Alarm Updated Cleared Zones, System is Faulted
                    Oct-14 5:49:00 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:49:00 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:49:00 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:56 PM Vista Alarm Zone changed. Set device Vista Zone 3 to Value=Fault
                    Oct-14 5:48:56 PM Vista Alarm MessageKey=FAULT-3
                    Oct-14 5:48:56 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:56 PM Vista Alarm [00000001000000000A--],003,[f700000f1003000008020000000000],"FAULT 03 GARAGE DOOR "
                    Oct-14 5:48:54 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:48:54 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:54 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:26 PM Vista Alarm MessageKey=FAULT-2
                    Oct-14 5:48:26 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:26 PM Vista Alarm [00000001000000000A--],002,[f700000f1002000008020000000000],"FAULT 02 FRONT DOOR "
                    Oct-14 5:48:24 PM Vista Alarm 0363149,00 received from Downstairs Honeywell Motion RF
                    Oct-14 5:48:24 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:48:24 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:24 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:22 PM Vista Alarm MessageKey=FAULT-2
                    Oct-14 5:48:22 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:22 PM Vista Alarm [00000001000000000A--],002,[f700000f1002000008020000000000],"FAULT 02 FRONT DOOR "
                    Oct-14 5:48:20 PM Vista Alarm 0363149,80 received from Downstairs Honeywell Motion RF
                    Oct-14 5:48:20 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:48:20 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:20 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:16 PM Vista Alarm Zone changed. Set device Vista Zone 2 to Value=Fault
                    Oct-14 5:48:16 PM Vista Alarm MessageKey=FAULT-2
                    Oct-14 5:48:16 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:16 PM Vista Alarm [00000001000000000A--],002,[f700000f1002000008020000000000],"FAULT 02 FRONT DOOR "
                    Oct-14 5:48:16 PM Vista Alarm Setting System to Faulted
                    Oct-14 5:48:16 PM Vista Alarm Zone changed. Set device Vista Zone 6 to Value=Fault
                    Oct-14 5:48:16 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:48:16 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:16 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:15 PM Vista Alarm Setting Partition 1 to Faulted
                    Oct-14 5:48:12 PM Vista Alarm MessageKey=****DISARMED**** Ready to Arm 1
                    Oct-14 5:48:12 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:12 PM Vista Alarm [10000001000000003A--],008,[f700000f1008001c08020000000000],"****DISARMED**** Ready to Arm "
                    Oct-14 5:48:12 PM Vista Alarm Zone changed. Set device Vista Zone 6 to Value=Normal
                    Oct-14 5:48:12 PM Vista Alarm Setting System to Disarmed-Ready
                    Oct-14 5:48:12 PM Vista Alarm Setting Partition 1 to Disarmed-Ready
                    Oct-14 5:48:12 PM Vista Alarm Clearing all zones for Ready mode.
                    Oct-14 5:48:08 PM Vista Alarm Zone changed. Set device Vista Zone 6 to Value=Fault
                    Oct-14 5:48:08 PM Vista Alarm MessageKey=FAULT-6
                    Oct-14 5:48:08 PM Vista Alarm Processing msg on Partition 1
                    Oct-14 5:48:08 PM Vista Alarm [00000001000000000A--],006,[f700000f1006000008020000000000],"FAULT 06 MOTION SENSOR "
                    Oct-14 5:48:08 PM Vista Alarm Setting System to Faulted
                    Oct-14 5:48:08 PM Vista Alarm Setting Partition 1 to Faulted
                    Oct-14 5:48:00 PM Vista Alarm Entering HSEvent

                    Comment


                    • #11
                      Oct-14 5:48:56 PM Vista Alarm [00000001000000000A--],003,[f700000f1003000008020000000000],"FAULT 03 GARAGE DOOR "
                      The above entry seems to be the first time the ad2usb reports the garage door is faulted.if Zone 3 was already faulted but the ad2usb didn't report it then there is nothing the plugin can do.

                      do you have the ad2usb on its own key address separate from any physical keypad?

                      Did anything change related to the panel programming for zone 2 or 3?
                      Mark

                      HS3 Pro 3.0.0.435
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                      • #12
                        Yes it's on its own address. It's not just these zones having the issue, if any zone is faulted while another zone is in fault the plug-in will not report that zone until the first zone is cleared. I disabled the plug-in and opened the alarm decoder software and everything seems to report properly with that. I'll double check everything tonight in the panel to make sure keypad addresses are unique. I didn't have this issue when I was running the older version though which is odd.

                        Comment


                        • #13
                          Steve, normally when multiple zones are faulted, you will see the Fault messages frpm both zones in the log. I'm not seeing that in your log. the plugin needs these msgs from the ad2usb in order to process them.

                          can you generate an hs log that shows Zone 2 and 3 both Faulted and reporting to the plugin. capture the log for a few cycles of both fault msgs.
                          Mark

                          HS3 Pro 3.0.0.435
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                          • #14
                            When I was watching the log yesterday as soon as I faulted one zone the log just stopped and no further messages came through until I cleared that first zone, then a bunch of messages came in. It seems like if more then one zone is faulted it doesn't update. And maybe that is a issue with the ad2usb or how it's configured. I'll mess with it some more tonight

                            Comment


                            • #15
                              are you seeing the correct Fault msgs on your physical keypad?

                              you can also stop the plugin and use Putty to view the message coming from the adusb to verify the ad2usb is getting the msgs from the panel.

                              Mark

                              HS3 Pro 3.0.0.435
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X