Announcement

Collapse
No announcement yet.

Can't arm, disarm, etc. from home seer with vista alarm plug in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't arm, disarm, etc. from home seer with vista alarm plug in

    Installed AD2USB and vista alarm home seer plug in. I can see updated alarm system status on home seer. My zones all work and show. When I set alarm to alarm away using alarm keypad home seer updates system status with no problem. The problem is when I try to arm, disarm, stay, night stay, etc.. using homeseer it does nothing. For some reason I get all communications from panel but can't send a arm or disarm command from home seer. Some things I have noticed I also have alarm decoder setup on my home seer controller. I can effectively disarm, arm, etc, using alarm decoder keypad. However when vista alarm plug in is enabled hen my alarm decoder no longer works and continuously gets stuck trying to communicate to panel. I assume both vista plug in and alarm decoder are both on same COM.

    Please advise what I need to do to fix or figure out why I can't disarm, arm etc. using home seer device.

  • #2
    you can't have two different SWs controlling the same com port. Only one can open it at a time.

    did you enter user codes into the plugin config page, and partition page? these are both required
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      still not working

      so in plugin settings I have interface address as 18 which is what was in instructions for installing ad2usb from nutech. I installed alarm decoder keypad as well but do not have open since both plug in and alarm decoder keypad are on same COM5. I presume security code under plugin settings is the code I use to disarm and arm system? Under partition 1 I put 18 and its user code 01(different than my alarm passcode). 18 is address for new keypad that I created. Up till now Ive been able to see homeseer see up to date alarm panel status messages and and zone triggers have worked such as door fault has lights go on. However i can not get vistaplugin to allow me to arm or disarm system from device management page or HSTOUCH. Any idea what may be going on?

      Thanks
      Chris

      Comment


      • #4
        Sorry to resurect an old thread. However, all of the sudden I homeseer isn't sending command to the vista plugin although it is receiving all the faults, messages, etc. Anywhere I should start to try and figure this out? Thanks.

        Comment


        • #5
          stop the plugin monitor and start putty and see if you can send commands

          check the wiring between the ad2usb and the panel. maybe something came loose.
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


          • #6
            Originally posted by mnsandler View Post
            stop the plugin monitor and start putty and see if you can send commands

            check the wiring between the ad2usb and the panel. maybe something came loose.
            Thanks, I'll try those things when I get home. I'm using the serial connection but I don't think that would make a different because something still may have come loose. Can you direct me to the putty commands again? It's been awhile.

            Comment


            • #7
              Originally posted by jayman13 View Post
              Thanks, I'll try those things when I get home. I'm using the serial connection but I don't think that would make a different because something still may have come loose. Can you direct me to the putty commands again? It's been awhile.
              once you have a putty connection to the ad2usb, just enter numbers like you were at a keypad.

              checkout the https://www.alarmdecoder.com site to get details on putty
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


              • #8
                So I got in with putty and used the = command to reboot the adapter. I could then send commands. Now in homeseer I can use the plugin to send commands as well. Weird. Never had to do that before.

                Comment


                • #9
                  Originally posted by jayman13 View Post
                  So I got in with putty and used the = command to reboot the adapter. I could then send commands. Now in homeseer I can use the plugin to send commands as well. Weird. Never had to do that before.
                  yes strange. glad it was that easy. thanks for reporting back
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment

                  Working...
                  X