Announcement

Collapse
No announcement yet.

Plugin Hard Locks Server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin Hard Locks Server

    I am having an interesting issue with the Viata Alarm plugin

    HS3 Standard version 3.0.0.208 Linux
    Ubuntu 14.04.3 LTS
    Dedicated VM just for HomeSeer (meaning nothing else on it. Headless server)
    Using Insteon Plugin (not HS one)
    RFXCom
    Z-Wave (HS Included)
    Vista Alarm (purchased Though in trial until I get it working)

    When I initialize the plugin, it runs fine. I get panel updates and everything is working. After about 5 minutes, it hard locks my server. No kernel panic, no errors on the screen, nothing in the log that I can see (since i hard locks). Nothing in syslog after rebooting. I just hard locks. I have been messing with this for a few days now and can not find anything. CPU spikes to max and SSH session disconnects, and server console is locked, can not type anything.

    Anyone have any ideas?

    Thanks,
    Daniel

  • #2
    can tell me about how you have the ad2usb connected to the server

    can you enable debug mode and see if anything presents itself. if so, please post
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      I will turn on debug and see what happens. Do you know if there is a persistent log that is available post reboot? If it wipes the log when it comes back up, I will have no way to get to it.

      the AD2USB is plugged in via USB to a Rasberry Pi in my basement. That RPI is running a USB server called Virtual here. The Linux Server has a Virtual Here client on it that create a network USB connection that is a virtual redirection of the USB device, so it shows up on the linux server like it is plugged in directly.

      I have been using it this way on HS2 running on a Windows7 box for about 2 years without any issues, other than if the RPI reboots and I have to reconnect the client. The only change is that it is connected to the linux server now instead of the Windows7 box. I even tested connecting it back to the Windows 7 HS2 and it is running fine, so it is only on the HS3 on linux that this is happening.

      Comment


      • #4
        i think there is a BL plugin for reading the old log entries from the hs database. the plugin does not log anything to a file itself.
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #5
          So I am getting closer to getting some good data. Last hurdle. How do you enable developer mode on a linux box? I have a linux server running headless, and when I have the developer mode on, I am not sure how it is supposed to running them in different command windows? Is it using screen or semething I can jump into? I am not getting debugging information in the log, or on the console when ran manually, or in mono if I launch the plugin on the box. Any thoughts? I know on Windows, it launches a command prompt windows with the plugin running in it, but on linux, no idea where it goes.

          Thanks,

          Comment


          • #6
            Originally posted by GreatWhiteDan View Post
            So I am getting closer to getting some good data. Last hurdle. How do you enable developer mode on a linux box? I have a linux server running headless, and when I have the developer mode on, I am not sure how it is supposed to running them in different command windows? Is it using screen or semething I can jump into? I am not getting debugging information in the log, or on the console when ran manually, or in mono if I launch the plugin on the box. Any thoughts? I know on Windows, it launches a command prompt windows with the plugin running in it, but on linux, no idea where it goes.

            Thanks,
            with debug mode you should see raw msgs in the log from the ad2usb. i don't think you need developer mode in this case.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #7
              I wanted to thank you for your help. I was unable to resolve this, and went back to the windows version of HS3. The server would hard lock if I used the Vista plugin after 5-15 minutes and there was nothing in either the HS3 logs, the syslog, or outputted to the screen. I am going to assume it was an issue with Mono based on the evidence, just hard to believe that could happen in linux. I have rarely seen an issue that would hard lock linux without even a kernel panic, or some sort of information.

              Thanks again for your time.

              Comment


              • #8
                very strange. maybe a linux flavor issue. I pretty sure there are others running the plugin on linux without problems.
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment

                Working...
                X