Announcement

Collapse
No announcement yet.

HS3 Vista Alarm plugin v3.0.0.40 Beta (for Windows & Linux)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Vista Alarm plugin v3.0.0.40 Beta (for Windows & Linux)

    If you are upgrading, do the following:
    On the Partition and System Status devices change the value of Arm-Away Button to 106
    For Virtual Zone devices with a Fault button, change the Fault Button value to 111


    Changes
    - Allows you to rename the control buttons (Arm-Stay, Arm-Away, etc) after initial setup
    - Supports the !REL (relay) msgs from the AD2USB. See your panel manual for setting these up (3.0.0.24)
    - Register RF devices that aren't programmed into the panel (unassigned) (3.0.0.27)
    - Revised text formatting for Last Panel Message device (3.0.0.28)
    - Added some event Conditions (3.0.0.28)
    - Arm Stay, Arm Instant, and Arm Night Stay will update immediately; doesn't wait for countdown to reach zero (3.0.0.38)

    Fixes since 3.0.0.10
    - the RFX message processing to account for an invalid bit in the message (3.0.0.15)
    - the Vista Alarm config sections on the device edit page
    - saving changes on the Loop and Partition options (3.0.0.15)
    - Telco and comm failure status (3.0.0.17)
    - Bypass zones (3.0.0.20)
    - Bug related to clearing zones at startup (3.0.0.28)
    - Last Panel Message formatting that affected HSTouch (3.0.0.29)
    - Error related to Clearing faulted zones (3.0.0.33)
    - Vista 40 show faults (3.0.0.34)

    The plugin is available in the Beta section of the Updater. Use the Update Listing to refresh the list if it does not show.

    If this is your first time installing the plugin:
    4. Go to the Manage Plugin page
    5. Enable the plugin and set the Com Port to your AD2USB port
    6. Restart HS3 again if necessary
    7. You will need to enable the Monitor (device address Vista 1) to get things rolling.

    First time Setup:
    1. Once the plugin is running it will create 6 new devices. You can always delete them and restart HS3 to have them recreated.
    2. Configure your Partitions as before. You need to know the panel address typically 16 for a Vista 20p panel. Check your panel programming if you are unsure.
    3. Add your zones and RF devices as necessary
    4. Test and report back to this thread

    If you enabled Developer Mode on the Plugin Manage page, you will get a command window that will display the AD2USB messages. this might help with debugging or at least let you know the plugin is seeing panel msgs.
    Last edited by mnsandler; January 10th, 2019, 01:57 PM.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

  • #2
    It works! I can now change the Status values to single words and have Alexa recognize and execute the command. I cannot have any spaces or symbols in the Status text - Alexa doesn't recognize the command on the device. I don't think this is a problem with the Vista plugin, but rather with the Alexa integration with HS3. Thank you!!!

    Comment


    • #3
      Thanks for reporting back. I'm glad it was that easy.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


      • #4
        What happens if i don't change RF devices from Fault=2 to Fault=111 ?

        Comment


        • #5
          Originally posted by skarragallagher View Post
          What happens if i don't change RF devices from Fault=2 to Fault=111 ?
          the status tracking will be affected.
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


          • #6
            Hmmm need to change my hstouch project to match then

            Comment


            • #7
              I am assuming I have to change the status graphic as well?

              Comment


              • #8
                Originally posted by skarragallagher View Post
                I am assuming I have to change the status graphic as well?
                yes, good catch.
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • #9
                  Can you explain a bit more how I would use an RF device that didn't have a zone in the system?

                  Currently my wireless devices get assigned a zone in the vista 20p and homeseer. Once I have the zone created I can then add an RF device in homeseer as well.

                  Am I understanding correctly that I can use an RF device that doesn't require a zone in homeseer but still needs to be installed and configured in the vista 20p (code, type, zone type, loop etc.)

                  Comment


                  • #10
                    Originally posted by skarragallagher View Post
                    Can you explain a bit more how I would use an RF device that didn't have a zone in the system?

                    Currently my wireless devices get assigned a zone in the vista 20p and homeseer. Once I have the zone created I can then add an RF device in homeseer as well.

                    Am I understanding correctly that I can use an RF device that doesn't require a zone in homeseer but still needs to be installed and configured in the vista 20p (code, type, zone type, loop etc.)
                    Plugin "RF Devices" respond to RFX msgs from the ad2usb. These msgs are transmitted from the device regardless of the state of the panel or even if the device is programmed as a zone in the panel. They also transmit quicker when the sensor changes state.

                    So you can use them as wireless sensors in HS without affecting the panel. Some users register the RF Device for an associated motion sensor in order to capture motion even when the panel is armed. Others have setup wireless door sensors for internal doors and use the RF device feature just to capture status.

                    hope this helps
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                    • #11
                      I use both circumstances that you mentioned. I think that is great that the don't need to be even programmed into the panel

                      Comment


                      • #12
                        I have an issue. I upgraded to the beta and modified the RF devices for fault =111. Now the images that I have set dont get passed to the HStouch client

                        Notice in the second picture the garage door is fault but it just displays a white background.

                        Note that in hstouch for these elements I don't specify any collection images for the status tracking. Whatever I have set in the status graphics should get set.

                        My only thought is either I have configured something wrong or perhaps the plugin isn't setting it to 111 when faulted
                        Last edited by mnsandler; June 28th, 2016, 06:18 AM.

                        Comment


                        • #13
                          Here are a couple more pics. You can see I am running the beta and that there is no status graphic or text after changing to 111
                          Last edited by mnsandler; June 28th, 2016, 06:18 AM.

                          Comment


                          • #14
                            you are correct. the instructions for changing the value on RF device fault to 111 were incorrect. that was supposed to be for Fault button values only. i have updated the instructions.

                            change your fault status & graphic value back to 2
                            Last edited by mnsandler; June 28th, 2016, 09:05 AM.
                            Mark

                            HS3 Pro 3.0.0.534
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                            • #15
                              So I changed it back and everything works, however even after reading the updated instructions I am still unclear on what needs be changed to 111.

                              I don't seem to have any devices that have a buttons that say fault. Sorry not sure what I am missing here.

                              Comment

                              Working...
                              X