Announcement

Collapse
No announcement yet.

Add RF tab?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Add RF tab?

    Hi, I am finally getting around to integrating my Vista 21iP panel with my Hometroller S6, and its looking good. I'm running version 3.0.0.27 of the plugin.

    I have a couple of questions and minor issues, so I'll start with a simple one. What is the Add RF tab function? All my sensors are wireless and are working fine without filling this in. Not sure how the plugin could use the info anyway...

    Thanks

  • #2
    an RF plugin device will response to the !RFX msgs from the ad2usb. this can be useful for capturing events when the panel is armed.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      Ah, I see. I will fill those in. Thanks.

      Comment


      • #4
        Motion sensors are probably the only useful ones unless you have sensors that are not registered in the panel or are not part of the arm state.

        Is short. You don't need to register every rf device if you already have t added as a zone
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #5
          Small issue, with the RF devices entered, when I stop & restart the monitor via the Monitor status device, I get an error message for each zone, see attached. I think it still works though, so it may just be noise. No errors when stop and starting the plugin.
          Attached Files

          Comment


          • #6
            thanks for the log. I'll fix this issue.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #7
              Missed you previous post. Based on that, I deleted the RF zones since they don't do much for me and they kind of clutter up the device view. Thanks.

              Comment


              • #8
                I'm getting the same error, but the RF devices seem to function correctly anyway.

                Code:
                Jul-12 10:32:20 AM	 	Vista Alarm	Monitor started...
                Jul-12 10:32:20 AM	 	Vista Alarm	Loading Relay Devices...
                Jul-12 10:32:20 AM	 	Vista Alarm	Error: System.ArgumentException: An entry with the same key already exists. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value) at HSPI_VistaAlarm.VistaAlarmClass.RFDeviceCollection.Add(Int32 dvref) [3.0.0.27]
                Jul-12 10:32:20 AM	 	Vista Alarm	Error adding RF Device 81
                Jul-12 10:32:20 AM	 	Vista Alarm	Error: System.ArgumentException: An entry with the same key already exists. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value) at HSPI_VistaAlarm.VistaAlarmClass.RFDeviceCollection.Add(Int32 dvref) [3.0.0.27]
                Jul-12 10:32:20 AM	 	Vista Alarm	Error adding RF Device 80
                Jul-12 10:32:20 AM	 	Vista Alarm	Found the AD2USB on port COM6 running firmware version V2.2a.6
                Jul-12 10:32:20 AM	 	Vista Alarm	Received msg: !VER:ffffffff,V2.2a.6,TX;RX;SM;VZ;RF;ZX;RE;AU;3X;CG;DD;MF;LR;KE;MK;CB
                Jul-12 10:32:20 AM	 	Vista Alarm	Sent cmd: V
                Jul-12 10:32:20 AM	 	Vista Alarm	Opened COM port COM6
                Jul-12 10:32:20 AM	 	Device Control	Device: Security Monitor Status to On (100) by/from: CAPI Control Handler

                Comment


                • #9
                  can you post a screen shot of the device zones and related rf zones that are generating the errors
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                  • #10
                    I am having the same problem

                    I am trying to get user codes also. I am following along this thread. I get the same results. The zones do appear to work. This one is an RF only zone.

                    HTML Code:
                    Sep-01 1:54:33 PM	 	Vista Alarm	Error adding RF Device 638
                    Sep-01 1:54:33 PM	 	Vista Alarm	Error: System.ArgumentException: An entry with the same key already exists. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value) at HSPI_VistaAlarm.VistaAlarmClass.RFDeviceCollection.Add(Int32 dvref) [3.0.0.27]
                    Attached Files

                    Comment


                    • #11
                      Originally posted by PJJPtx View Post
                      I am trying to get user codes also. I am following along this thread. I get the same results. The zones do appear to work. This one is an RF only zone.

                      HTML Code:
                      Sep-01 1:54:33 PM	 	Vista Alarm	Error adding RF Device 638
                      Sep-01 1:54:33 PM	 	Vista Alarm	Error: System.ArgumentException: An entry with the same key already exists. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value) at HSPI_VistaAlarm.VistaAlarmClass.RFDeviceCollection.Add(Int32 dvref) [3.0.0.27]
                      looks like you already registered this RF number. please check.

                      User code triggers are avail if you have the LRR feature enabled. please search for threads on that topic. you will also need to visit the ad2usb forum for instructions on setting up the panel side of this.
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment

                      Working...
                      X