Announcement

Collapse
No announcement yet.

Error Accessing Plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Accessing Plugin

    Trying to access the IFTTT plugin, I get a page that just says "Error" - and all the log says is:

    Jul-03 2:03:01 PM IFTTT ERROR Object reference not set to an instance of an object

    This is on Linux - Raspbian, running standard HS3.

  • #2
    this is when you try to go to the Config page, right?

    please create a IFTTT.ini file on your Config folder
    and paste those lines in it:
    Code:
    [GENERAL]
    log_level=Debug
    then restart the plugin go to the config page, and post your logs.

    This is the kind of issue I ran into last time I tried to test my plugins on the Pi. I don't know what is the problem yet, but that's weird as the same plugin works on HS3 linux (non Pi)

    Comment


    • #3
      Jul-03 3:43:53 PM IFTTT DEBUG at HSPI_IFTTT.WebConfig.GetPagePlugin (System.String pageName, System.String user, Int32 userRights, System.String queryString) [0x00000] in {0x3C}filename unknown{0x3E}:0 Jul-03 3:43:53 PM IFTTT ERROR Object reference not set to an instance of an object Jul-03 3:30:23 PM IFTTT DEBUG at RestSharp.RestClient..ctor (System.String baseUrl) [0x00000] in {0x3C}filename unknown{0x3E}:0 {0xA} at DropNet.DropNetClient.LoadClient () [0x00000] in {0x3C}filename unknown{0x3E}:0 {0xA} at DropNet.DropNetClient..ctor (System.String apiKey, System.String appSecret, AuthenticationMethod authenticationMethod) [0x00000] in {0x3C}filename unknown{0x3E}:0 {0xA} at HSPI_IFTTT.IFTTTApp.{0x3C}Init{0x3E}b__2 () [0x00000] in {0x3C}filename unknown{0x3E}:0 Jul-03 3:30:23 PM IFTTT ERROR Could not load file or assembly 'System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. Jul-03 3:30:22 PM Plug-In Finished initializing plug-in IFTTT Jul-03 3:30:20 PM Info Plugin IFTTT has connected. IP:127.0.0.1:34055 Jul-03 3:30:10 PM Plug-In Interface IFTTT is running as a trial, 30 days remaining.

      Comment


      • #4
        a library is missing, try this:

        Code:
        sudo apt-get install  libmono-system-xml-linq4.0-cil
        then restart the plugin

        Comment


        • #5
          OK. Got a little farther. Once I set it up with dropbox, I had to restart the plugin.

          After that, I just get the "Error" page again - I did notice the ifttt.ini now contains dropbox tokens.

          Jul-03 6:52:13 PM IFTTT ERROR Argument cannot be null.{0xA}Parameter name: userLogin

          Comment


          • #6
            could you restart the plugin and attach the full log (make sure you still have the log_level=Debug in IFTTT.ini)

            Comment


            • #7
              OK. I started from scratch:

              I disabled the plugin, then removed the dropbox credentials from the ini.

              Enabled the plugin and attempted to link to dropbox. The credentials were written to the INI file (token and secret), but the plugin doesn't seem to recognize that it is linked.

              Now, when I attempt to link it, dropbox gives me an error saying the URL is invalid and it redirects me to my dropbox home page.

              I do see the following error, this happened after I attempted to link the dropbox account the first time:

              Jul-15 4:15:19 PM IFTTT DEBUG at DropNet.DropNetClient.Execute (ApiType apiType, IRestRequest request) [0x00000] in {0x3C}filename unknown{0x3E}:0 {0xA} at DropNet.DropNetClient.GetAccessToken () [0x00000] in {0x3C}filename unknown{0x3E}:0 {0xA} at HSPI_IFTTT.IFTTTApp.SaveDropboxAccessToken () [0x00000] in {0x3C}filename unknown{0x3E}:0 Jul-15 4:15:19 PM IFTTT ERROR Exception of type 'DropNet.Exceptions.DropboxException' was thrown.

              Comment

              Working...
              X