Announcement

Collapse
No announcement yet.

Authorize failure

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Authorize failure

    I just upgraded to 3.0.0.5, and as I changed the dropbox password earlier, I thought I should reauthorize the dropbox connection (I realize NOW that perhaps this isn't necessary).

    However, I get this error from Dropbox:
    HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
    Running on Windows 10 (64) virtualized
    on ESXi (Fujitsu Primergy TX150 S8).
    WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

    Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

  • #2
    I can reproduce this error, I will try to fix it later.

    Here is a workaround that works for me:
    - edit Config/IFTTT.ini and delete the whole [DROPBOX] section
    - restart the plugin
    - do the authorization process again

    Comment


    • #3
      Thanks! That helped.
      HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
      Running on Windows 10 (64) virtualized
      on ESXi (Fujitsu Primergy TX150 S8).
      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

      Comment


      • #4
        Hi Spud. I am having Dropbox authorization issues as well but the workaround above does not help me. There is nothing actually in the IFTTT.ini file (it is blank). When trying to authorize Dropbox it open my DB account and displays the following message in red at the top of the screen:

        This session has expired. Please return to the app to try again.

        I have tried logging out of it of DB first and the signing in when IFTTT forwards me there - no go.

        Any thoughts?

        Thanks!

        John

        Comment


        • #5
          Originally posted by Keoni View Post
          Hi Spud. I am having Dropbox authorization issues as well but the workaround above does not help me. There is nothing actually in the IFTTT.ini file (it is blank). When trying to authorize Dropbox it open my DB account and displays the following message in red at the top of the screen:

          This session has expired. Please return to the app to try again.

          I have tried logging out of it of DB first and the signing in when IFTTT forwards me there - no go.

          Any thoughts?

          Thanks!

          John
          That's weird never saw that.
          Can you try to restart from scratch:

          - stop the plugin
          - delete IFTTT.ini from your config folder
          - in your dropbox account, click on your nickname in the top right corner, then click settings, go to the security tab, and in the Apps Linked section at the bottom check if you see HSPI_IFTTT, if you have it delete it
          - restart the plugin
          - make sure you don't have any popup blocker active, then go to the config page and click on "Dropbox Authorize" button.

          Comment


          • #6
            Originally posted by spud View Post
            That's weird never saw that.
            Can you try to restart from scratch:

            - stop the plugin
            - delete IFTTT.ini from your config folder
            - in your dropbox account, click on your nickname in the top right corner, then click settings, go to the security tab, and in the Apps Linked section at the bottom check if you see HSPI_IFTTT, if you have it delete it
            - restart the plugin
            - make sure you don't have any popup blocker active, then go to the config page and click on "Dropbox Authorize" button.
            That worked! HSPI_IFTTT was not in the authorized apps listed in dropbox so I am assuming that deleting the ini file is what did the trick. Thank you.

            Comment

            Working...
            X