Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MNB
    replied
    Steve, I've left the two "Execute immediate script" on and am waiting with baited breath for the way forward, Mike

    Leave a comment:


  • slbuck
    replied
    Originally posted by MNB View Post
    Steve, to answer your question yes I too have On/Off Controls showing (see attached) even after I de-select "Status only" Checkbox and set the Status-Control to all reflecting "Status". Randy do you have any insight as to how we can turn it off? Mike
    UPDATE: Setting things back to Both resolved the issue. There's something wrong with the download for v 507 so we'll have to wait on that. Reading the fixes for that release, I don't think we'll be able to hide the controls. I've reached out to Spud to see if he can allow a status only device to be copied to another status only device.

    Mike,

    It looks like I'm still having problems updating the Previous location device with anything set to Status for the Status-Controls. I'm going to set them all back to "Both" and see if that resolves the issue.
    Feb-17 10:29:30 EasyTrigger ERROR SetDeviceValue: Cannot find control value 4 for device 2826
    Feb-17 10:29:30 Event Event Trigger "PHLocation 2 PHL - Steve - Update Previous Location"

    Leave a comment:


  • MNB
    replied
    Thanxs Matt will do that once I finish my taxes … Mike

    Leave a comment:


  • MattL0
    replied
    Originally posted by MNB View Post
    Steve, to answer your question yes I too have On/Off Controls showing (see attached) even after I de-select "Status only" Checkbox and set the Status-Control to all reflecting "Status". Randy do you have any insight as to how we can turn it off? Mike
    Download homeseer v 507 , it deals with that

    Leave a comment:


  • MNB
    replied
    Steve, to answer your question yes I too have On/Off Controls showing (see attached) even after I de-select "Status only" Checkbox and set the Status-Control to all reflecting "Status". Randy do you have any insight as to how we can turn it off? Mike
    Attached Files

    Leave a comment:


  • slbuck
    replied
    Mike,

    ​​​​​I also removed the status only checkbox and set the status-controls to status and easy trigger is still able to update the previous location. Interestingly, I have an on and off control still showing, even though nothing is set to control or both. Do your devices show the on and off controls? I have a feeling there's something still set to control somewhere (just can't see it) which is why easy trigger still works with everything set to status.

    Leave a comment:


  • MNB
    replied
    Thanxs Randy, that was the ticket! I'm able to update using EasyTrigger without error. I noticed that I know have multiple controls within the control section so I changed Both to Status and that too seem to work without producing an error...

    Thanxs Steve, based on Randy's recommendation it looks like EasyTrigger can update the previous location device, have you confirmed? Mike

    Leave a comment:


  • rprade
    replied
    Originally posted by MNB View Post
    Steve, I've verified that I still get the same EasyTrigger Error (see below) even after I re-create a new virtual device from scratch (see attached screen shots);

    Feb-16 3:44:58 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 297
    Feb-16 3:44:58 PM Event Event Trigger "Location Mike - Update Previous Location"
    Feb-16 3:44:58 PM Event Event Location Mike - Update Previous Location triggered by the event page 'Run' button.
    You need to deselect “Status Only Device” so that Easy Trigger can control it.

    Leave a comment:


  • slbuck
    replied
    Here you go. I'm heading out and I'll test more. I think I may go back to the script method as well since it works flawlessly.

    Click image for larger version

Name:	Screenshot_2019-02-16-16-03-17.png
Views:	6
Size:	129.9 KB
ID:	1285482

    Leave a comment:


  • MNB
    replied
    Steve, in my attempts of copying your updates, I deleted your previous method of using an immediate script would you repost your previous solution as it seemed to work until we're able to get EasyTrigger to work as advertised.

    I should have kept it and use Randy's suggestion of toggling "NEVER" which would have kept the previous solution without compromising the Event. Mike

    Leave a comment:


  • MNB
    replied
    Steve, I've verified that I still get the same EasyTrigger Error (see below) even after I re-create a new virtual device from scratch (see attached screen shots);

    Feb-16 3:44:58 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 297
    Feb-16 3:44:58 PM Event Event Trigger "Location Mike - Update Previous Location"
    Feb-16 3:44:58 PM Event Event Location Mike - Update Previous Location triggered by the event page 'Run' button.
    Attached Files

    Leave a comment:


  • slbuck
    replied
    Originally posted by MNB View Post
    Steve, thanxs for the latest re EasyTrigger, question whilst reviewing logic I notice that the Group Conditions is set to "IF house status (Home/Away) has a value equal to Home" suggest that in all instances it should be set to Away for the Known events including Home Arriving because during each of these events you would be Away and not until your Home would Home be set so I would argue that the "AND IF The Group Conditions are all False" then the Event could execute as written, your thoughts Mike
    The occupancy status is if anyone is currently at home. If no-one is at home, then I don't fire the event since no-one would be home to hear the announcements.

    Originally posted by MNB View Post
    Using EasyTrigger I still get an error (even after creating a clean Virtual Device using the Green Plus button):
    Feb-16 11:09:27 AM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 296
    Make sure that all the device status-controls are set to Both and that the "Status Only Device" checkbox is selected under the configuration tab. Also, I'm still testing this, but I see the same error after trying to update the previous location device after it's already been set to the Home device. It might have something to do with the 0 value, but can't be sure. The same event was working yesterday when I was traveling around, so it may only be an error when trying to set it to the Home location for some reason.

    Leave a comment:


  • MNB
    replied
    Steve, thanxs for the latest re EasyTrigger, question whilst reviewing logic I notice that the Group Conditions is set to "IF house status (Home/Away) has a value equal to Home" suggest that in all instances it should be set to Away for the Known events including Home Arriving because during each of these events you would be Away and not until your Home would Home be set so I would argue that the "AND IF The Group Conditions are all False" then the Event could execute as written, your thoughts Mike

    Using EasyTrigger I still get an error (even after creating a clean Virtual Device using the Green Plus button):
    Feb-16 11:09:27 AM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 296
    Feb-16 11:09:27 AM Event Event Trigger "Location Mike - Update Previous Location"
    Feb-16 11:09:27 AM Event Event Location Mike - Update Previous Location triggered by the event page 'Run' button.

    Leave a comment:


  • slbuck
    replied
    Originally posted by MNB View Post
    Steve, thanxs for the latest.. I originally could not get my virtual device to reflect my previous location but rather was getting a value of "0" or "Off" (Home) until I realized I need a copy of my Current Location Virtual Device which was already setup for "0" = Home and "-2" = Multiple Location and -1 = None. Mike
    I was advised by Spud to not copy the plugin device, but instead, create a new virtual device. I've updated my post above and original post #528 for completeness.

    Leave a comment:


  • MNB
    replied
    Steve, thanxs for the latest.. I originally could not get my virtual device to reflect my previous location but rather was getting a value of "0" or "Off" (Home) until I realized I need a copy of my Current Location Virtual Device which was already setup for "0" = Home and "-2" = Multiple Location and -1 = None. Mike

    Leave a comment:

Working...
X