Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by zimmer62 View Post
    Now if I can just get it to stop doing this:
    Jan-11 9:36:40 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:36:20 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:36:00 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:35:40 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:35:20 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:35:00 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:34:40 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:34:20 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:34:00 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:33:40 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    Jan-11 9:33:20 AM PHLocation2 (Polling) IC Error. Key:430 is not in the polling interval list!
    You see this message because I neglected to put in code to remove a device from the list of devices to poll when the user deletes a device from HS3.

    If you stop and re-start the plug-in it should re-build the list and the messages should stop.

    The 20 second recurrence of this message is because that's the interval that it checks to see if anything needs polling.

    I've now put in the code to remove deleted device(s) from the polling list.

    Paul..

    Comment


    • #32
      Originally posted by sooty View Post

      You see this message because I neglected to put in code to remove a device from the list of devices to poll when the user deletes a device from HS3.

      If you stop and re-start the plug-in it should re-build the list and the messages should stop.

      The 20 second recurrence of this message is because that's the interval that it checks to see if anything needs polling.

      I've now put in the code to remove deleted device(s) from the polling list.

      Paul..
      Thanks! Looks like all is working.

      Do you ever have plans to trigger the icloud find my phone ping? I've got kind of a hacky way to do that something I wrote in C# but I'd love to ditch that and just have your plug-in do it.
      Joe (zimmer62)

      BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

      Comment


      • #33
        Dumb question.. in regards to the 2FA Controls, I depress "Request Code" and get a code on my phone (verifies that AppleId and Password is working for iCloud).. I get a two three digit Code separated with a space after the first three digits, I tried to enter all six digit together (1st try)then enter three digits followed by space and the last three digits (after second request) but get "Validation failed. See log for details" message in both attempts, what am I missing? Mike
        Computer: CUK Intel NUC7i7BNH
        Op System: Windows 10 Pro - Work Station
        HS Version: HS3 Pro Edition 3.0.0.435

        Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

        Comment


        • #34
          Originally posted by zimmer62 View Post
          Do you ever have plans to trigger the icloud find my phone ping? I've got kind of a hacky way to do that something I wrote in C# but I'd love to ditch that and just have your plug-in do it.
          Yes. All the code is in to sendMessage and/or playSound, I just need to provide a means for the user to initiate it.

          Would you like this to be driven an HS3 event action?

          Paul..

          Comment


          • #35
            Originally posted by MNB View Post
            Dumb question.. in regards to the 2FA Controls, I depress "Request Code" and get a code on my phone (verifies that AppleId and Password is working for iCloud).. I get a two three digit Code separated with a space after the first three digits, I tried to enter all six digit together (1st try)then enter three digits followed by space and the last three digits (after second request) but get "Validation failed. See log for details" message in both attempts, what am I missing? Mike
            You just need to enter all 6 digits together in the box like 123456.

            If it fails then you should get an error message in the HS3 log with details of why it failed.
            Drop that message to me in an email (DON'T POST IT HERE)

            [EDIT]
            Something else that just came to mind. It may be that you need to confirm some security setting on iCloud to allow access.

            Log into your iCloud account with a browser at icloud.com

            It may ask you to confirm something when you log in. Do that, then try access again from the plug-in.

            Paul..

            Comment


            • #36
              I did not want to double post, but could you look at my PHL2 - Backtitude post in the main phlocation forum? I can move here if needed. Thanks Paul

              Comment


              • #37
                Originally posted by sooty View Post

                Yes. All the code is in to sendMessage and/or playSound, I just need to provide a means for the user to initiate it.

                Would you like this to be driven an HS3 event action?

                Paul..
                Honestly event would be great but a scripting call would work.


                Sent from my iPhone using Tapatalk Pro
                Joe (zimmer62)

                BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

                Comment


                • #38
                  Thanxs for the quick comeback.. Problem resolved, it seemed to be a apple problem I logged into iCloud via my PC which worked and then did the same for PHLocation2 and "whala" it now is working "the mystery of electrons" Mike
                  Computer: CUK Intel NUC7i7BNH
                  Op System: Windows 10 Pro - Work Station
                  HS Version: HS3 Pro Edition 3.0.0.435

                  Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                  Comment


                  • #39
                    Does PHLocation2 require two factor authentication for iCloud?
                    If so, that rules it out for me.

                    Comment


                    • #40
                      Originally posted by joegr View Post
                      Does PHLocation2 require two factor authentication for iCloud?
                      If so, that rules it out for me.
                      Yes. Apple required me to switch to 2FA beginning with iOS11. Also i think they no longer support iCloud from 3rd party apps (other than browsers) without it.

                      From Apple:

                      "Two-factor authentication is our most advanced, easy-to-use account security, and it's required to use some of the latest features of iOS, macOS, and iCloud. If you're using two-step verification, we'll automatically update your account when you sign in to iOS 11 or later or macOS High Sierra or later. You can also manually switch your account from two-step verification to two-factor authentication when you follow the steps below."

                      https://support.apple.com/en-us/HT207198
                      Randy Prade
                      Aurora, CO
                      Prades.net

                      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                      Comment


                      • #41
                        Originally posted by rprade View Post
                        Yes. Apple required me to switch to 2FA beginning with iOS11. Also i think they no longer support iCloud from 3rd party apps (other than browsers) without it.

                        ...
                        Well, I'm on iOS12.1.2 and fortunately, the original PHLocation is still working for me.

                        2FA is a non-starter for me due to family members on the same Apple ID in different locations.

                        I guess I'll have to hope the original keeps working. I do wish it wouldn't try to do the elevation look ups.

                        Note that Apple does not require 2FA, so much as they try to trick you into it by not making it really clear how you avoid it.

                        Comment


                        • #42
                          Click image for larger version  Name:	Port Forwarding.PNG Views:	1 Size:	51.1 KB ID:	1275047

                          Originally posted by rprade View Post
                          For those of you posting from 3rd party apps like GeoFency, PHL2 does not use its own web server, it uses the HS built-in server. The posting is still the same as before with two changes 1) it now uses your HomeSeer web server port (usually 80) so create your port forwarding rules and structure the URL accordingly. 2) The api is now phl2api, with the original it was phlapi. The dtypes are the same as listed in the PHL documentation.


                          If you are posting to GeoFency for example it will be:

                          MYHS:
                          https://connected2.homeseer.com/phl2api?dtype=GF
                          Use your MyHS login credentials

                          Direct through port forwarding:
                          http://[ddns domain name]:[external port]/phl2api?dtype=GF
                          if you have "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" no credentials are required, otherwise use your HS admin account credentials.

                          Direct through VPN:
                          http://[HS local IP]:[HS port - not required if 80]/phl2api?dtype=GF
                          if you have "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" no credentials are required, otherwise use your HS admin account credentials.
                          I know I can be a little slow...

                          Are you indicating for GeoFency app that we change the Webhook setting;
                          From: "Notify on Entry and Exit - http://mnb.XXX.XXX:80XX/phlgeofency" (Old - PHlocate)
                          To: "Notify on Entry and Exit - http://mnb.XXX.XXX:80/phlgeofency" (New - PHlocate2)



                          With User name and password the same for HS3 login. I'm not clear where I to change the above items (MYHS or Direct through port forwarding) I include any example of my current port forwarding screen capture (top of file)?
                          Last edited by rprade; January 14th, 2019, 09:15 PM. Reason: corrected URL
                          Computer: CUK Intel NUC7i7BNH
                          Op System: Windows 10 Pro - Work Station
                          HS Version: HS3 Pro Edition 3.0.0.435

                          Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                          Comment


                          • #43
                            Originally posted by MNB View Post

                            I know I can be a little slow...

                            Are you indicating for GeoFency app that we change the Webhook setting;
                            From: "Notify on Entry and Exit - http://mnb.XXX.XXX:80XX/phlgeofency" (Old - PHlocate)
                            To: "Notify on Entry and Exit - http://mnb.XXX.XXX:80/phlgeofency" (New - PHlocate2)








                            With User name and password the same for HS3 login. I'm not clear where I to change the above items (MYHS or Direct through port forwarding)?
                            I forgot about the old URL for PHL1. The new API is just phl2api?dtype=GF, no matter how you post, because it uses the HomeSeer web server.

                            How are you posting? Through MyHS, port forwarding or a VPN? The MyHs credentials are used with MyHS, local admin credentials would be used for port forwarding or VPN. I do not need credentials for VPN, because it appears as a local connection and I have "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" enabled. In this case it doesn't matter what credentials are used, but I put in my local admin credentials.

                            If your old was Notify on Entry and Exit - http://mnb.XXX.XXX:80XX/phlgeofency
                            The new would be Notify on Entry and Exit - http://mnb.XXX.XXX:80/phl2api?dtype=GF

                            What I don't know is if the 80XX was the port number of the old PHL web server. If your HS web server uses the default HTTP port (80) it can be omitted, if using VPN.

                            Port forwarding would require using your external port.
                            Randy Prade
                            Aurora, CO
                            Prades.net

                            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                            Comment


                            • #44
                              I just noticed you were using port forwarding, so it would be as I wrote above and would use any local credentials that have Admin privileges. You will need to use the external port you have forwarded.

                              Looking at that forwarding rule, you would be giving external access for HS to the world, so you would probably be better off going with MyHS (preferably) or at least a non standard external port (not recommended).

                              MyHS is fast and reliable.

                              Remember that all communications are viewable if not over a secure HTTPS connection, so your credentials are exposed when using port forwarding.
                              Randy Prade
                              Aurora, CO
                              Prades.net

                              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                              Comment


                              • #45
                                Ok, I first entered you suggestion using my local lan;
                                http://192.168.0.XX:XXXX/phl2api?dtype=GF within my GeoFency app and performed Test connection Entry/Exit and got "Successful ["CTime", "1/11/2019 5:04:10 PM"] message for both Entry/Exit, however whilst looking at my HS3 Log I did not see any entry.
                                I then tried the same URL using my browser and got the following message "
                                Error! Fence data check type [F] failed.", looking again in my HS3 Log I see
                                Jan-11 5:09:10 PM PHLocation2 Error (phlapi) GET Error: Error! Fence data check type [F] failed.
                                Jan-11 5:09:10 PM PHLocation2 Error (ProcHttpFenceData) DataCheck Error. Did: Fid: Fname: Ftyp:F Fdir:-1 Fpv:17
                                Is this a correct indication? I'm currently working on getting my NoIP to work the same using my iPhone with the WiFi turned off. Mike
                                Computer: CUK Intel NUC7i7BNH
                                Op System: Windows 10 Pro - Work Station
                                HS Version: HS3 Pro Edition 3.0.0.435

                                Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                                Comment

                                Working...
                                X