Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Malosa
    replied
    Hi, sooty rprade

    i have seen a little problem in Reverse Geocode Data Provider,

    Most of the times it does not show the street numbers at all..
    Im here in the netherlands and dit test it but no numbers.

    Also is it possible to show it like this [street] [number] [postalcode] [town] at the adress device because now its here all messed up.
    I did use all providers(except google) because im out of api requestall the time.

    The second issue is that after a plugin restart (Force update of position devices) gets unchecked again.


    I would also do a request to add a number device, that shows the current home number where you are at.


    regards

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by sooty View Post

    Thanks for the heads up, I've fixed the installer package versions.

    Paul..
    I Paul,

    after another install, the plugin is still in v .41.


    Leave a comment:


  • sooty
    replied
    Originally posted by slbuck View Post
    I'm using Backitude with location steals on my phone which works great, except for the altitude. I noticed that Backitude is sending the wrong altitude over to PHLocation 2. My GPS app on my phone shows an altitude of 100 feet, but Backitude would show an altitude of 25 feet. This would then reflect in PHLocation 2.

    There is an option in Backitude to disable reporting of altitude data by removing the request parameter key for Altitude which prevents sending this over to PHLocation 2. (No key value - Request will not contain this field). When I do this, I'm not getting any altitude updates in PHLocation 2.

    How is the elevation data utilized in PHL2? Is there any way to utilize the elevation data to calculate the altitude from the lat/lon if no data is received from Backitude? I have a google and mapquest api entered and elevation data is configured to use these sources, but the altitude is never updated.
    Could be a conversion issue if Backitude is sending the data in different units although 100 feet doesn't equal 25 metres? I don't have Backitude to test but if you drop me an email I'll explain how you can get me some more info which may help to debug the issue.

    If you remove the altitude parameter from the Backitude app so it doesn't send a value, then assuming you have a primary elevation provider set on the plug-in config>API's page it will attempt to obtain the data from the lat / lon.

    Paul..

    Leave a comment:


  • sooty
    replied
    Originally posted by MattLau View Post
    Just to let you know sooty the zip file is named .41 . In the updater overdride it is .42

    I change the name of the .41 zipfile to .42...

    but now I have .41 installed in homeseer plugin page


    Code:
    FILEVERSION 3,0,0,41
    PRODUCTVERSION 3,0,0,41
    FILEFLAGSMASK 0x3F
    FILEFLAGS 0x0
    FILEOS VOS_UNKNOWN | VOS__WINDOWS32
    FILETYPE VFT_APP
    FILESUBTYPE 0x0
    {
    BLOCK "VarFileInfo"
    {
    VALUE "Translation", 0x0, 1200
    }
    BLOCK "StringFileInfo"
    {
    BLOCK "000004b0"
    {
    VALUE "Comments", "PH Location Plug-In for HS3"
    VALUE "CompanyName", "Paul Huddlestone"
    VALUE "FileDescription", "HSPI_PHLocation2"
    VALUE "FileVersion", "3.0.0.41"
    VALUE "InternalName", "HSPI_PHLocation2.exe"
    VALUE "LegalCopyright", "Copyright © Paul Huddlestone 2019"
    VALUE "LegalTrademarks", ""
    VALUE "OriginalFilename", "HSPI_PHLocation2.exe"
    VALUE "ProductName", "HSPI_PHLocation2"
    VALUE "ProductVersion", "3.0.0.41"
    VALUE "Assembly Version", "3.0.0.41"
    }
    }
    }
    Thanks for the heads up, I've fixed the installer package versions.

    Paul..

    Leave a comment:


  • jezza
    replied
    Hi Guys,

    I have got PHLocation2 installed and working. so far so good.
    I have my minimum distance to move set to 1km on my icloud. However when im walking around the site at work my time at location drops to 0m (site would be lucky to be 500m).
    Should having this set to 1km stop this from happening? i think that how i did it in PHL1.

    thanks

    Leave a comment:

Working...
X