Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by MNB View Post
    Paul, Map(s) question; which tab is controlling the two maps below (I was assuming the Configuration>Mapping but I do not believe that's totally correct?
    • Dynamic Map (Built-in Viewer)
    • Auto Generate (All Users) Dynamic Map settings
    • Auto Generate (All Users) Static Image Settings
    1. (Device Id)_history.HTML
    2. (Device ID)_current.PNG
    3. alluserscurrent.HTML
    Confusing I know. I'm confused and I wrote it
    I'll try and change / rearrange some of the descriptions and tooltips to better describe what each setting does.

    The built in-dynamic map viewer creates HTML files whenever it's used. The file names are fixed and are really not that relevant to the end user because they are only used internally.

    Settings for the built in dynamic map viewer are on the Mapping tab of the plug-in config.
    The first section (Dynamic Map (General) Settings) applies to all dynamic maps regardless of how they are created / viewed.
    The (Dynamic Map (Built-In Viewer) Settings) apply only to the built-in viewer.

    Within each position type user, there is the option to automatically generate both static and / or dynamic "All Users" maps.
    Map generation is triggered whenever a user with that option switched ON changes location. It will then grab all other users with the option switched ON and generate a map.
    The settings for "All Users" map types are a little confusing because they are split between the Config>Mapping and each individual user.
    The general parameters for "All Users" maps like map size, type and file name override etc are done in Config>Mapping.
    Within each user's PHL2 tab the marker character and marker pin colour apply to both All Users and Single User maps. The rest of the settings are "Single User" only.

    So, if you don't override any file names the defaults below will be used: F=Fixed File Name O=Overridable File Name
    F (alluserscurrent.html) Created / updated when the "All Users" button is clicked on the Map Viewer page.
    F (deviceId_history.html) Created / updated when the "History" button is clicked on the Map Viewer page.
    O (all_users_current.html) Created / updated when an "All Users" dynamic map is automatically generated.
    O (deviceId_current.html) Created / updated when a "Single User" dynamic map is automatically generated.
    O (dynamic_map_from_action.html) Created / updated when a dynamic map is generated from an event action.
    O (all_users_current.png) Created / updated when an "All Users" static map is automatically generated.
    O (deviceId_current.png) Created / updated when a "Single User" static map is automatically generated.
    O (static_map_from_action.png) Created / updated when a static map is generated from an event action.

    Think that's it.

    Paul..

    Comment


    • Paul, thanxs for the explanation it does provide insight into the confusion…

      1) According to your overview "History" with device ID (96_history.html) is created during Map Viewer page, however we can also get a history if we use a event to build a dynamic Map with Map type of History.

      2) Where does the static device Id (96_current.png) map get created from?

      3) The iCloud device>PHLocation2 tab Dynamic Mapping Options is a dynamic map for current mapping (when location changes) which doesn't have history associated with it, whilst Static Mapping Option is a static map for current mapping (when location changes) and doesn't have history associated with it by nature of a png file. Other than file type both basically produce similar results (have I missed something?)
      Thanxs in advance not trying to be difficult only trying to make sure I understand, Mike
      Computer: CUK Intel NUC7i7BNH
      Op System: Windows 10 Pro - Work Station
      HS Version: HS3 Pro Edition 3.0.0.435

      Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

      Comment


      • Originally posted by MNB View Post
        Paul, thanxs for the explanation it does provide insight into the confusion…

        1) According to your overview "History" with device ID (96_history.html) is created during Map Viewer page, however we can also get a history if we use a event to build a dynamic Map with Map type of History.

        2) Where does the static device Id (96_current.png) map get created from?

        3) The iCloud device>PHLocation2 tab Dynamic Mapping Options is a dynamic map for current mapping (when location changes) which doesn't have history associated with it, whilst Static Mapping Option is a static map for current mapping (when location changes) and doesn't have history associated with it by nature of a png file. Other than file type both basically produce similar results (have I missed something?)
        Thanxs in advance not trying to be difficult only trying to make sure I understand, Mike
        1. If the path and file name are not overridden then all dynamic maps generated from an event, regardless if history or current will be named (dynamic_map_from_action.html). The same applies to static maps although the file name will be (static_map_from_action.png).

        2. That should be coming from the "Build a new map when location changes" option within static map settings on the PHL2 tab of the user with device ref 96.

        3. You summary is exactly right.
        Dynamic maps are more suited to viewing with a browser where you can pan and zoom the map etc and are designed to be used in an iFrame which may be embedded in another web page.
        Static maps are just that, a fixed "static" image that cannot be panned or zoomed. This was initially done in PHL V1 so users could display the map images in HSTouch.
        Wasn't going to put this in V2 but a few folks asked for it so I added it.

        Paul..

        Comment


        • Again, thanxs Paul, I'm now feeling empowered PHL2 wise which might be just a false sense of security!
          Computer: CUK Intel NUC7i7BNH
          Op System: Windows 10 Pro - Work Station
          HS Version: HS3 Pro Edition 3.0.0.435

          Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

          Comment


          • Originally posted by slbuck View Post

            I was actually guessing the value for the Vortex to be 4 since it was the 4th location I had added. 0 is always Home and then 1-99999999 are for user added locations. I now have 10 known locations and they are alphabetized so I've lost track of which value is assigned to each known location. I've reached out to Paul to see if he might include the value for each location under the known locations tab.

            The vortex known place is just a regular location (my in-laws actually) and so I handle entry/exit to this location separately from all other locations.
            Steve, thanxs for providing your latest event updates.. so I'm feeling a little better in regards to not knowing about EasyTrigger range related to Known locations, I can be slow at times.. I see in your latest event iteration that you've abandoned the use of know locations within range and went the more simpler approach.

            I had to laugh at your Vortex known place, I was thinking it was the freeway hence the enquiry as to how one would capture that. Does your in-laws know that they are known as the "Vortex" ( I can relate) Mike
            Computer: CUK Intel NUC7i7BNH
            Op System: Windows 10 Pro - Work Station
            HS Version: HS3 Pro Edition 3.0.0.435

            Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

            Comment


            • Script help please, I was trying to modify a Execute immediate script command: "&nhs.WriteLog("Location","Fence - Mike is at "$$DSR:101: " and was trying to get my replacement value $$DSR:101 to print within my HS3 log what syntax am I missing? Mike
              Computer: CUK Intel NUC7i7BNH
              Op System: Windows 10 Pro - Work Station
              HS Version: HS3 Pro Edition 3.0.0.435

              Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

              Comment


              • Originally posted by MNB View Post
                Script help please, I was trying to modify a Execute immediate script command: "&nhs.WriteLog("Location","Fence - Mike is at "$$DSR:101: " and was trying to get my replacement value $$DSR:101 to print within my HS3 log what syntax am I missing? Mike
                You cannot use replacement variables in a script. You will have to use hs.DeviceValue(ref) or hs.DeviceString(ref).

                https://help.homeseer.com/help/HS3/s...or_last_change
                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                • Thanxs Randy I'll try your suggestion. Mike

                  UPDATE: Script command seem to work properly "&nhs.WriteLog("Location","Fence - Mike is at " & hs.deviceString(261))"

                  Steve, How did you get your previous location virtual device to work, it looked like you copied the PHL NearestLocation device and renamed it Steve phone Previous location. When I do that and use EasyTrigger to copy the PHL NearestLocation to the Phone Previous location I get an EasyTrigger error (see below). I can see that the NearestLocation is a string device so I would have thought the same should be for copying values from one device to the other? Mike
                  Feb-14 4:43:51 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 292
                  Feb-14 4:43:51 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 291
                  Computer: CUK Intel NUC7i7BNH
                  Op System: Windows 10 Pro - Work Station
                  HS Version: HS3 Pro Edition 3.0.0.435

                  Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                  Comment


                  • Originally posted by MNB View Post

                    Steve, thanxs for providing your latest event updates.. so I'm feeling a little better in regards to not knowing about EasyTrigger range related to Known locations, I can be slow at times.. I see in your latest event iteration that you've abandoned the use of know locations within range and went the more simpler approach.

                    I had to laugh at your Vortex known place, I was thinking it was the freeway hence the enquiry as to how one would capture that. Does your in-laws know that they are known as the "Vortex" ( I can relate) Mike
                    Regarding the known location and trying to use ranges, it was my lack of understanding as well that kept it from working. I was checking the current location which at the time would be "None" and so would always result in being a true comparison since the value in the range of 0 to 0 would never be equal to -1 nor would a value in the range of 4 to 4. Doing a check to see if the device value was not equal to Home (value of 0) or using easytrigger to see if the string did not contain "vortex" made it much more readable.

                    This did not work at first since I was not updating the previous location device correctly and so the value never got updated. I've updated my original post with the correct event to update the previous location device. See the link below to post #528

                    As a result of various personal circumstances, the release of PHLocation V2 has been delayed far longer than I would have liked :( As the majority of recently

                    Comment


                    • Originally posted by MNB View Post
                      Thanxs Randy I'll try your suggestion. Mike

                      UPDATE: Script command seem to work properly "&nhs.WriteLog("Location","Fence - Mike is at " & hs.deviceString(261))"

                      Steve, How did you get your previous location virtual device to work, it looked like you copied the PHL NearestLocation device and renamed it Steve phone Previous location. When I do that and use EasyTrigger to copy the PHL NearestLocation to the Phone Previous location I get an EasyTrigger error (see below). I can see that the NearestLocation is a string device so I would have thought the same should be for copying values from one device to the other? Mike
                      Feb-14 4:43:51 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 292
                      Feb-14 4:43:51 PM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 291
                      UPDATE: After posting on the EasyTrigger forum, Spud got me straightened out. I'm currently testing to validate that it's working. The reason it was failing is that the status-control type has to be set to Both and should not be a clone of a plugin controlled device. When I created a new virtual device and replicated all the status graphics and values, made the status-controls Both, and set the device as a Status Only Device, EasyTrigger is now able to update the device. Here is the new device along with the new simpler event to update it.


                      Click image for larger version  Name:	phlocation2-device-previous-location-configuration.PNG Views:	1 Size:	311.3 KB ID:	1285279Click image for larger version  Name:	phlocation2-device-previous-location-advanced.PNG Views:	1 Size:	52.3 KB ID:	1285280Click image for larger version  Name:	phlocation2-device-previous-location-status-values.PNG Views:	1 Size:	180.2 KB ID:	1285281Click image for larger version  Name:	phlocation2-device-previous-location-status-graphics.PNG Views:	1 Size:	85.2 KB ID:	1285282

                      Click image for larger version

Name:	phlocation2-event-update-previous-location.PNG
Views:	30
Size:	28.2 KB
ID:	1285294

                      I've updated my original post #528. for completeness.

                      Comment


                      • I've noticed a problem with the location from home when using an iOS device, in my case my iPhone.

                        My phone is at home but it says my phone is 6551.76 Miles from Home. Needless to say that's a very large error indeed. I had a know location called Home however it was in error, I left out the "-" in the Longitude, but is now corrected. The problem is that I'm still getting the error even though I've restarted the phone and Location2.

                        So either something is broken or I don't have something setup correctly.

                        Apparently something was out of kilter. Don't know exactly fixed it but it's now working correctly.
                        HomeSeer Version: HS3 Standard Edition 3.0.0.531 | Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:02:17 UTC 2019)
                        Linux version: Linux auto 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
                        IP Address: 10.0.2.16 | Number of Devices: 417 | Number of Events: 667 | Available Threads: 399 | HSTouch Enabled: True

                        Enabled Plug-Ins: AirplaySpeak: 3.0.0.13 | BLBackup: 2.0.61.0 | EasyTrigger: 3.0.0.65 | LiftMaster MyQ: 1.3.7006.42100
                        mcsMQTT: 4.0.2.2 | PHLocation2: 3.0.0.53 | Pushover 3P: 0.0.0.45 | Z-Wave: 3.0.1.262

                        Z-Net version: 1.0.23 using a HomeSeer SmartStick+: 6.04 (ZDK 6.81.3)

                        Comment


                        • Steve, thanxs for the latest.. I originally could not get my virtual device to reflect my previous location but rather was getting a value of "0" or "Off" (Home) until I realized I need a copy of my Current Location Virtual Device which was already setup for "0" = Home and "-2" = Multiple Location and -1 = None. Mike
                          Computer: CUK Intel NUC7i7BNH
                          Op System: Windows 10 Pro - Work Station
                          HS Version: HS3 Pro Edition 3.0.0.435

                          Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                          Comment


                          • Originally posted by MNB View Post
                            Steve, thanxs for the latest.. I originally could not get my virtual device to reflect my previous location but rather was getting a value of "0" or "Off" (Home) until I realized I need a copy of my Current Location Virtual Device which was already setup for "0" = Home and "-2" = Multiple Location and -1 = None. Mike
                            I was advised by Spud to not copy the plugin device, but instead, create a new virtual device. I've updated my post above and original post #528 for completeness.

                            Comment


                            • Steve, thanxs for the latest re EasyTrigger, question whilst reviewing logic I notice that the Group Conditions is set to "IF house status (Home/Away) has a value equal to Home" suggest that in all instances it should be set to Away for the Known events including Home Arriving because during each of these events you would be Away and not until your Home would Home be set so I would argue that the "AND IF The Group Conditions are all False" then the Event could execute as written, your thoughts Mike

                              Using EasyTrigger I still get an error (even after creating a clean Virtual Device using the Green Plus button):
                              Feb-16 11:09:27 AM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 296
                              Feb-16 11:09:27 AM Event Event Trigger "Location Mike - Update Previous Location"
                              Feb-16 11:09:27 AM Event Event Location Mike - Update Previous Location triggered by the event page 'Run' button.
                              Computer: CUK Intel NUC7i7BNH
                              Op System: Windows 10 Pro - Work Station
                              HS Version: HS3 Pro Edition 3.0.0.435

                              Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                              Comment


                              • Originally posted by MNB View Post
                                Steve, thanxs for the latest re EasyTrigger, question whilst reviewing logic I notice that the Group Conditions is set to "IF house status (Home/Away) has a value equal to Home" suggest that in all instances it should be set to Away for the Known events including Home Arriving because during each of these events you would be Away and not until your Home would Home be set so I would argue that the "AND IF The Group Conditions are all False" then the Event could execute as written, your thoughts Mike
                                The occupancy status is if anyone is currently at home. If no-one is at home, then I don't fire the event since no-one would be home to hear the announcements.

                                Originally posted by MNB View Post
                                Using EasyTrigger I still get an error (even after creating a clean Virtual Device using the Green Plus button):
                                Feb-16 11:09:27 AM EasyTrigger ERROR SetDeviceValue: Cannot find control value 0 for device 296
                                Make sure that all the device status-controls are set to Both and that the "Status Only Device" checkbox is selected under the configuration tab. Also, I'm still testing this, but I see the same error after trying to update the previous location device after it's already been set to the Home device. It might have something to do with the 0 value, but can't be sure. The same event was working yesterday when I was traveling around, so it may only be an error when trying to set it to the Home location for some reason.

                                Comment

                                Working...
                                X