Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OK I'm having an issue with iCloud (2 different accounts) not updating. All that is updating is Device state, Charging, Battery and Time at location (but not he actual minutes). I have re-authorized the iCloud accounts, stop and re-start the plugin, signed on the iCloud accounts via PC (they are showing the movement) and still no updates. Should I shutdown the plugin remove all the HS3 nodes and let the plugin rebuild everything?

    Comment


    • Originally posted by Bigstevep View Post
      OK I'm having an issue with iCloud (2 different accounts) not updating. All that is updating is Device state, Charging, Battery and Time at location (but not he actual minutes). I have re-authorized the iCloud accounts, stop and re-start the plugin, signed on the iCloud accounts via PC (they are showing the movement) and still no updates. Should I shutdown the plugin remove all the HS3 nodes and let the plugin rebuild everything?
      Have the phones moved more than the minimum distance? Nothing will update until the phones post a new location that is greater than the minimum distance to move.

      You can force an update by selecting ”Force update of position devices” under Other on Configuration, then manually polling the accounts.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • Yes one of the phones has a change in the items mentioned prior (again no update as of the minutes) and is 30 miles currently away from the last location in HS3 (I can login into the iCloud account and see it). Force update doesn't do anything different even after manual polling. Any other ideas or just rebuild the nodes?

        Comment


        • So I dumped the nodes and iCloud accounts now I have created the iCloud accounts and verified but in create device drop down there is no iCloud account pick to set up the device. Do I need to remove the plugin and start all over? My Geofency devices are working BTW

          Comment


          • Has this project stopped?
            There's been no new release sins January, and no post form developer.
            Anybody know?

            Comment


            • Paul has been called to help a friend’s business. He wrote to me that it was demanding much more time than he expected, leaving him very little time to spend on this project. He said he wanted to get back to it, but was unsure when he would have time again.

              My employment has similarly affected my ability to spend time on these forums, so I completely understand.

              All that being said, PHL2 is working perfectly for me. There is only one issue of expiring cookies for iCloud authorization tokens. I reset my accounts monthly to avoid getting nag emails from Apple. There have been two instances of Apple breaking the authorization scheme over the last 8 months. Once late last year and again a few months ago. Other than those two instances, mine has been working well since initial installation.

              PHL2 requires 2FA (2 factor authorization) to be used, it will not work with 2-step authorization. The one issue that Paul hoped to address is the expiration of the authorization tokens, but as of the last time we spoke, he still had not found a solution. He has not been able to find anything from Apple to allow the tokens to be persistent or to automatically renew.
              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


              • Originally posted by Bigstevep View Post
                Yes one of the phones has a change in the items mentioned prior (again no update as of the minutes) and is 30 miles currently away from the last location in HS3 (I can login into the iCloud account and see it). Force update doesn't do anything different even after manual polling. Any other ideas or just rebuild the nodes?
                I’m going to set up a test installation over the next day or so so I can test on a clean system. You should be able to delete iCloud devices and recreate them. You also should be able to “Rebuild Child Devices” under the root device.
                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                • Don't waste the time for me. I just dumped and rebuilt everything and it's all working.

                  Comment


                  • I find this works perfectly with GeoFency.
                    Love it!

                    Comment


                    • Originally posted by rprade View Post
                      Paul has been called to help a friend’s business. He wrote to me that it was demanding much more time than he expected, leaving him very little time to spend on this project. He said he wanted to get back to it, but was unsure when he would have time again.

                      My employment has similarly affected my ability to spend time on these forums, so I completely understand.

                      All that being said, PHL2 is working perfectly for me. There is only one issue of expiring cookies for iCloud authorization tokens. I reset my accounts monthly to avoid getting nag emails from Apple. There have been two instances of Apple breaking the authorization scheme over the last 8 months. Once late last year and again a few months ago. Other than those two instances, mine has been working well since initial installation.

                      PHL2 requires 2FA (2 factor authorization) to be used, it will not work with 2-step authorization. The one issue that Paul hoped to address is the expiration of the authorization tokens, but as of the last time we spoke, he still had not found a solution. He has not been able to find anything from Apple to allow the tokens to be persistent or to automatically renew.
                      Thanks for your update rprade

                      Comment


                      • Originally posted by MattL0 View Post
                        You can use geofency with the json api via myhs . No need for a plugin to run
                        Explain? How do you use Geofency without PHLOCATION?

                        Curious? Are there any guides or details?

                        Comment


                        • Originally posted by mjolsen View Post

                          Explain? How do you use Geofency without PHLOCATION?

                          Curious? Are there any guides or details?
                          Will do when I get home

                          Comment


                          • Originally posted by mjolsen View Post

                            Explain? How do you use Geofency without PHLOCATION?

                            Curious? Are there any guides or details?
                            Here you go .


                            Make sure ''Enable control using JSON '' under ''Remote Control Settings'' is activated ( Go to hs3_IP:Port/setup and click on Network tab).

                            -------------------


                            + Instead of using your MYHS username AND PASSWORD. you have the possibility to use a token

                            Here is an example to set the virtual device to the value ''1'' with the token :

                            https://myhs.homeseer.com/json?token...yvalue&ref=xxx

                            I have put random number here. But to generate a token from myhs you will need to take a look at myhstoken plugin.

                            https://forums.homeseer.com/forum/ul...lex-technology is it in the ''utility'' section on the plugin manage page

                            Attached Files

                            Comment


                            • Hi All. I got a new iphone. So i reset my icloud service account and authenticated the 2FA piece with no issue. When I try to poll the phone however i get the following message: PHLocation2 Error, (PollAccount) Auth failed for AppleId. and (idmsaAuthenticate) Missing result data for Ref:4538. I'm not sure why this is happening as the Phlocation 2 iCloud service shows that I've successfully verified it. Does anyone else have this issue?

                              Comment


                              • Updated today to v2 of this PI.

                                I'm experiencing the following issues:

                                1( Attitude has unknown status
                                2) Distance to home, drive time to home and time at location will not update

                                Click image for larger version

Name:	Capture - PHLocation.PNG
Views:	45
Size:	74.3 KB
ID:	1321635

                                ---
                                John

                                Comment

                                Working...
                                X