Announcement

Collapse
No announcement yet.

PHLocation V2 Discussion

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    i did check but no apple device is showing up at all.
    The verification went all correct with no problem.
    i did see post #60

    maybe i doing something wrong, but i checked the add user, but i cant choose any idevice.

    regards
    Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
    Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




    HS3Pro 3.0.0.523 on windows 7 ultimate X64 on hp quadcore laptop 8 GB.

    Comment


    • #92
      Jan-13 00:23:53 PHLocation2 Error (Logout) IC WebException for Ref:4142 Msg:The remote server returned an error: (421) Misdirected Request.
      Jan-13 00:23:51 PHLocation2 (SetIOMulti) Manual poll called for iCloud account: @gmail.com
      Jan-13 00:23:51 Device Control Device: PHLocation2 PHLocation2 Account Status to Poll (-1) by/from: CAPI Control Handler
      Getting these errors after deselecting ignore unknown devices

      i did try again and get this
      Jan-13 00:27:50 PHLocation2 Error (idmsaAuthenticate) webException for Ref: 4142 Ex:The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.
      Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
      Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




      HS3Pro 3.0.0.523 on windows 7 ultimate X64 on hp quadcore laptop 8 GB.

      Comment


      • #93
        Apple Family Sharing?

        Will PHL2 have the ability to see all devices in Family Sharing? Only the devices under the primary Apple ID (mine) show up.

        Thanks,

        Jim

        Comment


        • #94
          I did restart the plugin and it works good now, it shows up.
          Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
          Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




          HS3Pro 3.0.0.523 on windows 7 ultimate X64 on hp quadcore laptop 8 GB.

          Comment


          • #95
            For the Life360 error, I have restarted multiple times and it does not seem to have any effect.
            Billy Draper

            Comment


            • #96
              Originally posted by AutomatedJim View Post
              Apple Family Sharing?

              Will PHL2 have the ability to see all devices in Family Sharing? Only the devices under the primary Apple ID (mine) show up.

              Thanks,

              Jim
              No, I had to create service accounts for my wife and for me separately. iCloud only shows my devices, even though my wife is part of family sharing.
              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


              • #97
                Originally posted by bdraper View Post
                For the Life360 error, I have restarted multiple times and it does not seem to have any effect.
                I'll have to defer to Paul. Mine connected first try and all the users were there. So I know it can work.

                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                • #98
                  Originally posted by AutomatedJim View Post
                  Apple Family Sharing?

                  Will PHL2 have the ability to see all devices in Family Sharing? Only the devices under the primary Apple ID (mine) show up.

                  Thanks,

                  Jim
                  I've always had to add them with their own iCloud ID.
                  HS 3.0.0.531: 1985 Devices 1128 Events
                  Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

                  Comment


                  • #99
                    Randy, per chance do you have the URL's for ElevationApi and MapQuest that you used? Rather than looking through the haystack of information and "rabbit holes" it would help if we could go directly to the source(s).

                    We I now have the following established;
                    • iCloud Account
                    • Geofency Device with associated GeoFency fences (around 9)
                    • iCloud Device - My iPhone
                    I noticed that my iCloud and iCloud Device are working as the iCloud and iPhone particulars (devices) are updating. Only the GeoFency devices that are associated with my local LAN are being updated e.g. door iBeacons (2x) and vehicle iBeacon when I'm in the driveway. It appears that my GeoFency devices that are not associated with my local LAN e.g. Perimeter fences which are well beyond my local LAN and are dependent on external internet for their communications link are not working. As I have a Satellite internet connection with a dynamic IP address, I've been using NoIP to facilitate a static IP host which was working well so as you indicated I'm still working on the correct Port number. Question as I mention yesterday I have a different port for my HS3 rather than the standard port 80, I thought phlocate2 should also have this different port number to match what my HS3 is using or are you implying that PHLocate2 has to be set to port 80? Mike
                    Computer: CUK Intel NUC7i7BNH
                    Op System: Windows 10 Pro - Work Station
                    HS Version: HS3 Pro Edition 3.0.0.435

                    Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                    Comment


                    • Originally posted by rprade View Post
                      For those of you posting from 3rd party apps like GeoFency, PHL2 does not use its own web server, it uses the HS built-in server. The posting is still the same as before with two changes 1) it now uses your HomeSeer web server port (usually 80) so create your port forwarding rules and structure the URL accordingly. 2) The api is now phl2api, with the original it was phlapi. The dtypes are the same as listed in the PHL documentation.


                      If you are posting to GeoFency for example it will be:

                      MYHS:
                      https://connected2.homeseer.com/phl2api?dtype=GF
                      Use your MyHS login credentials

                      Direct through port forwarding:
                      http://[ddns domain name]:[external port]/phl2api?dtype=GF
                      if you have "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" no credentials are required, otherwise use your HS admin account credentials.

                      Direct through VPN:
                      http://[HS local IP]:[HS port - not required if 80]/phl2api?dtype=GF
                      if you have "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" no credentials are required, otherwise use your HS admin account credentials.
                      Randy, I was doing some further investigating, I turned my WiFi on my iPhone to OFF and use the browser and entered http://mnb.XXX.XXX:10210 which gave me a login screen, I entered my HS3 Admin account credentials which allowed me to see my HS3 Device Control Screen. Looking at my Setup >Network tab I noticed that under "Web Server Settings" I have the "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" enabled so... I'm not sure why I'm being prompted for credentials.

                      Question based on my particulars how/where do I enter HS3 User Name/Password? Mike

                      UPDATE: Never mind I forgot that the Username and Password is in the GeoFency app. I told you I'm a little slow... lo and behold I am able to successfully test both Entry and Exit within the GeoFency app.
                      Last edited by rprade; January 14th, 2019, 09:17 PM. Reason: corrected URL
                      Computer: CUK Intel NUC7i7BNH
                      Op System: Windows 10 Pro - Work Station
                      HS Version: HS3 Pro Edition 3.0.0.435

                      Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                      Comment


                      • Ok now that I'm up and running what is the pro/con using MYHS vs Direct through port forward vs VPN is there a lag (time) penalty going through MYHS? Mike
                        Computer: CUK Intel NUC7i7BNH
                        Op System: Windows 10 Pro - Work Station
                        HS Version: HS3 Pro Edition 3.0.0.435

                        Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                        Comment


                        • Originally posted by MNB View Post
                          Randy, per chance do you have the URL's for ElevationApi and MapQuest that you used? Rather than looking through the haystack of information and "rabbit holes" it would help if we could go directly to the source(s).

                          We I now have the following established;
                          • iCloud Account
                          • Geofency Device with associated GeoFency fences (around 9)
                          • iCloud Device - My iPhone
                          I noticed that my iCloud and iCloud Device are working as the iCloud and iPhone particulars (devices) are updating. Only the GeoFency devices that are associated with my local LAN are being updated e.g. door iBeacons (2x) and vehicle iBeacon when I'm in the driveway. It appears that my GeoFency devices that are not associated with my local LAN e.g. Perimeter fences which are well beyond my local LAN and are dependent on external internet for their communications link are not working. As I have a Satellite internet connection with a dynamic IP address, I've been using NoIP to facilitate a static IP host which was working well so as you indicated I'm still working on the correct Port number. Question as I mention yesterday I have a different port for my HS3 rather than the standard port 80, I thought phlocate2 should also have this different port number to match what my HS3 is using or are you implying that PHLocate2 has to be set to port 80? Mike
                          As I wrote at the beginning of the thread ElevationAPI, does not require a key, so I don't know what you mean by URL. Just select ElevationAPI as the provider. For Mapquest I used https://developer.mapquest.com and created a new account and got a free key.


                          For local access GeoFency would post to the IP address of your HS server and its port number if different than 80. For external access you would need a port forwarding rule in your router. The forwarding rule would be from an external port of your choice, forwarded to the IP and port number of your HS server. Then your phone would post to the No-Ip domain and external port you chose. If it was working before, you would just need to modify the port forwarding rule. PHL1 defaulted to 8026, you would just change that to the port of your HS# server.

                          I highly recommend you consider MyHS. The security is much better than exposing your HS server to the Internet. If you do choose to port forward to your HS server, make sure all of your passwords for HS accounts are strong and be aware that since it is not secure connection, even strong passwords are exposed whenever GeoFency posts.
                          Randy Prade
                          Aurora, CO
                          Prades.net

                          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                          Comment


                          • Originally posted by MNB View Post

                            Randy, I was doing some further investigating, I turned my WiFi on my iPhone to OFF and use the browser and entered http://mnb.XXX.XXX:10210 which gave me a login screen, I entered my HS3 Admin account credentials which allowed me to see my HS3 Device Control Screen. Looking at my Setup >Network tab I noticed that under "Web Server Settings" I have the "No Password Required for Local/Same Network Login (Web Browser/HSTouch)" enabled so... I'm not sure why I'm being prompted for credentials.

                            Question based on my particulars how/where do I enter HS3 User Name/Password? Mike

                            UPDATE: Never mind I forgot that the Username and Password is in the GeoFency app. I told you I'm a little slow... lo and behold I am able to successfully test both Entry and Exit within the GeoFency app.
                            When you are port forwarded to HS3 you are NOT a local user, nor are you on the same network.
                            Randy Prade
                            Aurora, CO
                            Prades.net

                            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                            Comment


                            • Originally posted by MNB View Post
                              Ok now that I'm up and running what is the pro/con using MYHS vs Direct through port forward vs VPN is there a lag (time) penalty going through MYHS? Mike
                              MyHS responds within a second, about the same as my VPN or as port forwarding. Your satellite may have greater latency, it usually does, but that would be in milliseconds, hardly an issue. Satellite latency will equally affect MyHS and VPN. Configuring a VPN is not extraordinarily difficult, but it is not without challenges. I used MyHS for more than 6 months without a single missed posting, I am only experimenting with a VPN.

                              Randy Prade
                              Aurora, CO
                              Prades.net

                              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                              Comment


                              • I'm inclined to agree with you Randy that I should use the MYHS route not that it's big deal to change. Randy and Paul, many thanxs for helping and facilitating the "clue-less" I'm talking in reference to myself only so there's no need for others out there to take offence . Now that I'm up and working it's time to modify my Events.

                                Paul did I see a post from you this late in the evening? Mike
                                Computer: CUK Intel NUC7i7BNH
                                Op System: Windows 10 Pro - Work Station
                                HS Version: HS3 Pro Edition 3.0.0.435

                                Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                                Comment

                                Working...
                                X