Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Geofency and RadBeacon issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Geofency and RadBeacon issue

    I’m relatively new to this, so I’m hoping I can just adjust a setting.

    I have a USB RadBeacon in my car with PHLocation, and for the most part it is working fine (about a week or so). In the last three days I’ve noticed the beacon detection was not updating - twice

    After checking things in geofency and HS. It appears geofency shows the history correctly, but the HS does not. (Only incorrect twice). In both cases, i was in my car, made a quick stop and was back in the car less than a minute later. In geofency, it showed correctly. But in HS, it triggered - not in range when I got out of my car, but then never updated when I got back in less than a minute later. (then drove for 5 plus minutes)

    Any ideas (not sure if this is a geofency thing or HS thing).

    I noticed in geofency under settings there is a presence limit and absence limit. Both are set to off. Should one or both of these be changed
    (for geofency, I use the MyHS connection - it seems instantaneous, other than those two times)

    Any thoughts would be appreciated, am hoping for some direction before I do some trial and error.

  • #2
    Hi

    First have you looked in your HS log file what was logged at for your ibeacon device around the time of the problem ?

    you should see two lines, one that turn on your device and if HS catches you going out you should have a line that turn off the device:
    mars-24 18:02:39 Device Control Device: Bruno in his truck to On (100)
    mars-24 18:02:39 Device Control Device: Bruno in his truck to Off (0)
    If you don't have both lines then you can look further on the phone side, possibly phone network issue that prevented the "out" command to be sent

    Comment


    • #3
      Ok, now I need to feel a little stupid.

      I am unable to get any of the PHLocation devices to show in the log. At this point I was only looking at the last change on the device screen.

      How do I get them to show in the logs. Under the device config -
      Do not log commands from this device:
      I have this unchecked.

      I’ve looked everywhere else but can’t find anything.

      Comment


      • #4
        Originally posted by theroefam View Post
        Ok, now I need to feel a little stupid.

        I am unable to get any of the PHLocation devices to show in the log. At this point I was only looking at the last change on the device screen.

        How do I get them to show in the logs. Under the device config -
        Do not log commands from this device:
        I have this unchecked.

        I’ve looked everywhere else but can’t find anything.
        You don't have to activate anything, at least this is my understanding, everytime yout Geofency detects you enter or exit an ibeacon region then it send an HTTP POST to your HS3 server via the webhook you have configured on your Geofency device. Once this HTTP POST is received by your HS3 server it should create a new entry in your HS3 log file with a Type/Error equal to "DEVICE CONTROL" and a Message/source correspodance containing the Device Name of your PHLocation equivalent Device like this:

        Click image for larger version

Name:	geofency.JPG
Views:	35
Size:	32.7 KB
ID:	1372677

        Comment


        • #5
          Just a comments since there are a lot more experienced users here than I am...

          I see logged fence events in my log only...not in/out of range of any of my beacons...I don't know what's tripping that for goldriver, but guessing an app setting and not in HS. The following is my output from a trip. It didn't log me coming in range of the USB ibeacon in my jeep...The geofence it's referring to is the one around my house...and it's the event that is logging.
          Mar-24 7:17:56 PM Event Event Trigger "Geofence Cherokee coming home"
          Mar-24 7:00:56 PM Event Event Trigger "Geofence Tom and Kim leaving home in Cherokee together"
          It only logged crossing a fence via the event. The ONLY fences I have defined are around my house. I tried one for all of Denver and it was filling up my log with location settings. Anyway, my guess is goldriver is exactly right about cell service. If the message doesn't get to the Internet it seems the the app never sends the message again...thus no status change.

          Until about 4-5 months ago the cell service was bad around my house and quite often my phone saw changes that never made it to HS when I crossed my fence as well.

          The funny part is my devices in HS3 do update, but they do not log. My guess that it a phone setting is likely wrong, but would make sense from a phone battery perspective

          Comment


          • #6
            Thanks for the reply’s. Correct ‘ts1234’ mine do not log...same as you. But it appears ‘goldriver’ does log. And I agree most of the time it works fine(the events will trigger). The two cases I had was when I jumped out of my car for less than a minute. It recorded in geofency, but only the exit recorded in HS not the re-entry. That didn’t really feel like a cell issue, it felt moe like a settings issue.

            Goldriver - as for as the log... I sorted for device control today and here is what I have...
            Log
            But then on my devices I can see where some of the PHLocations have changed today
            Click image for larger version

Name:	10A7F4C2-A6F6-4128-8826-D0215642200E.jpeg
Views:	33
Size:	18.1 KB
ID:	1372715

            Any suggestions on
            1) getting the PHLocation devices to show in the log
            2) Missing updates on geofency beacon

            Thanks for the help
            Scott

            Comment


            • #7
              Do both entry and exit test out in your Geofency app? If not, it may be in the app settings. If they do...then cell.

              Comment


              • #8
                I have been getting more frequent missed entry or exit events from Geofency as of late. They are usually related to the MyHS service briefly becoming unreachable (usually DNS cache issue or load balancer failover). See here: https://forums.homeseer.com/forum/ho...access-service

                Comment


                • #9
                  Yes...just another issue that makes this flaky and why I think we're doing this all backwards...as far as arrival and departure to your home works... as I've mentioned in other posts. Add cell service and other issues to it...

                  My log is full of...
                  Mar-29 7:46:13 AM Warning MyHS could not connect to server: No such host is known
                  Mar-29 7:46:02 AM Warning Have not heard from MyHS in over 3 minutes, disconnecting for re-connection.
                  If the root of the problem is not in transport to their servers...which in 2020 I kind of doubt. It is very reason I left Smartthings and came to HS since at least the zwave stuff is all local. I wonder if their server farm is just overloaded, though I would think it actually lives some place like AWS which just correlates probably to $$$'s.

                  Maybe one the the smart guys around here knows...

                  Comment

                  Working...
                  X