Announcement

Collapse
No announcement yet.

Distance to home not updating any more on PHLocation2 on HS4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eman
    replied
    Google made extra configurations on how APIs are used. There is too much to go through... also make sure you not restricting yourself from some parts of the API. I don't know if this : https://cloud.google.com/docs/authen...617684577&rd=1 adds value but worth looking into.


    *** Just also hopping that non of the browsers (web) on devices like IPAD or desktop at work or at home are not left logged in your Google account when you are mobile...

    Eman.

    Leave a comment:


  • mikee123
    replied
    I was too busy yesterday to change anything, and this morning distance to home started updating again. Phew. No idea why all of a sudden its working again, but never mind.
    But not everything is back as it should.
    The device current location is stuck on multiple locations. It does not change to work or home. Nearest location works, its showing distance to work or home, whichever is closest, so as it should. Anything regarding device address has a reverse geo error. I used to get those occasionally, then all of a sudden they disappear and show address, postcode etc again. But this is stuck now for a few days.
    Attached Files

    Leave a comment:


  • Eman
    replied
    Originally posted by mikee123 View Post

    I have synced places a few times, it did not do anything unfortunately
    Delete Home Location in the Phone App then HomeSeer and recreate. The Device ID should change by design....


    Eman.

    Leave a comment:


  • mikee123
    replied
    Originally posted by Eman View Post
    Can this : https://jphuddlestone.co.uk/phlocati...e/Life360.html help? Somewhere along the lines it stipulates to Sync Palaces...

    Related : https://jphuddlestone.co.uk/phlocati...ReadFirst.html

    Eman.
    I have synced places a few times, it did not do anything unfortunately

    Leave a comment:


  • mikee123
    replied
    Originally posted by racerfern View Post
    Thinking out loud here, anything to do with some mix of metric and imperial? I see 15 metres, 87.6 miles. I have everything in imperial.
    I always had everything except accuracy in imperial. Not sure why accuracy is in meters tbh, it never bothered me so never tried to change it.

    Leave a comment:


  • Eman
    replied
    Can this : https://jphuddlestone.co.uk/phlocati...e/Life360.html help? Somewhere along the lines it stipulates to Sync Palaces...

    Related : https://jphuddlestone.co.uk/phlocati...ReadFirst.html

    Eman.

    Leave a comment:


  • racerfern
    replied
    Thinking out loud here, anything to do with some mix of metric and imperial? I see 15 metres, 87.6 miles. I have everything in imperial.

    Leave a comment:


  • mikee123
    replied
    I am also on 3.0.0.64

    I have noticed a few strange things. On the way home from work, I was watching the PHLocation devices. The distance to home was increasing ! At the same rate, distance to work was also increasing (which makes sense). Before I left work, I created a new location in the Life360 app, I added a Gym location. I entered my home address, the same as I have for home in Life360... now that distance decreased on the way home, once arrived at home nearest location is gym with 0.032m distance. Home (remember, same location is now 64.8m away)
    I double checked known locations in HS4 the PH PI, they are correct and the same as home and gym...

    Hard to get your head around that... well I cant understand it no matter how hard I try...

    All I could do is use Gym as home location. But that does not come up as known location (only shows as nearest). It shows as multiple locations in the Life360 current location device
    Attached Files

    Leave a comment:


  • racerfern
    replied
    mikee123 I didn't delete anything, I simply clicked that button. I don't even remember what the original issue was but right away both devices started working as I expected.


    What version of the PI are you on? I'm on 3.0.0.64

    Leave a comment:


  • mikee123
    replied
    Originally posted by racerfern View Post
    I had an issue recently with Life 360PI and I ended up clicking on "rebuild child devices".
    Plugins > PHLocation2 > Users/Devices > Edit (for the device in question) > "Rebuild Child Devices" at the bottom. It fixed everything at least for me.
    I have tried that, but did not change anything. did you delete any devices before you tried to rebuild ?

    I have also tried changing my home address in the Life360 app without any success. I have added a few more places in the Life360 app to see if they track. My 'Work' place in the app seems to work, as my current location in the phlocation child device it shows as work with a distance of 0.052m

    Leave a comment:


  • racerfern
    replied
    I had an issue recently with Life 360PI and I ended up clicking on "rebuild child devices".
    Plugins > PHLocation2 > Users/Devices > Edit (for the device in question) > "Rebuild Child Devices" at the bottom. It fixed everything at least for me.

    Leave a comment:


  • mikee123
    replied
    Originally posted by mrceolla View Post
    Are you sure your Known Location for "Home" is setup correctly? I don't use Life360 but for my setup the Known Location is required to get things like "Distance from Home" to work.
    It shows right in Life360, so should (and has in the past) update the Life360 devices in HS4. Everything else updates. I am thinking I might uninstall PHLocation over the weekend and reinstall. Are there install instructions in the PHLocation folder somewhere ? Cant remember how to install its since it first was released... never had any issue since.

    Leave a comment:


  • mrceolla
    replied
    Are you sure your Known Location for "Home" is setup correctly? I don't use Life360 but for my setup the Known Location is required to get things like "Distance from Home" to work.

    Leave a comment:


  • mikee123
    replied
    Originally posted by Eman View Post
    Make sure nothing else (computers..etc .at home) are logged in to Google Location services or in other words you can't be at 2/more places at the same time....


    Eman.
    I checked. Thats not the problem

    Leave a comment:


  • Eman
    replied
    Make sure nothing else (computers..etc .at home) are logged in to Google Location services or in other words you can't be at 2/more places at the same time....


    Eman.

    Leave a comment:

Working...
X