Announcement

Collapse
No announcement yet.

Plugin works for a few seconds then disconnects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Plugin works for a few seconds then disconnects

    I am using this modem: https://www.amazon.com/gp/product/B00BD1NPCU

    The plugin works for a few seconds then says "Watchdog timer failed communicating with modem: Unsupported feature: WatchDogFeature: Send AT to the gateway (Error in command AT : ERROR )"

    I get the error: "Error in command AT+CPMS? : ERROR"

    However, if I disable the plugin and send "AT+CPMS?" to the COM port I get:
    "+CPMS: "SM",0,50,"SM",0,50,"SM",0,50"

    What can I do to fix this? Thanks!

    #2
    Here is the full log:
    Code:
    Aug-30 8:20:15 PM	 	SMS-Gateway Debug	Could not retrieve accurate SIM storage information.
    Aug-30 8:20:14 PM	 	SMS-Gateway Debug	Refreshing storage data - erasing messages if phone memory is full.
    Aug-30 8:20:14 PM	 	SMS-Gateway Debug	UpdateRssi Called - retrieving values from device
    Aug-30 8:20:14 PM	 	SMS-Gateway Debug	Checking for messages received while offline (no events will be processed for these messages)
    Aug-30 8:20:12 PM	 	Vista Alarm	FAULT 05 DINING ROOM MOTION
    Aug-30 8:20:09 PM	 	SMS-Gateway Debug	Inboud PDU not supported - contact devleoper with phone make/model (text mode may cause errors)
    Aug-30 8:20:08 PM	 	SMS-Gateway Debug	Enabling detailed error messages: Error in command AT+CMEE=1 : ERROR
    Aug-30 8:20:08 PM	 	SMS-Gateway	Retrieved SMSC () from modem, storing in INI file for future reference
    Aug-30 8:20:08 PM	 	SMS-Gateway Debug	Trying to get the SMSC from the modem itself
    Aug-30 8:20:07 PM	 	SMS-Gateway Debug	Using SIM card storage for send/receive - it's not the biggest but is the most reliable
    Aug-30 8:20:07 PM	 	SMS-Gateway	Connected to SMS Gateway
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Connectecting on COM2 with Baud 115200 | DataBits Eight | Parity None | StopBits One
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	InitSMS() called
    Aug-30 8:19:50 PM	 	Plug-In	Finished initializing plug-in SMS-Gateway
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Found existng Signal device with address: SMS-Signal
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Found existng Sender device with address: SMS-Sender
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Found existng Message device with address: SMS-Message
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Found existng Date device with address: SMS-Date
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	NLog v4.0.0.0
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	Toolkit.Core v1.8.1.0
    Aug-30 8:19:50 PM	 	SMS-Gateway	Initialising SMS-Gateway v3.3.4.18307 on COM2
    Aug-30 8:19:50 PM	 	SMS-Gateway Debug	OS is windows and port is COM2
    Aug-30 8:19:50 PM	 	Info	Plugin SMS-Gateway has connected. IP:127.0.0.1:53963
    Aug-30 8:19:49 PM	 	Plug-In	Interface SMS-Gateway is running as a trial, 28 days remaining.

    Comment


      #3
      Can you try a direct "AT+CMEE=1" command to the modem and tell me what response you get please?

      Also, please enable debug logging and log to file and look in the \logs folder - you should see 2 log files created by the plugin. Please mail them to me (there's a lot of data in there to publish to a public forum). gavin @ highpeak.co.za
      Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

      Comment


        #4
        Originally posted by beerygaz View Post
        Can you try a direct "AT+CMEE=1" command to the modem and tell me what response you get please?

        Also, please enable debug logging and log to file and look in the \logs folder - you should see 2 log files created by the plugin. Please mail them to me (there's a lot of data in there to publish to a public forum). gavin @ highpeak.co.za
        When I first sent "AT+CMEE=1", the modem responded with "ERROR" then about 5 seconds later responded with "OK". When I sent it again after that, it responded with "OK".

        Could it be a bad modem? The one I had previously connected to the plugin just fine but was the wrong frequency for my country (US). This one is the same make/model but for US GSM frequencies.

        I'm sending you the logs right now. Thanks for helping me out!

        Comment


          #5
          I also tried using another modem that I have (this one: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1)

          I have the same errors with the plugin that I had before (Error in command AT+CMEE=1 : ERROR) and (Error in command AT : ERROR).

          I can send "AT+CMEE=1" just fine on the modem and receive an "OK" in response.

          When I check the plugin modem log, I can send each one of those commands individually without an error, but it seems the plugin itself invokes an error in response.

          Anything else I can try?

          The only modem I've gotten it to work with was one with the wrong GSM Frequency that I ended up returning.

          Comment


            #6
            Can you grab the latest version from the updater. Stop the plugin. Then manually edit the HSPI_SMSGW.INI file in the \Config folder. You should see a line:

            COMMANDWAITINTERVAL=300
            set that to

            COMMANDWAITINTERVAL=500
            Save the file and start the plugin.

            I'm trying to work out if this is a timing issue or something else.

            Thanks for your patience.

            Gavin
            Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

            Comment


              #7
              Originally posted by beerygaz View Post
              Can you grab the latest version from the updater. Stop the plugin. Then manually edit the HSPI_SMSGW.INI file in the \Config folder. You should see a line:



              set that to



              Save the file and start the plugin.

              I'm trying to work out if this is a timing issue or something else.

              Thanks for your patience.

              Gavin
              I'm having the same issue I had before. I narrowed it down, however.

              I can send all the commands that the plugin sends to the modem just fine except for "AT+COPS=0,2".

              If I send "AT+COPS=0,2", the modem hangs and everything sent after that results in "ERROR" until I manually reset the modem.

              I noticed that the plugin starts communicating with the modem and then as soon as "Sending: AT+COPS=0,2" happens in the modem log, every command after that results in "ERROR".

              Is it possible to have the PI not send that command and leave the modem in automatic network selection mode?

              EDIT: I can get the plugin working pretty well if I wait until the modem is done searching and connects to the network, then enable the plugin. If I do this, the plugin connects, can send all the commands, and can send/receive messages properly.
              Last edited by bphillips; September 2, 2016, 12:47 PM.

              Comment


                #8
                That command tells the modem to automatically select an operator. Can you try AT+COPS? manually from a terminal and post the result?

                You do have a working SIM card installed that is registered to your operators network right?


                Sent from my iPhone using Tapatalk
                Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                Comment

                Working...
                X