Announcement

Collapse
No announcement yet.

Warnings And Errors During UltraCID Startup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I have turned on Debug, restarted HomeSeer and called myself. I still see the errors and cannot explain why. When I query the Modem directly it immediately responds and there is no delay.

    I am running the same modem you bought from eBay and I am running a clean install of Windows XP Pro (SP3) dedicated to HomeSeer.

    Let me know what other data I can get for you.
    Attached Files
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

    Comment


      #17
      Please download the version I just uploaded to the HomeSeer updater and let me know if that fixes the issue.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


        #18
        Originally posted by jeanv View Post
        I have turned on Debug, restarted HomeSeer and called myself. I still see the errors and cannot explain why. When I query the Modem directly it immediately responds and there is no delay.

        I am running the same modem you bought from eBay and I am running a clean install of Windows XP Pro (SP3) dedicated to HomeSeer.

        Let me know what other data I can get for you.
        Yes, I see a very strange serial port buffering issue. I see the debug output reports the commands completed successfully about 2 seconds later which is why the modem is working.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


          #19
          Have you had a chance to try the new version I uploaded to the HomeSeer updater?
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


            #20
            I am SOOOO sorry. I had not gotten a chance to test it and had not been home the last 4 days. I am going to install and test right now! I will give you feedback right away.

            Thanks so much!
            ---------------------------------------------------
            Jean-Marie G. Vaneskahian
            jean@vaneskahian.com
            ---------------------------------------------------

            Comment


              #21
              I am still seeing the same initialization warnings and errors in the log. What would you like me to try?


              9/17/2012 8:55:54 AM ~!~Startup~!~
              9/17/2012 8:55:54 AM ~!~Startup~!~*********************************************** *********************************
              9/17/2012 8:55:54 AM ~!~Startup~!~ HomeSeer version 2.5.0.55 Starting Now (Standard Build)
              9/17/2012 8:55:54 AM ~!~Startup~!~*********************************************** *********************************
              9/17/2012 8:55:54 AM ~!~Startup~!~
              9/17/2012 8:55:54 AM ~!~Startup~!~Using system's regional settings
              9/17/2012 8:55:54 AM ~!~Startup~!~Creating Class Objects...
              9/17/2012 8:55:54 AM ~!~Startup~!~COM port classes started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Application interface class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Web server class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~E-Mail SEND class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~E-Mail RECEIVE class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Z-Wave class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Plug-In Interface class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Speech recognition class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~HSPhone dialer class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Loading Settings
              9/17/2012 8:55:54 AM ~!~Startup~!~Settings Loaded.
              9/17/2012 8:55:54 AM ~!~Startup~!~Current sunrise/sunset values calculated.
              9/17/2012 8:55:54 AM ~!~Startup~!~HSPhone external interface class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Local voice recognition class started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Database SAVE process started.
              9/17/2012 8:55:54 AM ~!~Startup~!~Loading configuration file ...
              9/17/2012 8:55:54 AM ~!~System~!~Loading device types file...
              9/17/2012 8:55:54 AM ~!~Database~!~Opening (Mode=Read) up HomeSeer database: C:\Program Files\HomeSeer HS2\Config\jarvis.mdb
              9/17/2012 8:55:54 AM ~!~Database~!~Loading Devices...
              9/17/2012 8:55:54 AM ~!~Load Config~!~182 total devices loaded.
              9/17/2012 8:55:54 AM ~!~Load Config~!~Checking device type settings for all devices...
              9/17/2012 8:55:54 AM ~!~Load Config~!~Finished checking device type settings.
              9/17/2012 8:55:54 AM ~!~Load Config~!~Loading Events...
              9/17/2012 8:55:54 AM ~!~Load Config~!~20 total events loaded.
              9/17/2012 8:55:54 AM ~!~Database~!~HomeSeer configuration database C:\Program Files\HomeSeer HS2\Config\jarvis.mdb has been closed.
              9/17/2012 8:55:54 AM ~!~Startup~!~HomeSeer version is: 2.5.0.55
              9/17/2012 8:55:54 AM ~!~Startup~!~Starting remoting (Remote client connection monitor)
              9/17/2012 8:55:54 AM ~!~Startup~!~Creating Speaker Client Interface Object...
              9/17/2012 8:55:55 AM ~!~Startup~!~Initializing phone interface...
              9/17/2012 8:55:55 AM ~!~HSPhone~!~HomeSeer Phone Web Interface initializing.
              9/17/2012 8:55:55 AM ~!~Startup~!~Checking for pending updates to be installed...
              9/17/2012 8:55:55 AM ~!~Startup~!~Restoring Device Status...
              9/17/2012 8:55:55 AM ~!~Startup~!~Checking for available plug-ins
              9/17/2012 8:55:55 AM ~!~Plug-In~!~Found plug-in: AC-RF2 Processor, version: 1.4.4385.31464
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: BLIcon, version: 1.0.56.0
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: BLRadar, version: 1.0.96.0
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: Current Cost, version: 1.0.0.57
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: HAI RC Thermostat, version: 1.0.16.0
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: Insteon, version: 1.7.2.5
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: mcsTemperature, version: 6.2.0.14
              9/17/2012 8:55:56 AM ~!~Plug-In~!~Found plug-in: RFXCOM, version: 15.0.0.12
              9/17/2012 8:55:57 AM ~!~Plug-In~!~Found plug-in: UltraCID, version: 1.1.4639.35518
              9/17/2012 8:55:57 AM ~!~Startup~!~Initializing Plug-Ins
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~Register Callback completed
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~BLRadar version is: 1.0.96.0
              9/17/2012 8:55:57 AM ~!~Plug-In~!~Initializing Plug-in: BLRadar
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~Initializing BLRadar...
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~Loaded configuration successfully
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~BLRadar Debug Logging is Enabled!
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~Sensors and Active Zones have been loaded.
              9/17/2012 8:55:57 AM ~!~BLRadar start~!~User Defined Motion Code has been loaded
              9/17/2012 8:55:59 AM ~!~BLRadar start~!~BLRadar plugin has been initialized
              9/17/2012 8:55:59 AM ~!~Plug-In~!~Finished initializing plug-in BLRadar
              9/17/2012 8:55:59 AM ~!~Plug-In~!~Initializing Plug-in: HAI RC Thermostat
              9/17/2012 8:55:59 AM ~!~startup~!~Initialized HAI Thermostat Plug-in
              9/17/2012 8:55:59 AM ~!~COM Plugin~!~Calling InitIO
              9/17/2012 8:55:59 AM ~!~Plug-In~!~Finished initializing plug-in HAI RC Thermostat
              9/17/2012 8:55:59 AM ~!~AC-RF2 Processor~!~AC-RF2 Processor Plugin Version Release 1.4.4385.31464 Has Registered. Plugin Copyright (c) 2000-2012 AutomationCraft, LLC.
              9/17/2012 8:55:59 AM ~!~AC-RF2 Processor~!~Application path: C:\Program Files\HomeSeer HS2
              9/17/2012 8:55:59 AM ~!~AC-RF2 Processor~!~Last version run against INI: 1.4.4385.31464
              9/17/2012 8:55:59 AM ~!~Plug-In~!~Initializing Plug-in: AC-RF2 Processor
              9/17/2012 8:55:59 AM ~!~AC-RF2 Processor~!~Device #1 Initializing - (W800RF32 receiver on Com 2)
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~The RF receiver was initialized on Com 2 - Ready to start I/O
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Serial service library started. Listening to inbound RF data.
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'ACRF2 Plugin ACRF2 Device Monitor', XCode ']4'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'Garage OS - 001 - Motion Sensor', XCode ']5'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'Garage OS - 003 - Door Sensor', XCode ']6'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'Garage OS - 004 - Motion Sensor', XCode ']7'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'Garage OS - 005 - Motion Sensor', XCode ']8'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'Master Closet OS - 006 - Door Sensor', XCode ']9'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'System Keyfob 1', XCode ']10'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Found existing device in HS DB, updating 'System Keyfob 2', XCode ']11'
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~Serial data RF processing thread has started.
              9/17/2012 8:56:00 AM ~!~AC-RF2 Processor~!~System/Device maintenance thread started.
              9/17/2012 8:56:01 AM ~!~Plug-In~!~Finished initializing plug-in AC-RF2 Processor
              9/17/2012 8:56:01 AM ~!~BLIcon start~!~Register Callback completed
              9/17/2012 8:56:01 AM ~!~BLIcon start~!~BLIcon version is: 1.0.56.0
              9/17/2012 8:56:01 AM ~!~Plug-In~!~Initializing Plug-in: BLIcon
              9/17/2012 8:56:01 AM ~!~BLIcon start~!~Initializing BLIcon...
              9/17/2012 8:56:01 AM ~!~BLIcon start~!~Loaded configuration successfully
              9/17/2012 8:56:02 AM ~!~BLIcon start~!~Devices have been loaded.
              9/17/2012 8:56:02 AM ~!~BLIcon start~!~BLIcon plugin has been initialized
              9/17/2012 8:56:02 AM ~!~Plug-In~!~Finished initializing plug-in BLIcon
              9/17/2012 8:56:02 AM ~!~Plug-In~!~Initializing Plug-in: Insteon on COM port 1
              9/17/2012 8:56:03 AM ~!~Insteon~!~RF PLM contacted on COM1 with an Insteon address of 1C.FB.C8 and firmware version 99
              9/17/2012 8:56:04 AM ~!~Insteon~!~Waiting to initialize External Devices...
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Finished initializing plug-in Insteon
              9/17/2012 8:56:04 AM ~!~RFXCOM~!~Restricted for use with RFXCOM receivers/transmitters/transceivers only!
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Initializing Plug-in: RFXCOM
              9/17/2012 8:56:04 AM ~!~RFXCOM~!~(InitTRX) Connect Transceiver #1 on COM19
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Finished initializing plug-in RFXCOM
              9/17/2012 8:56:04 AM ~!~Current Cost~!~Register callback completed
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Initializing Plug-in: Current Cost on COM port 4
              9/17/2012 8:56:04 AM ~!~Current Cost~!~Current Cost Startup Complete.
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Finished initializing plug-in Current Cost
              9/17/2012 8:56:04 AM ~!~Current Cost~!~Initializing Current Cost on COM port 4
              9/17/2012 8:56:04 AM ~!~Current Cost~!~Opening COM port at 57600 for newer Envi units
              9/17/2012 8:56:04 AM ~!~Current Cost~!~Updating ALL projected values
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered Version() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Info~!~UltraCID version 1.1.4639.35518 starting ...
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~RegisterMenu callback executing...
              9/17/2012 8:56:04 AM ~!~Plug-In~!~Initializing Plug-in: UltraCID
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered InitIO() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Info~!~UltraCID - initializing I/O ...
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered InitHW() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Initiating connection to COM18...
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered InitPluginDevices() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Verification of base IO code '#' for device class 'BaseClass' complete. Code currently in use.
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered CreatePluginDevices() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing CID Monitoring State Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing CID Database Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing Phone Extension Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing Last Caller Name Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing Last Caller Number Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing Last Caller Attributes Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Updating existing Last Caller Rings Device
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~ProcessCommandQueue Thread Started
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Attemping to enable modem caller ID ...
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Sending command: 'ATQ0V1E0' to modem, attempt # 1
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Sending ATQ0V1E0 to modem serial port ...
              9/17/2012 8:56:04 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:06 AM ~!~UltraCID Debug~!~Waited 2062 milliseconds for the command response.
              9/17/2012 8:56:06 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'ATQ0V1E0'
              9/17/2012 8:56:06 AM ~!~UltraCID Debug~!~Sending command: 'ATQ0V1E0' to modem, attempt # 2
              9/17/2012 8:56:06 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:06 AM ~!~UltraCID Debug~!~Sending ATQ0V1E0 to modem serial port ...
              9/17/2012 8:56:06 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:08 AM ~!~UltraCID Debug~!~Waited 2062 milliseconds for the command response.
              9/17/2012 8:56:08 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'ATQ0V1E0'
              9/17/2012 8:56:08 AM ~!~UltraCID Debug~!~Sending command: 'ATQ0V1E0' to modem, attempt # 3
              9/17/2012 8:56:08 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:08 AM ~!~UltraCID Debug~!~Sending ATQ0V1E0 to modem serial port ...
              9/17/2012 8:56:08 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:10 AM ~!~UltraCID Debug~!~Waited 2062 milliseconds for the command response.
              9/17/2012 8:56:10 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'ATQ0V1E0'
              9/17/2012 8:56:10 AM ~!~UltraCID Debug~!~Sending command: 'AT+GMM' to modem, attempt # 1
              9/17/2012 8:56:10 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:10 AM ~!~UltraCID Debug~!~Sending AT+GMM to modem serial port ...
              9/17/2012 8:56:10 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:12 AM ~!~UltraCID Debug~!~Waited 2062 milliseconds for the command response.
              9/17/2012 8:56:12 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+GMM'
              9/17/2012 8:56:12 AM ~!~UltraCID Debug~!~Sending command: 'AT+GMM' to modem, attempt # 2
              9/17/2012 8:56:12 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:12 AM ~!~UltraCID Debug~!~Sending AT+GMM to modem serial port ...
              9/17/2012 8:56:12 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:14 AM ~!~UltraCID Error~!~Failed to initialize caller ID. The command at+vcid=1 failed.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered InitializeDatabase() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered OpenDBConn() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Info~!~Database initialization complete. Ready to accept HomeSeer events into database.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered GetSetting() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Section: Settings, Key: Version, Value: 1.1.4639.35518
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered Version() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered Version() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered SaveSetting() subroutine.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Section: Settings, Key: Version, Value: 1.1.4639.35518
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Table tblCallerLog exists.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Table tblCallerDetails exists.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered GetSetting() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Section: DBSchema, Key: Version, Value: 1.0.1
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered SaveSetting() subroutine.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Section: DBSchema, Key: Version, Value: 1.0.1
              9/17/2012 8:56:14 AM ~!~Error~!~Initializing interface: UltraCID->Could not initialize modem caller ID!
              9/17/2012 8:56:14 AM ~!~Plug-In~!~Finished initializing plug-in UltraCID
              9/17/2012 8:56:14 AM ~!~Plug-In~!~Initializing Plug-in: mcsTemperature
              9/17/2012 8:56:14 AM ~!~mcsTemperature~!~Version 6.2.14 Registered with Homeseer
              9/17/2012 8:56:14 AM ~!~COM Plugin~!~Calling InitIO
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Waited 2062 milliseconds for the command response.
              9/17/2012 8:56:14 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+GMM'
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Sending command: 'AT+GMM' to modem, attempt # 3
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Sending AT+GMM to modem serial port ...
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered Serial DataReceived() function.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [+GMM: V90]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [+GMM: V90]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [+GMM: V90]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Modem init command AT+GMM returned OK.
              9/17/2012 8:56:14 AM ~!~UltraCID Debug~!~Exited Serial DataReceived() function.
              9/17/2012 8:56:15 AM ~!~mcsTemperature~!~Last temperature sample recorded at 9/17/2012 8:53:17 AM
              9/17/2012 8:56:15 AM ~!~UltraCID Debug~!~Waited 62 milliseconds for the command response.
              9/17/2012 8:56:15 AM ~!~UltraCID Debug~!~Sending command: 'AT+VCID=1' to modem, attempt # 1
              9/17/2012 8:56:15 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:15 AM ~!~UltraCID Debug~!~Sending AT+VCID=1 to modem serial port ...
              9/17/2012 8:56:15 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:15 AM ~!~Plug-In~!~Finished initializing plug-in mcsTemperature
              9/17/2012 8:56:15 AM ~!~Plug-In~!~Finished initializing X10 interface
              9/17/2012 8:56:15 AM ~!~Plug-In~!~Finished initializing infrared interface
              9/17/2012 8:56:15 AM ~!~Web Server~!~Local IP address (subnet) is: 192.168.1.50 (255.255.255.0)
              9/17/2012 8:56:15 AM ~!~Web Server~!~UPNP Discovery started
              9/17/2012 8:56:15 AM ~!~Web Server~!~Web Server started on port 8085
              9/17/2012 8:56:15 AM ~!~Startup~!~Creating ASP.NET application host...
              9/17/2012 8:56:16 AM ~!~Startup~!~ASP.NET application host created
              9/17/2012 8:56:16 AM ~!~Startup~!~Start automation engine...
              9/17/2012 8:56:16 AM ~!~Startup~!~This version of HomeSeer is registered.
              9/17/2012 8:56:16 AM ~!~Startup~!~Initializing Speaker Client Interface
              9/17/2012 8:56:16 AM ~!~Speech~!~Listening for remote speaker connections on port 8742
              9/17/2012 8:56:16 AM ~!~Startup~!~Starting Event Scheduler...
              9/17/2012 8:56:16 AM ~!~Startup~!~Checking HTTP connection...
              9/17/2012 8:56:16 AM ~!~Web Server~!~Web Server authorized local login successful from: 127.0.0.1 User: jarvis
              9/17/2012 8:56:16 AM ~!~Startup~!~Updater services starting...
              9/17/2012 8:56:16 AM ~!~Startup~!~Starting DDNS service...
              9/17/2012 8:56:16 AM ~!~Insteon~!~External Device Registration complete.
              9/17/2012 8:56:16 AM ~!~Startup~!~Running the Startup.txt Script
              9/17/2012 8:56:16 AM ~!~Startup~!~Scripting is OK and is now running Startup.txt
              9/17/2012 8:56:16 AM ~!~Startup~!~Start up complete.
              9/17/2012 8:56:17 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:17 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+VCID=1'
              9/17/2012 8:56:17 AM ~!~UltraCID Debug~!~Sending command: 'AT+VCID=1' to modem, attempt # 2
              9/17/2012 8:56:17 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:17 AM ~!~UltraCID Debug~!~Sending AT+VCID=1 to modem serial port ...
              9/17/2012 8:56:17 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:18 AM ~!~Network~!~Speaker client connected from: 127.0.0.1
              9/17/2012 8:56:18 AM ~!~Speaker~!~Speaker host added, Name: jarvis IP address: 127.0.0.1
              9/17/2012 8:56:19 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:19 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+VCID=1'
              9/17/2012 8:56:19 AM ~!~UltraCID Debug~!~Sending command: 'AT+VCID=1' to modem, attempt # 3
              9/17/2012 8:56:19 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:19 AM ~!~UltraCID Debug~!~Sending AT+VCID=1 to modem serial port ...
              9/17/2012 8:56:19 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:21 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:21 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+VCID=1'
              9/17/2012 8:56:21 AM ~!~UltraCID Debug~!~Sending command: 'AT+FCLASS=8' to modem, attempt # 1
              9/17/2012 8:56:21 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:21 AM ~!~UltraCID Debug~!~Sending AT+FCLASS=8 to modem serial port ...
              9/17/2012 8:56:21 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:23 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT+FCLASS=8'
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Sending command: 'AT+FCLASS=8' to modem, attempt # 2
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Sending AT+FCLASS=8 to modem serial port ...
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered Serial DataReceived() function.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Modem init command AT+FCLASS=8 returned OK.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Modem init command AT+FCLASS=8 returned OK.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Modem init command AT+FCLASS=8 returned OK.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Modem init command AT+FCLASS=8 returned OK.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered ProcessReceived() function with a string [OK]
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Modem init command AT+FCLASS=8 returned OK.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Exited Serial DataReceived() function.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Waited 46 milliseconds for the command response.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Sending command: 'AT-STE=7' to modem, attempt # 1
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Sending AT-STE=7 to modem serial port ...
              9/17/2012 8:56:23 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:25 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:25 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT-STE=7'
              9/17/2012 8:56:25 AM ~!~UltraCID Debug~!~Sending command: 'AT-STE=7' to modem, attempt # 2
              9/17/2012 8:56:25 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:25 AM ~!~UltraCID Debug~!~Sending AT-STE=7 to modem serial port ...
              9/17/2012 8:56:25 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:27 AM ~!~UltraCID Debug~!~Waited 2015 milliseconds for the command response.
              9/17/2012 8:56:27 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT-STE=7'
              9/17/2012 8:56:27 AM ~!~UltraCID Debug~!~Sending command: 'AT-STE=7' to modem, attempt # 3
              9/17/2012 8:56:27 AM ~!~UltraCID Debug~!~Entered SendToModem() function.
              9/17/2012 8:56:27 AM ~!~UltraCID Debug~!~Sending AT-STE=7 to modem serial port ...
              9/17/2012 8:56:27 AM ~!~UltraCID Debug~!~Waiting for the modem to respond with 'OK' for up to 2 seconds...
              9/17/2012 8:56:29 AM ~!~UltraCID Debug~!~Waited 2031 milliseconds for the command response.
              9/17/2012 8:56:29 AM ~!~UltraCID Warning~!~No response/improper response from modem command 'AT-STE=7'
              9/17/2012 8:56:44 AM ~!~UltraCID Debug~!~Watchdog Timer database query returned 26 records.
              9/17/2012 8:56:44 AM ~!~UltraCID Debug~!~Watchdog Timer indicates database is connected.
              9/17/2012 8:57:14 AM ~!~UltraCID Debug~!~Watchdog Timer database query returned 26 records.
              9/17/2012 8:57:14 AM ~!~UltraCID Debug~!~Entered DBMaintenance_Elapsed() subroutine.
              9/17/2012 8:57:14 AM ~!~UltraCID Debug~!~Watchdog Timer indicates database is connected.
              ---------------------------------------------------
              Jean-Marie G. Vaneskahian
              jean@vaneskahian.com
              ---------------------------------------------------

              Comment


                #22
                UltraJones, are you able to see anything new in my recent Log dump? Is there anything you want me to try?
                ---------------------------------------------------
                Jean-Marie G. Vaneskahian
                jean@vaneskahian.com
                ---------------------------------------------------

                Comment


                  #23
                  The logs show your modem is not responding to the commands in a timely manner. I am not sure if this is an issue with the Microsoft Net serial port classes or an issue with your PC. While leaving debug on, press the disconnect, then reconnect button on the CID Monitoring State device then send me the logs.

                  By the way, what type of PC are you running HomeSeer on and what type of OS?

                  Regards,
                  Ultrajones
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                    #24
                    What type of PC am I running HomeSeer on:
                    This is a brand new dedicated built machine. It is WAY over built to run HomeSeer. It has not given me any problems on any other devices and is using minimal resources. Here are the specs.

                    - Windows XP Professional SP3 with all the updates and patches (Clean Install)
                    - 64 GB SSD HD
                    - 4 GB RAM

                    As far as HomeSeer

                    - HomeSeer version 2.5.0.55 Starting Now (Standard Build)
                    - I have MANY Serial Port Plug-Ins (Not have problems)
                    --- Insteon (MSandler) - COM Port# 1
                    --- ACRF2 - COM Port# 2
                    --- HAI Serial Thermostat - COM Port# 3
                    --- CurrentCost Envi - COM Port# 4
                    --- RFXCom - COM Port# 19

                    All of these Plugins work with no errors at all.

                    The UltraCID Plugin is on COM Port# 18

                    If there was a problem with .Net, then all the other plugins would have issues, but it is only the UltraCID plugin that has a problem.

                    Also, when I disable the UltraCID plug-in and run a terminal against COM Port# 18 and connect to the modem and issue the commands manually, the responses are INSTANT. I will shoot video of me doing this so that you can see that there is ZERO delay on the modem's response. Also when a call comes in the modem immediately reports the caller ID to the terminal program and even shows the hook state of the phone as I had posted previously.

                    I have posted a video of me documenting and showing you the behavior live. The video is at this YouTube Link:

                    Video of UltraCID Problem and Modem Communications

                    I have also attached the HomeSeer Log with the Debug on as you requested. This is with the new version of the plugin that you posted.

                    Please let me know what to try next.

                    Thanks again for your help with your plug-in,
                    Jean-Marie Vaneskahian
                    Attached Files
                    ---------------------------------------------------
                    Jean-Marie G. Vaneskahian
                    jean@vaneskahian.com
                    ---------------------------------------------------

                    Comment


                      #25
                      The UltraCID HSPI sends data to the serial port and expects an OK response from the modem within 2 seconds. The debug shows your computer is sending all the OK responses from all the commands exactly 10 seconds later. As I said, I have no explanation for this. I even re-wrote the serial routines which didn't help.

                      I tested UltraCID on the 4 different computers at my home and I cannot duplicate the issue you reported. I was not able to test with Windows XP as it won't install on any of my computers (it blue screens during install).

                      Did you install the modem drivers from the CD?

                      Regards,
                      Ultrajones
                      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                      Comment


                        #26
                        I did not install the modem drivers from the CD since the modem was detected and assigned a serial port. Should I install the drivers?

                        Did you happen to look at the video I made that shows the instant reply from the modem when the commands are sent directly inside a serial terminal program?

                        I have not written a .Net serial communication program, but I would like to try it and see if I can duplicate the behavior.

                        I am stumped... If I was having problems with the various other plugins that I would agree and just rebuild my system as a Windows 7 64 Bit machine. But I am not seeing this anywhere else.

                        I am going to try writing a Serial .Net program and see what happens... I really don't want to do this, but I am also curious to find out what is going on. Can you give me an idea where to start? Is these a base serial port HomeSeer plug-in I should use as the foundation?
                        ---------------------------------------------------
                        Jean-Marie G. Vaneskahian
                        jean@vaneskahian.com
                        ---------------------------------------------------

                        Comment


                          #27
                          Finally got Windows XP working. I was able to duplicate the issue you reported using the modem drivers from Windows update. Still testing ...
                          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                          Comment


                            #28
                            Uninstall the existing modem from the Computer Management > Device Manager > Modems list.

                            When you reinstall the driver, make sure you select the driver on the CD ROM or Windows XP will keep installing the driver that doesn't work.

                            I confirm it works once the correct UDB modem driver is installed

                            Regards,
                            Ultrajones
                            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                            Comment


                              #29
                              drivers of modem conexant usb

                              Hello friends. I bought it but did not bring usb modem drivers. I installed the Windows drivers but I've seen that do not work well. Could you send me those of you kindly?. Thank you.

                              Comment


                                #30
                                UltraJones, you are going to kill me, but I cannot find the little CD that came with the modem. I tried downloading the "Conexant 93010" from the Conexant website, but that did not help.

                                Can I please trouble you to post the drivers from the micro CD that came with the modem.

                                I am so glad you were able to duplicate it! I thought I was going insane! The really odd part is that my terminal program that I used to test direct modem communications did not have this problem (Secure CRT it is called). Apparently the problem is only when the Serial .NET class makes calls to the modem.

                                I created a little dummy serial program in vb.net yesterday, and indeed I saw the problem your plugin saw. So strange.

                                Thanks SO much for all your trouble and testing. Let me compensate you for all the time you took. How best can I pay you? Paypal?
                                ---------------------------------------------------
                                Jean-Marie G. Vaneskahian
                                jean@vaneskahian.com
                                ---------------------------------------------------

                                Comment

                                Working...
                                X