Announcement

Collapse
No announcement yet.

Way2Call Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Way2Call Problems

    Just got the Way2Call Hi-Phone.

    So far, it sorta works - guess that's why its called a beta [img]/infopop/emoticons/icon_wink.gif[/img]

    First I'll describe some of my settings in HSP Options:

    Modem Page:
    Line 1: <Hi-Phone Device>
    External Answer: <Don't answer, just look for caller ID information>
    Internal Answer: [Not checked]

    Text-to-Speech/WAV Device Page:
    Message playback/record device: <System Default>

    External call handling Page:
    Caller ID - Anounce the caller: [Checked]


    Now, two problems found so far...

    1) With the [Internal answer] option unchecked, HSP still answers internal
    calls. With the [Internal answer] option checked, HSP answers both internal
    and external calls as internal (says 'Yes Sire') and when its an external call
    it announces CID information at the same time as saying 'Yes Sire'.

    2) When answering an internal call, all sound output (i.e. 'Yes Sire' and all
    other) comes through the sound card. I have changed the "Message playback
    /record device" option to anything else, but the sound still comes through the
    sound card.

    I had been using a Phone Switch with a Hawking modem for a long time before this
    so I have some background with HSP.

    I know how great Rich is about fixing problems, so please let me know what else I
    can do to help.

    Craig

    #2
    Which version of the hi-phone drivers are you running? 1.08.08, 1.08.12 or 1.08.18?

    You may rename the ScWave2K.DLL to ScWave2K.old in your Windows\system32 directory to fix the problem with the sound going to the wrong sound device.

    AMD K6 366Mhz 128MB
    XP Pro HS 1.5.42 HSP 1.0.17 ATT Natural Voices
    USR Voice Faxmodem Pro (5605)
    Way2Call Hi-Phone Desktop USB

    Comment


      #3
      I am running version 1.08.25 drivers that shipeed on the HomeSeer Hi-Phone installation disk.

      I am running Win2000 Advanced Server. I tried renaming the scwav2k.dll file but some process is using it and it will not allow me to rename it. I've tried killing various processes, but I can't find what has the dll open.

      Rich, Help!!!!

      Comment


        #4
        Try downloading the drivers from the website. I am running with the .12 drivers and it's been pretty good. Some have used the .18 drivers and just renamed the dll.

        SteveP

        Comment


          #5
          Alright, I've tried the .12 drivers and have seen no improvement or change at all.

          Also Win2000 Server will not allow me to change the name of the scwave2k.dll since it is in use by Windows. I've tried killing tasks, diasbling the Hi-Phone device and everything else I mcan think of but I still am unable to rename the file.

          One more time, HELP, RICH!!!

          Comment


            #6
            Is there a later driver then the one that came with the install cd?
            I've checked the way2call.com web site and the version appears to be the same.

            Comment


              #7
              Try going into Safe Mode to rename. If this doesn't work then try searching the reg for a Key call RunOnce. This reg key is used to run commands (ie a rename or copy in a new .dll or some other function) before Windows is fully up and running.

              If these options don't work are you running NTFS for standard FAT for the file system. You can search the web for a free product called 'Ultimate Boot Disk', this disk will let you access an NTFS file system after booting from a floppy.

              Hope this helps, as I'm following your experience and thinking about a purchase.

              Mike

              Comment


                #8
                Thanks all for your help.

                I have solved Problem 1 where HSP would always send ouput to the sound card. It seems that I had installed some older HiPhone drivers and some 1.08.25 drivers (from the HSP Installation CD) at the same time! I think this may have happened when, in the face of instuctions that clearly said otherwise, I installed the HiPhone hardware before installing the supplied drivers. Some may call this user error, but I refer to call it thorough testing... [img]/infopop/emoticons/icon_wink.gif[/img]

                Now I only have Problem 2 left where I have to leave Internal Answer disabled for internal answer to work properly. [img]/infopop/emoticons/icon_confused.gif[/img]

                If I check Internal Answer->Enabled, HSP recognizes external calls as internal and external both, and announces "Yes Sire" and the CID info at the same time.

                Is anyone else experiencing this or am I pushing the limits of testing again???

                Craig

                Comment


                  #9
                  Your #2 problem is very strange, I have not seen that problem. The first thing I would do is update HS and HSP to the latest using the updater from the help menu in HS. If its still not working, send me your hsphone.log file showing it answering an external call as internal. I don't see how this can happen.

                  -Rich

                  HomeSeer Technologies LLC
                  💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                  Comment


                    #10
                    I tried a couple of things but couldn't get this to happen.

                    I am on the latest releases of all and version .8.12 of the Hiphone drivers.

                    SteveP

                    Comment


                      #11
                      I cannot get the sound to play thru the phone either. I have been unsuccessful at renameing scwav2k.dll! Why is this necessary? I've uninstalled the drivers, which deletes the dll, and reinstalled.

                      When looking at the configuration in HSP for Hi-Phone, the USB port is there when initially selected a modem but when HS/HSP is restarted the USB port is not there. Is this normal behavior? Hi-Phone answers the call but speaks thru the computer speakers.

                      Win2k Adv Server, latest betas of HS/HSP using updater. Hi-Phone drivers 1.08.25 installed from Homeseer CD.

                      csmith, how did you fix this on your system?

                      roger@netctc.net
                      NETCTC.NET

                      Comment


                        #12
                        I can right click the Hi-Phone Icon in the system tray and go to hardware configuration and see the USB port. In HSP the hardware configuration does not list it after the initial restart.

                        roger@netctc.net
                        NETCTC.NET

                        Comment


                          #13
                          Rich,

                          I have sent you an email with a hsphone.log showing the problem.

                          Thanks,
                          Craig

                          Comment


                            #14
                            Roger,

                            I got HSP to use the HiPhone for sound output by uninstalling all remnants of the HiPhone drivers followed by a reboot, then doing a clean reinstall of the 1.08.25 drivers from the HSP installation disk.

                            I noticed as you did that the Options:Modem:Properties:Hardware device parameters:Configure... does not show USB as one of the options. Its still this way for me even though it now works. Make sure you look at the title of the Options:Modem:Properties:Hardware device parameters:Configure... dialog box to see if it says the right version. Mine didn't before I reinstalled the latest drivers.

                            I'm still have a problem with Internal answer:Enabled as in my earlier posts, but maybe Rich can now figure it out with my hsphone.log file.

                            Let me know if I can help you any more.

                            Craig

                            Comment


                              #15
                              You do not have to rename the dll file. This was only necessary for an older driver. For the 8.25 driver, its ok. The only issue with this driver is that it may reset your preferred audio device to the hi-phone device. This will really mess up your system. Go into your control panels, multimedia, and re-select your sound card as your preferred audio device. Even if its already selected, physically select it again. Then restart your system.
                              If you still cannot get HSP to speak out the phone, email me your hsphone.log file. It will tell me what audio device the Hi-Phone is using.

                              I have made Way2Call aware of this issue and I am awaiting a new driver which will fix it.

                              -Rich

                              HomeSeer Technologies LLC
                              💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                              Comment

                              Working...
                              X