Announcement

Collapse
No announcement yet.

way2call and windows 7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    way2call and windows 7

    I just upgraded to windows 7, and one of the problems I'm still trying to eliminate is with the way2call. I am getting this in my startup:

    ~!~HSPhone~!~Error in Hi-Phone InitVR: (100), Exception from HRESULT: 0x80045002

    I should point out that my wave ID # are "good" ie, positive. I've been told that if they are zero or negative that's bad.

    I also tried unstalling and reinstalling the latest drivers from the way2call website. I used Bill B's instructions, which are not exactly up to date with Vista and the latest w2c stuff, but the general gist has worked for me in the past.

    http://board.homeseer.com/showpost.p...7&postcount=24

    not this time though. I still get the initvr error, and when i try to do anything with the phone, all i hear is the short beep. I check the logs, and of course they think everything's fine.

    any help?
    Plugins:
    BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

    #2
    This error indicates an issue with the drivers. Does Way2Call have W7 drivers available?
    -Rupp
    sigpic

    Comment


      #3
      Well, their website doesn't show anything. I'll poke around their forums. I know W2c used to give HS beta "custom" DLL files...is that still the case? as far as I know, the w2c passes the self tests, so could it be that the dll HS uses is not compatible w/win7?

      Thanks Rupp.

      Ian
      Plugins:
      BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

      Comment


        #4
        here's this from heatvent. I'll PM him and see if it ever got resolved.

        http://www.way2call.com/forum/forum_posts.asp?TID=26

        Ian
        Plugins:
        BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

        Comment


          #5
          I've been getting a similar message for almost a year. However, I'm still running Windows XP Home Edition:
          Attached Files
          -Todd

          ____________________________________________________________ ________________
          HS2Pro: 2.5.0.81 :: HS3Pro (beta) || Plugins:| SmartHome PowerLinc USB, Global Cache, BLBackup, DooCPU Monitor, DooMotion, BLOutlook, BLIcon, BLOutgoingCalls, OutgoingCalls, ROC-Rnd, HSTouch iPhone, UPS Monitor, DooMenuBar, BLSpeech, HSTouch Server, WAF AB8SS, mcsTemperature, VWS, BLChart, RFXCOM, ISY Insteon, iAutomate RFID, iTunes, NetCAM, DSC Security, Nest

          Comment


            #6
            Originally posted by completelyhis View Post
            I should point out that my wave ID # are "good" ie, positive. I've been told that if they are zero or negative that's bad.
            Guys

            Is there any reference around that explains the wave ID#s and the cause?

            I have been struggling with an issue - wont explain the setup for now... just need to do some reading!

            David
            ---------------------------------------------------http://weather.penicuik.org

            Comment


              #7
              Windows 7 and Way2Call Hi-Phone Error

              There appears to be a bug in Windows 7 where it will not allow an application to change the audio input for the speech recognition. The identical code works fine on XP and Vista. I will have to get Microsoft involved to figure out exactly what is going on.

              In the meantime there is a workaround. Go into your Speech control panel, advanced options and set the input device to the Way2Call Hi-Phone USB (no the AUX). You will also need HS 2.4.0.4 or later which has detects the error but allows the VR to complete initialization.

              If you want to try this, here is build 2.4.0.4:

              For HS2 update to this build:
              ftp://ftp.homeseer.com/updates/Beta/...ate2_4_0_4.exe
              For HSPRO:
              ftp://ftp.homeseer.com/updates/Beta/...PRO2_4_0_4.exe
              For PRO100:
              ftp://ftp.homeseer.com/updates/Beta/...OHW2_4_0_4.exe
              website | buy now | support | youtube

              Comment


                #8
                that did it for me, thanks!
                Plugins:
                BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

                Comment


                  #9
                  spoke too soon. while it did get the VR too work, it trashed the incoming call handling. Here's what I noticed:

                  when i do VR the "ding" is played over the whole house audio on the main sound card in my system.
                  I use "external_announce" for my incoming call handling, so it should work like this: people call - the caller ID is announced over the whole house audio, the caller hears TTS saying, "you have reached the ________ Home, after the tone, please speak the name of the person you are calling for" then they hear a tone and speak their name, and so on, with more tts and more wave files. while the call is announced to us via the whole house audio there should be hold music playing for them..this is the way it worked until the update.

                  Now when i get an incoming call hear's what happens: I don't hear the TTS CID info, I DO hear everything the caller should be hearing, except it's over the whole house audio. The caller hears nothing. If I call the house and speak my name on the phone while i hear the prompts over the WHA, I do hear the recording played over the WHA, on top of hte hold music that should be playing over the phone.

                  I tried undoing the device setting changes, but it still does not work. At this point I'm stuck going to "manual" phone usage until i can either roll back the upgrade, or there is a fix made available.

                  Any word from Microsoft?

                  Thanks,

                  Ian
                  Plugins:
                  BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

                  Comment


                    #10
                    Originally posted by Bestgear View Post
                    Guys

                    Is there any reference around that explains the wave ID#s and the cause?

                    I have been struggling with an issue - wont explain the setup for now... just need to do some reading!

                    David

                    Any clues or ideas Guys?
                    ---------------------------------------------------http://weather.penicuik.org

                    Comment

                    Working...
                    X