Announcement

Collapse
No announcement yet.

New PC - Strange error -Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New PC - Strange error -Fixed!

    I am in the process of upgrading my HS machine. When I install the Way2Calld device, it seems fine on the PC but I get this error when HS starts which I haven't seen before:
    3/15/2012 7:55:55 PM HSPhone Calling hangup for line: Home
    3/15/2012 7:55:51 PM HSPhone Error initializing Hi-Phone driver, possible corrupt or missing drivers, or Hi-Phone is not plugged in or powered on.
    3/15/2012 7:55:51 PM Error Initializing Hi-Phone (Set Tones): Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    3/15/2012 7:55:51 PM HSPhone Resetting line: Home
    3/15/2012 7:55:51 PM Phone Line 1 Initializing Hi-Phone device...


    Any ideas? I have done the usual uninstall the device, delete from the registry, etc. but I get the same error every time.

    #2
    Same OS? Or did you go from XP to 7?
    Mark

    Hometroller S6 w/ HS3Pro, Way2Call
    BLAB8SS, BL Backup, Easy Trigger, HSTouch, Open Sprinkler, SONOS, Ultra1Wire3, UltraM1G, WeatherXML, Z-Wave

    Comment


      #3
      It's XP Pro to XP Pro.

      Comment


        #4
        Make sure your DLL's are in the HS directory and the same as the current ones utilized by the W2C drivers. I believe there is only two of them.
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
        HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
        HS4 Lite -

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


          #5
          When I switched machines a few months ago (XP --> XP), it was a matter of only installing the W2C latest drivers from their site. It was an EXE installer. I didn't copy or move anything. Although, per Pete's suggestion, the files may have already existed in the HS backup I'd restored to the new machine.
          Real courage is not securing your Wi-Fi network.

          Comment


            #6
            Using the w2c .exe installer worked. I didn't even have to de/reinstall the drivers. I just ran it with HS off then started it up and it was fine. Thanks!

            Comment


              #7
              Great news!

              For whatever reason and for a couple of years the older running drivers caused me some issues with the W2003 standard Windows update/patches stuff. If I disabled the legacy W2C driver then the updates would be fine.

              Unrelated to W2C drivers but related to Wintel updating;

              Recently noticed a change with the MSUpdating stuff; especially on the newer builds of Wintel (whether XP, W2003, W2008 or W7). It seems that there is some wierd crypto exchange on first authentication for updates. Once past that or with first update then the issue goes away. My work around has been to shut off the web proxy then turn it on. I haven't really bothered to check it out at this time; easier just to temporarily shut down web proxy for a bit of time. I don't think though the "off the shelf" firewalls utilize web proxy services so its probably a non issue for most users.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
              HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
              HS4 Lite -

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment

              Working...
              X