Announcement

Collapse
No announcement yet.

CT30 Z-Wave Thermostat - Not "Staying Awake" - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CT30 Z-Wave Thermostat - Not "Staying Awake" - Fixed!

    I just purchased a CT30 Z-Wave thermostat from homeseer. It's installed and working, with one frustrating exception.

    The instructions state that the radio will go to sleep if using only battery power. The thermostat must have the "c-wire" connected in order for the radio to remain on and receive commands from Homeseer. I have the c-wire connected (and it was in use/functional with the original thermostat in use) but the radio goes to sleep several seconds after the last "touch" to the thermostat.

    I can visually see the radio active indicator on the display, and when the display and as soon as the back-light turns off, the radio active indicator turns off.

    When that display is turned off, the thermostat will not accept z-wave commands from Homeseer. When the display is on and the radio indicator shows activity, the homeseer z-wave commands complete successfully every time.

    The thermostat is set up with a 4-wire heat/cool connection on setting 1 (single stage), and the additional c-wire.

    Thanks for the help!

    Jim

  • #2
    Message log when attempting to access thermometer

    Here's the post to the log...

    12/2/2010 5:56:02 PM ~!~ZWave Thermostats DEBUG~!~In Poll: Time: 12/2/2010 5:56:02 PM
    12/2/2010 5:56:02 PM ~!~ZWave Thermostats DEBUG~!~Entering SendCMD: CMD=Temp G/S=True VAL= SPNum=1
    12/2/2010 5:56:02 PM ~!~ZWave Thermostats DEBUG~!~Sending ZWave Command: 31-4 to Thermostat at ZWaveID: 39
    12/2/2010 5:56:07 PM ~!~ZWave Thermostats DEBUG~!~Received return: 45-52-52-4F-52 from thermostat at ID: 39
    12/2/2010 5:56:07 PM ~!~ZWave Thermostats DEBUG~!~Entering ProcessCMD, CMD=45-52-52-4F-52
    12/2/2010 5:56:12 PM ~!~ZWave Thermostats DEBUG~!~Entering ProcessCMD, CMD=45-52-52-4F-52
    12/2/2010 5:56:12 PM ~!~ZWave Thermostats~!~Error sending ZWave Command, aborting: 31-4
    12/2/2010 5:56:12 PM ~!~ZWave Thermostats~!~Aborting poll of this thermostat due to and error retrieving the temperature.

    When the thermostat is "alive" (the radio indicator is active), the command completes successfully.

    Comment


    • #3
      Thermostat Z-Wave Setting

      Lettercode/Unitcode: Q37
      Zwave node number: 039

      Comment


      • #4
        Originally posted by jjcrowley1 View Post
        I just purchased a CT30 Z-Wave thermostat from homeseer. It's installed and working, with one frustrating exception.

        The instructions state that the radio will go to sleep if using only battery power. The thermostat must have the "c-wire" connected in order for the radio to remain on and receive commands from Homeseer. I have the c-wire connected (and it was in use/functional with the original thermostat in use) but the radio goes to sleep several seconds after the last "touch" to the thermostat.

        I can visually see the radio active indicator on the display, and when the display and as soon as the back-light turns off, the radio active indicator turns off.

        When that display is turned off, the thermostat will not accept z-wave commands from Homeseer. When the display is on and the radio indicator shows activity, the homeseer z-wave commands complete successfully every time.

        The thermostat is set up with a 4-wire heat/cool connection on setting 1 (single stage), and the additional c-wire.

        Thanks for the help!

        Jim
        I thought that was the whole selling point behind this new unit - that it could run without having the C-Wire?? You need to contact HST to be sure that is the way it works.
        HS3Pro Running on a Raspberry Pi3
        68 Z-Wave Nodes, 174 Events, 326 Devices
        UPB modules via OMNI plugin/panel
        Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
        HSTouch Clients: 3 Android, 1 Joggler

        Comment


        • #5
          I thought they were able to run on batteries as well. I just picked up 2 of them but have not had time to test them yet.

          Keep us updated on this

          Comment


          • #6
            I just got mine setup and after about an hour the thermostat stops responding like yours.

            I'm going to contact HS suport on this

            Comment


            • #7
              Originally posted by jjcrowley1 View Post
              I just purchased a CT30 Z-Wave thermostat from homeseer. It's installed and working, with one frustrating exception.

              The instructions state that the radio will go to sleep if using only battery power. The thermostat must have the "c-wire" connected in order for the radio to remain on and receive commands from Homeseer. I have the c-wire connected (and it was in use/functional with the original thermostat in use) but the radio goes to sleep several seconds after the last "touch" to the thermostat.

              I can visually see the radio active indicator on the display, and when the display and as soon as the back-light turns off, the radio active indicator turns off.

              When that display is turned off, the thermostat will not accept z-wave commands from Homeseer. When the display is on and the radio indicator shows activity, the homeseer z-wave commands complete successfully every time.

              The thermostat is set up with a 4-wire heat/cool connection on setting 1 (single stage), and the additional c-wire.

              Thanks for the help!

              Jim
              Are you using a z-troller? I just got my CT30 thermostat in the mail the other day and ran into this same issue! After many hours of troubleshooting, I eventually figured out that the problem was that I needed to update my z-troller firmware version from 1.13 to 1.15. After running the update (found here) everything immediately started working perfectly!

              From what I understand, the update added beaming capabilities necessary for the schlage locks. The CT30 uses this same functionality to wake up the device.

              Just a note about the update: it seems to carry some risk of bricking your z-troller. I followed the instructions found in the zip file closely, crossed my fingers and it worked fine.

              Hope that helps!

              Comment


              • #8
                I set up mine up last night along with an HM-TS001 (my first Z-wave) devices and am NOT having a problem communicating with only the batteries installed so far. Can control/read the thermostat and am getting some periodic info from the thermostat and HM-TS001. Don't know if I got all the devices picked up correctly on that one - I don't have humidity level, but do have 'humidify', which may be the humidity level trigger I guess.

                The only thing I don't see working as expected with the thermostat is that I'm getting operating mode change events but 'operating mode' is always idle, though 'mode' does change for a while from heat to off. I was thinking mode set and mode would be 'heat' and operating mode would toggle as the furnace turned on and off.

                Comment


                • #9
                  Thanks for the help!!!

                  Guys, thank you very much for the help! That did it! I upgraded the Ztroller to .15 and it's working just great.

                  Funny, I was going to update that anyway as a part of normal trouble shooting, but all the warnings in the readme.txt about only completing the upgrade if you had a Schlagge lock kept me from doing so.

                  Note to HomeSeer Technical Support - please update the documentation related to this thermostat and use with the Ztroller!

                  Thanks again!

                  Jim

                  Comment


                  • #10
                    I have a Smart Stick and it required me downloading the Schlage firmware. Now the Tsta is working perfectly. HS Team you could us all a lot of trouble if you told us that in the 1st place!!!

                    Comment


                    • #11
                      I am having the same problem the operating mode reporting incorrectly

                      I am having trouble with mode state reporting as well. The thermostat responds to z-wave just fine. I can change the setpoints, fan and mode via script and the plug-in page. And it works as expected in running the furnace and responding to my events.

                      But the string reports "(Operating) mode" as "Heating" all the time, whether it is heating or not. I thought this might be a problem with the plug-in, but when I query the stat directly with .GetCurrentMode(i,1) in a script, it also returns 1 -- which is "Heating" according to the Scheduler.HSPI_ZWAVETHERM.Thermostat.TMO enum. I do have the thermostat running on my furnace and fortunately is is not actually heating when it says it is heating -- i.e. the heat point works and changes according to my events or script. The problem is .GetCurrentMode is apparently returning the wrong value. Every other .Getxxxx command returns the proper values, as far as I can tell.

                      I have tried rescanning, optimizing, deleting the device and adding it back, deleting the node and adding it back, powering down the stat, pushing the reset button on the stat, and restarting HS. I am running z-troller 1.15 and HS 2.5.0.1.

                      Is anyone else experiencing this, or is it just the two of us?




                      Originally posted by flynnwt View Post
                      The only thing I don't see working as expected with the thermostat is that I'm getting operating mode change events but 'operating mode' is always idle, though 'mode' does change for a while from heat to off. I was thinking mode set and mode would be 'heat' and operating mode would toggle as the furnace turned on and off.

                      Comment


                      • #12
                        Mine is reporting Heating always as well. Turn off the tstat and it still says heating.



                        Originally posted by 1619Farm View Post
                        I am having trouble with mode state reporting as well. The thermostat responds to z-wave just fine. I can change the setpoints, fan and mode via script and the plug-in page. And it works as expected in running the furnace and responding to my events.

                        But the string reports "(Operating) mode" as "Heating" all the time, whether it is heating or not. I thought this might be a problem with the plug-in, but when I query the stat directly with .GetCurrentMode(i,1) in a script, it also returns 1 -- which is "Heating" according to the Scheduler.HSPI_ZWAVETHERM.Thermostat.TMO enum. I do have the thermostat running on my furnace and fortunately is is not actually heating when it says it is heating -- i.e. the heat point works and changes according to my events or script. The problem is .GetCurrentMode is apparently returning the wrong value. Every other .Getxxxx command returns the proper values, as far as I can tell.

                        I have tried rescanning, optimizing, deleting the device and adding it back, deleting the node and adding it back, powering down the stat, pushing the reset button on the stat, and restarting HS. I am running z-troller 1.15 and HS 2.5.0.1.

                        Is anyone else experiencing this, or is it just the two of us?

                        Comment


                        • #13
                          What does it show in the thermostat status web page? I checked mine and it shows idle and I am in heat mode.
                          website | buy now | support | youtube

                          Comment


                          • #14
                            Mine say heating all the time even when it is idle. now one of mine has stopped responding to zwave.

                            now I have one that is not responding to commands again. wow, this becoming not fun at all

                            Comment


                            • #15
                              Remember, these use beaming, so if the stat is far from the controller commands may need to route. If you don't have a beaming compatible module between the controller and the stat, communications may be unreliable. To see if you have any beaming modules or switches, look at your node info screen in HomeSeer and look for "(Beam 1000)" in the listener column.

                              Originally posted by GaryDN View Post
                              Mine say heating all the time even when it is idle. now one of mine has stopped responding to zwave.

                              now I have one that is not responding to commands again. wow, this becoming not fun at all
                              website | buy now | support | youtube

                              Comment

                              Working...
                              X