Announcement

Collapse
No announcement yet.

How do I get Honeywell Z-Stat to resume schedule?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I get Honeywell Z-Stat to resume schedule?

    Things seem to be generally working fine with this 'stat except for this. I can tell it to go to a particular set point, I can set its mode to "off" etc etc.

    The problem is that I would like to tell it to resume running it's own internally stored program. This is accomplished by pressing the "shed" button on the thermostat.

    If I use an event to tell it to "resume", instead it gets set to "off". (If I use an even to tell it to go "off", it does indeed go "off").

    I'm running HSPRO .60 with a Ztroller.

    Doug

  • #2
    Why not use HomeSeer to set the schedule?
    -Rupp
    sigpic

    Comment


    • #3
      Two reasons.
      1 is to make use of the thermostat's ability to automatically adapt to the response rate of the house, and 2 is simplicity and redundancy. If HS dies when I'm out of town, the family is ok with lights not doing their thing but they will get grumpy if the house is cold in the morning...

      Clearly, I could do it all in HS but it seems that HS *ought* to be able to tell it to go back to running its program. It seems that the "resume" command should do that, right?

      Doug

      Comment


      • #4
        I'm sure it's due to the Z-Wave command library not knowing about the resume command. The Z-Wave command library is generic and not every stat has this option.
        -Rupp
        sigpic

        Comment


        • #5
          Maybe, but "resume" is on the pull down menu for the device in HS. Instead it appears to do the same as the "off" command.

          I presumed that if it was on the pull-down menu it was at least comprehended by z-wave, and so I was wondering if I am doing something wrong or if there's a bug here...

          Doug

          Comment


          • #6
            Originally posted by DMcKnight View Post
            Two reasons.
            1 is to make use of the thermostat's ability to automatically adapt to the response rate of the house, and 2 is simplicity and redundancy. If HS dies when I'm out of town, the family is ok with lights not doing their thing but they will get grumpy if the house is cold in the morning...

            Clearly, I could do it all in HS but it seems that HS *ought* to be able to tell it to go back to running its program. It seems that the "resume" command should do that, right?

            Doug
            That's why I abandoned my 2GIG z-wave. Went with Wifi in end.

            You can read why here: http://www.hometoys.com/emagazine/20...ermostats/2060
            ________________________

            Dell Zino HD - HSPRo 2.x
            HSTouch - iPhone 3GS, 4S, iPad2 and iPad 3, 3xKindle Fire (Wall mounted)
            2 x Brultech ECM1240 with UltraECM
            USB UIRT
            Cooper Aspire Z-Wave Switches
            WGL800 w ACRF2 and 3xDS10a (Sump Level/Activity sensing)
            HM ST812-2 Flood Sensor
            HSM100 - Motion Detector with Light and Temperature
            2GIG Thermostat
            BLDSC - Alarm Plug-in
            BLUPS
            UltraLog (SQL2008)
            Jon00 Plugins
            Host XR3 BT and Jon00 BT Proximity
            Global Cache IP2IR
            Foscam FI8918W

            Comment


            • #7
              Originally posted by DMcKnight View Post
              Maybe, but "resume" is on the pull down menu for the device in HS. Instead it appears to do the same as the "off" command.

              I presumed that if it was on the pull-down menu it was at least comprehended by z-wave, and so I was wondering if I am doing something wrong or if there's a bug here...

              Doug
              Good point. This may be a bug.
              -Rupp
              sigpic

              Comment


              • #8
                Yes, it seems like it might be. What's the best way to communicate this to HS?
                Doug

                Comment


                • #9
                  I've come back to this and experimented a bit more.
                  It seems that multiple issues of the Set Mode Resume command gets it to cycle through modes. This seems odd to me.
                  Issuing the command to "Set Mode Heat" causes the scheduled program to resume, but only if the thermostat is not in a temporary hold mode.
                  The "Set Mode EnergySaveHeat" command always seems to work, and furthermore the Set Mode Heat command always seems to work in the EnergySaveHeat mode.
                  SO, I think the workaround that allows me to resume the thermostat's internally stored program whenever I want is to first issue Set Mode EnergySaveHeat and then issue Set Mode Heat.

                  A bit clunky, but it seems to work.

                  Perhaps I'm being stupid, but I haven't been able to find any documentation describing these modes. Maybe I'm just misunderstanding what is meant by "resume"???

                  Comment


                  • #10
                    Can anybody clear up what the 'resume last' command does?

                    I have an event where my thermostat is shut off to conserve energy for a brief period of time (1 hour) and then I want it to go back to the last setting (heat, cool, energy save heat, energy save cool) that it was on before it was turned off. This event happens on an inconsistent basis so therefore I can't program my event to go to a particular model. I had thought 'resume last' would do that, but it seems to always put the thermostat into cool mode. Any ideas what this command does?

                    Comment

                    Working...
                    X