Announcement

Collapse
No announcement yet.

Ecobee Offline

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ecobee Offline

    I have an event which informs me that Ecobee is offline according to Homeseer. I find that I quite often receive a message that the Ecobee is offline, and when I go to the thermostat, or login with the Ecobee app, I am able to access it. Today this happened numerous times - every 4 minutes, which I think is the default for monitoring. Suggestions on how to eliminate the false notifications? Thank you.

  • #2
    Other than your issues :-)

    can you share how you set the event up. I wouldn't mind monitoring that.

    Comment


    • #3
      The root device status can be set to Offline if the thermostat is actually Offline or if for some reason the plugin can't retrieve data from the Ecobee server when it tries to poll. So it doesn't necessarily mean that the thermostat is Offline.

      Comment


      • #4
        TomGru, set up a device event that the device is the Ecobee thermostat, and is set to offline. I have it then text me via email that it is offline. But now going to add a counter that when it hits 15 - that would be one hour - of no communication with the Ecobee, lets me know so that I can check on it (I do occasionally have the Ecobee drop its WiFi connection).

        When the Ecobee comes back online (to the app, anyway) I'll reset the counter to 0. Hopefully this will be a satisfactory way to monitor it.

        Thanks for the info, Spud! Great app.

        Comment


        • #5
          Originally posted by mdavison View Post
          TomGru, set up a device event that the device is the Ecobee thermostat, and is set to offline. I have it then text me via email that it is offline. But now going to add a counter that when it hits 15 - that would be one hour - of no communication with the Ecobee, lets me know so that I can check on it (I do occasionally have the Ecobee drop its WiFi connection).

          When the Ecobee comes back online (to the app, anyway) I'll reset the counter to 0. Hopefully this will be a satisfactory way to monitor it.

          Thanks for the info, Spud! Great app.
          SO when device (scones) changes and becomes offline...you start the time. Another event to reset timer if it comes back online?

          Comment


          • #6
            I have 3 events.

            One - IF EcobeeOnline value becomes this: 15
            Then Send an Email to myname@myaddress
            with the subject Ecobee Communication Lost

            Two - IF Thermostats Ecobee Downstairs Ecobee had its value set to Offline
            Then Increment counter EcobeeOnline

            Three - IF Thermostats Ecobee Downstairs Ecobee had its value set to Online
            AND IF EcobeeOnline value has exceeded this: 0
            Then Send an Email to myname0@myaddress
            with the subject Homeseer Ecobee Online
            Then Reset counter EcobeeOnline (To Zero)

            Make sure to run Three when you're set up to zero the counter the first time.

            Comment


            • #7

              Comment


              • #8
                Hi Spud, having the same issue, when I try to re authorize it and click on the button ecobee authorization, nothing happen while the log indicated this
                Oct-27 3:50:47 PM Ecobee ERROR One or more errors occurred.
                Thanks,
                Aldo

                Comment


                • #9
                  Originally posted by aldo View Post
                  Hi Spud, having the same issue, when I try to re authorize it and click on the button ecobee authorization, nothing happen while the log indicated this
                  Oct-27 3:50:47 PM Ecobee ERROR One or more errors occurred.
                  Thanks,
                  Aldo
                  Update to version 3.0.0.29 available in beta section of the updater. If you are on Linux this may still not work depending on the version of mono:

                  related threads:
                  https://forums.homeseer.com/forum/th...-with-ecobee-3
                  https://forums.homeseer.com/forum/th...-was-cancelled

                  Comment


                  • #10
                    Thanks Spud,that fixed the issue. Unfortunately all my thermostats still show offline, any other suggestion?

                    Comment


                    • #11
                      Originally posted by aldo View Post
                      Thanks Spud,that fixed the issue. Unfortunately all my thermostats still show offline, any other suggestion?
                      That fixed what issue?
                      Please provide more information when you have a problem: OS, mono version, debug logs, etc..

                      Comment


                      • #12
                        Sorry, I was able to re authenticate, but my ecobees are still showing offline. I'm using windows.
                        Error Warming the ecobee plugin hasn't been authorized to access your ecobee account.

                        Comment


                        • #13
                          After few minutes, I see my devices back online. Thank you for all your help.

                          Comment

                          Working...
                          X