Announcement

Collapse
No announcement yet.

Auxiliary heat status

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auxiliary heat status

    Hi Spud,

    As you know, winter kicked into high gear fairly soon in our area this year. Things that I was hoping to test or validate in January-February with my new Daikin (Ecobee) T-stats are happening right now. So after some observations I was wondering if you could implement the followings change :

    Observations :
    - In the configuration "Response" section there is a variable called "hasElectric : true/false". If the T-stat is configured with "Aux. Heat", this flag is "true". It is part of the system configuration and not something that you would toggle ON/OFF so having a device for it is not really useful. However it becomes helpful for the next point.

    - When it gets very cold, both the "Heat pump" and "Aux. Heat" can be engaged. The stat "Response" will be like this : "XXXXXXX670:auxHeat1,fan,heatPump".

    - You do have a device showing "Fan status" and a second one showing "HVAC status" as either "Idle, Heating, Cooling" but there is no way to tell if "Aux. Heat" is ON/OFF

    Request :
    - What would be nice is that : IF "hasElectric" = true then create a device called "Auxiliary heat status" showing ON-OFF state.
    or
    - Just add a new "Aux. Heat status" device and T-stat without Aux heat enabled will always show OFF.

    Hoping this is somewhat clear.

    Regards.

    Michel

  • #2
    I think I can add that, but do you have hasHeatPump = true, in your logs?

    Comment


    • #3
      Originally posted by spud View Post
      I think I can add that, but do you have hasHeatPump = true, in your logs?
      Spud,

      Thanks for the prompt reply. Yes I do.

      Comment


      • #4
        In version 3.0.0.31 available in the Beta section of the updater I have added a "Aux Heat Status" device

        Comment


        • #5
          Hi Spud. Thanks for the prompt update. However the new device is not showing-up after updating to 3.0.0.31. A debug log does not seem to show any errors.

          Is the new device systematically added or based on the ("hasElectric": true) value?

          Regards.

          Comment


          • #6
            It is supposed to be created only if hasElectric=True and hasHeatPump=True.

            Make sure the new device is not filtered out by your room/floor filters?

            Comment


            • #7
              Sure is a common mistake but does not seem the case this time. I've removed all filters and even search for "Heat" and "Aux Heat Status is nowhere to be found.

              I've attached the portion of the log showing both flags as being "true", "hasHeatPump" being the 1st and "hasElectric" the last one. Could it be a parsing/typo error in the variable name?

              Attached Files

              Comment


              • #8
                I think I found the problem, please test version BETA 3.0.0.32

                Comment


                • #9
                  Spud,

                  With 3.2.0.32

                  "Aux Heat Status" appeared as expected on the T-Stat having "Aux. Heat" and not on the second that does not have the feature turned-on. So this is behaving as expected.

                  Doing a really quick test, "Aux Heat Status" also seems to be properly tracking.

                  I'll monitor the situation during a few days but all seems to be working properly.

                  As usual your promptness and plug-in's quality is greatly appreciated.

                  Best regards.

                  Comment


                  • #10
                    Hi All,

                    I'd like to see the running mode as well, but I don't see this new device listed with all my other ecobee functions. What config file contains the "hasElectric" = true and "hasHeatPump" = true - I don't see it in the ecobee.ini file.

                    Thanks

                    Comment


                    • #11
                      Originally posted by Automate View Post
                      What config file contains the "hasElectric" = true and "hasHeatPump" = true - I don't see it in the ecobee.ini file.
                      Hi Automate,
                      • First, you need to make sure that "Aux. Heat" is enabled in your thermostat. It is not a flag that you turn on or off in an Ecobee.ini file.
                      • If the "Aux Heat Status" device is not created by the plug-in in HS, you can confirm if the plug-in is being given that proper setting in a Debug file called Ecobee.txt, located in "YOUR HOMESEER SOFTWARE PATH\HomeSeer HS3\Logs"
                      • In order to have that log file you first need to go into the "Config" page of the Ecobee plug-in. On the "General" tab, check "Log to file" and select "Debug" from the drop down list.
                      • The plug-in polls information every (5) minutes so you will need to give it some time to create the log file.
                      • One you have a file I suggest you turn "Log to file" Off as it will only add more information and make it harder to navigate.
                      • It is a dump file so not formatted at all. I suggest you use the "Search" function of your notepad lo locate the "hasElectric" and "hasHeatPump" flags.
                      So in short it is NOT the plug-in that decides if you have Aux. Heat or not. It comes from your thermostat settings.

                      Let me know how you make out. And feel free to post your Ecobee.txt file if I can be of any help.

                      Comment


                      • #12
                        Hi Michel,

                        Thanks for the detailed explanation. I actually got that far in my further troubleshooting last night - but it's good to have here as I'm sure it will help others who may be searching and come across this tread as I did.

                        I discovered the problem was the "hasElectric" flag. For some reason it is set to false, although I don't understand why that is. I went through the furnace configuration again on the Ecobee and found no specific choice for fuel type. The Ecobee is set for forced air (vs boiler) and the "hasHeatPump" is set to true, so all that is working. I have opened a ticket with Ecobee on how to get the "hasElectric" flag changed. I'll update once I learn more.

                        Thanks again!

                        Comment


                        • #13
                          What model of Ecobee do you have?

                          Comment


                          • #14
                            I spent quite sometime playing with my T-Stat and heating systems in general. Feel free to detail your setup.

                            What is your main Heating source?
                            What is your Aux Heat?
                            Can you share a picture of the wire terminals. Do you have wires tied to W1 and/or W2?
                            Feel free to share your Ecobee.txt log

                            Comment


                            • #15
                              Sure! It's an Ecobee 3 running firmware 4.5.13.45 debug lists the model as "athenaSmart"

                              Main heating is heat pump and aux is electric. I do have w1 connected to fire the AUX heat. W2 is not connected.

                              I suspect it's related to an issue at Ecobee and have opened a ticket with them, although it's a bit slow going to get any sort of detail from them.

                              Honestly, I think the ecobee is really lacking for my requirements and when I got it I expected that it wouldn't be long until they opened a local API. That was a few years ago, and it seems like that won't ever happen. I need fairly real-time response to be able to coordinate with other HVAC devices in the home. I'm investigating using a z-wave thermostat instead and having homseer provide the more advanced logic functions. The ecobee is a good thing with it's remote sensors, but the lack of the local API kills it's ability to integrate effectively.

                              Spud,
                              Does the plugin need to refrence the the "hasElectric" flag for the purpose of creating the aux heat interface? Could it not just rely on the "hasHeatPump", and ignore the state of "hasElectric"?

                              Thanks!

                              Comment

                              Working...
                              X