Announcement

Collapse
No announcement yet.

Fan Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fan Error

    I've got a simple HS3 event to turn the fan "on" at night, and turn back to "auto" in the morning. However, I get this error, and would appreciate your help in determining what is wrong.
    Apr-29 10:45:09 AM Ecobee ERROR System.AggregateException: One or more errors occurred. ---> Ecobee.Net.FunctionError: An error occured processing a function. Ensure required properties are provided. at Ecobee.Net.ApiResult.ThrowException() at Ecobee.Net.Thermostat.d__64.MoveNext() --- End of inner exception stack trace --- at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification) at System.Threading.Tasks.Task`1.get_Result() at HSPI_Ecobee.EcobeeApp.SetFanMode(Thermostat thermostat, FanSetMode mode) ---> (Inner Exception #0) Ecobee.Net.FunctionError: An error occured processing a function. Ensure required properties are provided. at Ecobee.Net.ApiResult.ThrowException() at Ecobee.Net.Thermostat.d__64.MoveNext()<---

  • #2
    Could you set the log level to Debug and capture the problem again?
    thanks

    Comment


    • #3
      Here is the log. Thanks.
      Attached Files

      Comment


      • #4
        what's wrong is this:

        Code:
          "functions": [
            {
              "type": "setHold",
              "params": {
                "holdType": "holdHours",
                "holdHours": 0,
                "coolHoldTemp": 760,
                "heatHoldTemp": 760,
                "fan": "on",
                "isTemperatureAbsolute": false
              }
            }
          ],
        if holdType = holdHours, then holdHours should be equal to 2 or 4
        I don't understand how it is possible you have this field set to 0

        What is "Hold action For" set to in your Config page?

        What version of the plugin do you run?

        Do you change the Hold setting from an action?

        Comment


        • #5
          Plugin is 3.0.0.2; Hold action is set for 2 hours in Config. I have two Events: one at 10:30pm to set the Ecobee Fan Mode to On, and one at 7:30am to set the Ecobee Fan Mode to Auto.

          Comment


          • #6
            Originally posted by mdavison View Post
            Plugin is 3.0.0.2; Hold action is set for 2 hours in Config. I have two Events: one at 10:30pm to set the Ecobee Fan Mode to On, and one at 7:30am to set the Ecobee Fan Mode to Auto.
            Did you mean 3.0.0.32

            I think I found the problem, I believe your "Hold Action" setting got corrupted and is set to -1 in the ini file. To fix your problem, from the config page, change this setting to something else then change it back to "2 hours". Let me know if that works

            I will fix the source of the problem.

            Comment


            • #7
              That fixed it. Thanks for your help!

              Comment

              Working...
              X