Announcement

Collapse
No announcement yet.

Invalid code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Invalid code

    Did something to the ecobee authorization code? I started getting authorization errors in my HS logs, tried to remove and re-add the application on the ecobee's website and I get the error that says "The code you entered is invalid. If the problem persists please contact the application vendor."

    Edit: never mind... user error. Wish I could delete this.

    #2
    Not sure it was user error...
    My system did the same to me today.
    Spit out a bunch of these:
    Code:
    ERROR System.AggregateException: One or more errors occurred. (The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.) ---> Ecobee.Net.ErrorCodeException: The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client. at Ecobee.Net.ApiResult.ThrowException () [0x00057] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Access.Refresh (System.Boolean forceRefresh) [0x0014c] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Http.Create (System.Boolean allowTokenRefresh) [0x0011c] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Http.Post (System.String address, Ecobee.Net.ApiObject content, System.Boolean allowTokenRefresh) [0x00086] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Thermostat.SetHold (Ecobee.Net.Hold hold) [0x000d8] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 --- End of inner exception stack trace --- at System.Threading.Tasks.Task.ThrowIfExceptional (System.Boolean includeTaskCanceledExceptions) <0x7f0178cd4fd0 + 0x00042> in :0 at System.Threading.Tasks.Task`1[TResult].GetResultCore (System.Boolean waitCompletionNotification) [0x0002b] in :0 at System.Threading.Tasks.Task`1[TResult].get_Result () [0x0000f] in :0 at HSPI_Ecobee.EcobeeApp.SetClimateHold (System.String ecobeeId, System.String climateRef) [0x00028] in <2425484103da41ba8e15d174260e802a>:0 ---> (Inner Exception #0) Ecobee.Net.ErrorCodeException: The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client. at Ecobee.Net.ApiResult.ThrowException () [0x00057] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Access.Refresh (System.Boolean forceRefresh) [0x0014c] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Http.Create (System.Boolean allowTokenRefresh) [0x0011c] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Http.Post (System.String address, Ecobee.Net.ApiObject content, System.Boolean allowTokenRefresh) [0x00086] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 at Ecobee.Net.Thermostat.SetHold (Ecobee.Net.Hold hold) [0x000d8] in <014e01efe6884d9ba5c5be35ca1aaf59>:0 <---
    then a few of these:
    Code:
    ERROR The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.
    I stopped and restarted the plug-in with no change.

    I authorized again with Ecobee and all seems fine again.

    Strange.

    Scott

    Comment

    Working...
    X