Announcement

Collapse
No announcement yet.

Sudden authorization issues.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sudden authorization issues.

    Early this morning the plugin spit out a few of these 'request is malformed' errors and ever since it has been spitting out authorization errors, hundreds of them, flooding my log.

    Code:
    08:40:01:4381:[Event]->Event Trigger "HVAC Windows Closed - Resume ecobee"
    08:40:01:4514:[Device Control]->Device: Downstairs Ecobee Current Program to Resume Program (1000)
    08:40:01:4522:[Device Control]->Device: Upstairs Ecobee Current Program to Resume Program (1000)
    09:02:02:9761:[Ecobee]->ERROR The request is malformed. Check parameters.
    09:02:15:9929:[Ecobee]->ERROR The request is malformed. Check parameters.
    09:02:23:4853:[Ecobee]->ERROR The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.
    09:06:03:3622:[Ecobee]->ERROR The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.
    09:06:05:2138:[Ecobee]->ERROR The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.
    09:06:07:9273:[Ecobee]->ERROR The request is malformed. Check parameters.
    09:09:57:0673:[Ecobee]->ERROR The authorization grant, token or credentials are invalid, expired, revoked, do not match the redirection URI used in the authorization request, or was issued to another client.
    Their status page shows all good. My logon is still working without issue, I can access their app and web page. When I go to the app authorizations it still shows this plugin as good.
    The plugin logging is set to the maximum 'Error' level, but as these are errors that is of no help.

    I am stumped.

    I did open a ticket with Ecobee but I do not expect any response from them. The initial contact went less than ideal.

    I have been getting a a run of these JSON error messages that I have not been able to track down.
    There were a few scattered in the log around the same time:
    Code:
    08:37:43:1586:[Error]->Problem serializing data for JSON request: Object reference not set to an instance of an object
    08:37:53:1417:[Error]->Problem serializing data for JSON request: Object reference not set to an instance of an object
    thanks,

    Scott

    #2
    I was finally able to solve these by running through the authorization steps with the plug-in. I had already tried that earlier in the day, not sure why it didn't work then and it worked now.

    Probably something on the ecobee side.

    Will leave this here in case someone else runs into the same.

    Scott

    Comment


      #3
      I experienced the same problem (began about noon EDT). I was also not able to log into my account on my computer. I suspect that the Ecobee server was offline for a while.
      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548, NUC i3

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

      Comment


        #4
        Looking back at my logs I had the same error, at the same time. Seems to have lasted 2-3 hours.

        Comment


          #5
          yeah, there was a problem on ecobee side yesterday: https://status.ecobee.com/

          Comment


            #6
            Does this happen once a month on the 29th?

            Oct-29 12:17:03 PM Ecobee ERROR Unknown issue or condition caused a failure.
            Oct-29 12:16:57 PM Ecobee ERROR Unknown issue or condition caused a failure.
            Oct-29 12:16:52 PM Ecobee ERROR Invalid credentials supplied to the registration request, or invalid token. Request registration again.
            Oct-29 12:13:19 PM Ecobee ERROR A task was canceled.
            Mike____________________________________________________________ __________________
            HS3 Pro Edition 3.0.0.548, NUC i3

            HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

            Comment


              #7
              I actually had to re-authorize for the first time today. Never had an issue in the past. I am still on HS3.

              Comment

              Working...
              X