Announcement

Collapse
No announcement yet.

Timeout writing data to Thermostat

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Timeout writing data to Thermostat

    I get the error "Timeout writing data to Thermostat
    " in my log every time something is written to the RC80, but when I check the thermostat it has received the command just fine. Any ideas???

    Dave

  • #2
    This message will be written if a response to a command to the thermostat is not received in the specified time. However the plug-in will retry 5 times before it gives up on a particular command. You might want to go into the INI file and add the line

    Debug=1

    to the [General] area and see what is happening to cause this.

    What is your polling interval set to? 10 sec X the number of thermostats has worked OK.

    Alan

    Comment


    • #3
      I had the same problem with my rc 100's when I first installed them.
      http://board.homeseer.com/showthread.php?t=100963

      Read the whole thread.
      If it ain't broke, don't fix it!

      Comment


      • #4
        Hello I am also getting the timeout error as above but my tstat doesnt respond to any commands so It is a wiring issue. I have followed all the diagrahms and I am about to pull my hair out. (If I had any) I have tried these connections and I am using an edgeport if that matters on com7. I have cat5 going to the com connection and the other end is a DB9 connector that I have soldered wires to using cat-5. Here are the wire setups I have tried, HS2..

        If using a DB-9F connector:
        1. On the DB-9F connector: Connect pins 7 and 8 together. (RTS and CTS)
        2. On the DB-9F connector: Connect pins 1, 6 and 4 together. (DCD, DTR and DSR)
        3. Connect pin 4 of the DB-9F to the YELLOW wire on the thermostat plug (DTR)
        4. Connect pin 3 of the DB-9F to the GREEN wire on the thermostat plug (TXD)
        5. Connect pin 2 of the DB-9F to the RED wire on the thermostat plug (RXD)
        6. Connect pin 5 of the DB-9F to the BLACK wire on the thermostat plug. (GND)


        Then I tried 3 wires
        Black to 2
        red to 3
        yellow to 5

        Any help would be appreciated....

        Comment


        • #5
          Did you try it with the script instead of the plug-in?

          Alan

          Comment


          • #6
            No, Which script? Also what should the address and com mode be?
            Also which wiring setup above do I use? Or are they wrong?

            Comment


            • #7
              This is the wiring I have used:

              If using a DB-9F connector:
              1. On the DB-9F connector: Connect pins 7 and 8 together. (RTS and CTS)
              2. On the DB-9F connector: Connect pins 1, 6 and 4 together. (DCD, DTR and DSR)
              3. Connect pin 4 of the DB-9F to the YELLOW wire on the thermostat plug (DTR)
              4. Connect pin 3 of the DB-9F to the GREEN wire on the thermostat plug (TXD)
              5. Connect pin 2 of the DB-9F to the RED wire on the thermostat plug (RXD)
              6. Connect pin 5 of the DB-9F to the BLACK wire on the thermostat plug. (GND)

              You need to set the 00 address of the thermostat to 1. If you have more than one thermostat, each must have a unique address (set in address 00) starting at one, and increasing sequentially.

              Address 01, the comm mode, must be set to 0. The default is 1, so if you have not changed this, then you probably should.

              The script is called rc80.thm. I think you need to add a device, and on the device properties page say it is a thermostat and then select the script the device will use.

              Finally, is this a backlit version (ie RC80B)? If so, do you have 5 HVAC wires or only 4? There have been reports of B units with only 4 wires having some kind of comm problems. I think you can disable the backlight in this case and see if it works.

              Alan

              Comment


              • #8
                Okay I resodered the wires to your setup, I changed the Unit address and codes which where wrong. Now I see the temp of the unit on HS2 so I think it might be working.. Before the current temp would always say 54...
                Thanks alot! Especially if it works!!

                Comment


                • #9
                  Great! Glad to hear it seems to be working. If you see the temp, then everything else should work.

                  Alan

                  Comment


                  • #10
                    Correction Not working, I jumped the gun. Yes it has 4 wires.. It has a backlight with the little jumper. I am trying that then I am looking for that rc0 script....

                    Comment


                    • #11
                      wegienka,
                      Got it now! The com port moved again on the tstat, it must have reset some how... Thanks alot I followed your post fully and your on the money. Your post should be a sticky! hmm I seem to have seen that line somewhere.. Anyway anyone looking to get RC80 set direct to DB9 all you could ask in in the post above.....

                      Comment

                      Working...
                      X