Announcement

Collapse
No announcement yet.

comm port issue with Lantronix and HAI RC-80

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • comm port issue with Lantronix and HAI RC-80

    Hi all,
    I was wondering if anyone else had seen this problem.

    I have the HAI rc-80 wired up correctly to my Latronix box.
    When homeseer starts and loads the Thermostat plugin, the plugin doesnt seem to change the default windows comm port speed of 9600.

    As a consiquence, when the HAI rc-80 port on the lantronix box is connected to by the pc it runs at the windows default speed of 9600 and this prevents the thermostat from working.

    Issueing a command of "set port 6 speed 300" on the lantronix admin console sets the port to the correct speed and the thermostat plugin works as described.

    I do not have this comm port issue with any other device that I am using such as the CM11A computer interface which runs at 4800. Its port on the lantronix is indeed changed to 4800 Baud when homeseer connects to it on startup, and my weather station that runs at 9600 ( although this is also the windows default speed ).

    This is only an issue if the system or homeseer falls over and restarts automatically.

    As I have stated above I can issue a command on the Lantronix box to fix the problem, but it is not a preferable method as I am often not around to be able to fix these issue due to work commitments ( hence the whole reason for a home Automation System ).

    Any Ideas here on how to fix this issue.

    Apart from the challenge above, I love the plugin, I have my wireless weather station providing external temperature readings to the thermostat which is soooo cool and the better half likes that feature too.

    Cheers

    Nick.

  • #2
    I run the same configuration and set my port speed on the Lantronix to 300. In the Redirector setup I have Inband Listen disabled so the external program cannot change the port settings of the Lantronix port.

    Comment


    • #3
      Hi Michael,

      I went down the same path as you, but even with Inband Listen disabled, I found that the redirector was still changing the baud rate.

      This could be confirmed by the fact when you do a "show port 6" when the port was idle the baud rate was 300, as expected due to the fact that i did a "define port 6 speed 300" command and rebooted the lantronix.

      But when the redirector connected to the service on the lantronix box the baud rate went to 9600.

      Playing around further today, I found if I turned on "raw mode" in the redirector, then the redirector application would not set the Lantronix baud rate but instead the lantronix box used its default baud rate ( 300 baud ).

      All now works well, and I am a very happy camper :-)

      Comment


      • #4
        I think you will want to use Raw for all HA-type uses of the Lantronix. We do not want any interpretation of the bits going through the Lantronix.

        Comment

        Working...
        X