Announcement

Collapse
No announcement yet.

RC80 Comms Problem in HS 2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RC80 Comms Problem in HS 2.0

    I envy all of you that have minor comms problems because I can't get my RS232 interface working to an RC80B (HS 2.0). I have checked my configuration many times and I have measured the voltage levels on each pin and I have reason to believe my installation of the thermostat plugin is bad. I'll explain below:

    The RC80B is setup as follows:
    Installer Setup: 00 Address set to 1, 01 Communications mode set to 0 (300 baud RS-232).
    Backlight is disabled for testing.

    Comms cable:
    Yellow (DTR) connected to pin 4, 1, 6 of my PC serial port (com port 2).
    Green (TXD) connected to pin 3 of my PC serial port.
    Red (RXD) connected to pin 2 of my PC serial port.
    Black (GND) connected to pin 5 of my PC serial port.
    Pins 7,8 on PC serial port are connected together.

    I use CAT5 between PC and RC80B. All unused wires go to GND pin.

    I was very concerned about having the pinout of the serial connector backwards, because male vs. female is flipped and many drawings have it wrong, but with searching on the internet for the PC layout and measuring with a voltmeter I am quite confident.

    Now here is the interesting part. I called HAI and they sent a "Serial Protocol Description" document. This was very useful and I have included it as an attachement. They use pin 4, DTR as a voltage source to power their optically isolated interface. They require +12 V on this pin. When I measure this pin it is at -10V when the HS plugin for the RC80 is controlling the serial port. When my Napco plugin is controlling the port (and this plugin works for my security panel) it is at +12V. I know that the state of the pin is conrolled by software, so maybe the plugin does not explicitly set this bit and it works for only some systems? I can see the TXD line switch between +12V and -12V as it should for data transmission. The RXD line is floating around 0V, as you expect if there is nothing on the other end.

    I have tried switching the PC serial port to a known working port (com 1), but that made no difference. When the thermostat plugin has control the DTR goes from +12V to -10V. Note that RS232 only needs 2.5 V plus or minus so the small voltate difference is not important. I also tried com 3 and com 4, which are not valid, and HS reported that correctly, so I know the plugin is setup for com 2 and I can see the TXD switching voltage as well on that port. But the DTR is not +12V as HAI requires. Can someone else measure their DTR on the working com port, that would be a big help.

    HS log file has this output:
    1/14/2006 2:51:30 PM rc80 GetChar timeout: 53482 53490
    1/14/2006 2:52:38 PM rc80 GetChar timeout: 53550 53558
    1/14/2006 2:52:46 PM rc80 GetChar timeout: 53558 53566
    1/14/2006 2:53:54 PM rc80 GetChar timeout: 53626 53634
    1/14/2006 2:54:02 PM rc80 GetChar timeout: 53634 53642
    1/14/2006 2:55:10 PM rc80 GetChar timeout: 53702 53710
    1/14/2006 2:55:18 PM rc80 GetChar timeout: 53710 53718
    1/14/2006 2:56:26 PM rc80 GetChar timeout: 53778 53786
    1/14/2006 2:56:34 PM rc80 GetChar timeout: 53786 53794
    1/14/2006 2:57:42 PM rc80 GetChar timeout: 53854 53862
    1/14/2006 2:57:50 PM rc80 GetChar timeout: 53862 53870
    1/14/2006 2:58:58 PM rc80 GetChar timeout: 53930 53938
    1/14/2006 2:59:06 PM rc80 GetChar timeout: 53938 53946
    Attached Files
    Last edited by danielperez; January 14th, 2006, 03:51 PM.

  • #2
    Got it working!

    My first post was right, but boy did this take a lot of time. The "built-in" thermostat support was either not for this thermostat or it didn't work. I finally got the updater to download and install the HAI RC80 plugin and now it works just as I cabled it. The problem was that I kept thinking my cabling was bad when it was the software all along. So that is why DTR was not +12V. If it wasn't for that I may not have solved this for awhile, thinking that I had the RC80 software running.

    Comment


    • #3
      I think I did try the update, But I am going to try again. For me, the thermostat works all the time for setting the mode, fan and temp. But cant set the HOLD feature, or get responses.


      I also get the timeouts.

      As far as the com port not open thingy, I have only 1 stat on 1 port.......

      Comment


      • #4
        Now, my stat is equivelant to an RC100 I think . (2 stage heat pump)

        Anyhow, Tried both scripts, and updating the plugin, still the same for me.


        My Stat isnt an HAI its actually an Aegis. But they are the same thing........

        If I use a program with direct port access, I can get the stat to return info. But of course the program I was using for testing is JUST for testing, and requires manual input of each string......

        This is driving me bonkers, as it "kinda" works

        Comment


        • #5
          Originally posted by gorfllb
          I think I did try the update, But I am going to try again. For me, the thermostat works all the time for setting the mode, fan and temp. But cant set the HOLD feature, or get responses.


          I also get the timeouts.

          As far as the com port not open thingy, I have only 1 stat on 1 port.......
          I'm having the same issue with the RC80B. Did you ever get this working? If so, how?


          I finally got this working. My problem was that I had read somewhere to tie the red and black comm wires together on the thermostat side. This must be only for certain configurations. Once I fixed the comm cable, I was able to control everything and 2 way communications worked.

          Scott
          Last edited by sqhughes; December 3rd, 2006, 04:12 PM. Reason: update

          Comment


          • #6
            Hi All,

            I've read some posts referring to "enabling serial communications" on the thermostat. I've built a cable (checked it multiple times) but am still getting timeouts/port not open errors. Does anyone have details on enabling this setting?

            Thanks,

            Jason

            Comment

            Working...
            X