Announcement

Collapse
No announcement yet.

Hai Outside temp reading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hai Outside temp reading

    Hi all

    I have recently installed a HAI RC-80 thermostat and have it communicating fine with the homeseer hai plugin. I can send commands to the thermostat and heater turns on/off etc. The only problem is that it displays the outside temperature as 0 degrees. I have the box ticked in my setup to use one of my 1 wire temp sensors as the outside temp reading from data I import to homeseer via weather display. I have tried a couple of rebooting and power off combinations, but still no luck.
    Anyone else had a similar problem?

    I am running Homeseer 2.1.28

    Cheers

    Andy

  • #2
    Hi Andy,

    I have this working at my house. In my case the temperature is also coming from a 1-wire device. The 1-wire device is connected to a PIC that I query via a serial port using a script. If I remember right, my script sets both the value and status of the temp virtual device.

    I wonder if perhaps just setting the status would cause this? You might want to check and see if the value is also being set...

    Comment


    • #3
      Hi YoYo
      Thanks for the reply. I changed the device type from Status Only to Virtual and then turned On the device I want to use as the outside temp reading. It changed from 0 to -28. Although not the correct reading, it changed which is a good start. When I turned it off, the reading went back to zero.
      I have attached my script which populates the weather data to homeseer, just in case the problem lies there.

      Cheers
      Andy
      Attached Files

      Comment


      • #4
        Hi Andy, Here's a snippet of the part of the script that sets the outside temp virtual device for me:

        SUB SetTemperature(xDevice,xTemp)
        IF HS.DeviceValue(xDevice) = 998 THEN
        HS.WriteLog "HLT",GetDeviceName(xDevice) & " probe is now reporting"
        END IF
        IF HS.DeviceString(xDevice) <> CStr(xTemp) THEN
        'HS.WriteLog "HLT", "Writing device string change"
        HS.SetDeviceString xDevice,xTemp
        HS.SetDeviceValue xDevice,ROUND(xTemp)
        END IF
        HS.SetDeviceLastChange xDevice,NOW
        END SUB

        I think the important lines are in red... Looks to me like you're basically doing the same thing though... Perhaps you could do a hs.WriteLog with the status and value when the script executes, just to double-check that aspect of it.

        Comment


        • #5
          I have tried this with Homeseer 1.7.44 and it worked fine first time with the exact same script!! Are there perhaps some subtle changes to the scripting commands that are needed for Homeseer 2.1?

          Cheers

          Andy

          Comment


          • #6
            Are there perhaps some subtle changes to the scripting commands that are needed for Homeseer 2.1?
            Well... I suppose that's possible. However, the script I'm using was unchanged between 1.7, 2.0, and 2.1.

            I think if you wrote another short script to log the device value and device status to the console, and they look fine, then I doubt it's the script that's the problem.

            Could it be the version of the HAI plug-in you've got? I just checked mine from the Setup | Interfaces tab and it shows 1.0.16.0 Don't have any idea if that's the most current, but all aspects are working fine for me.

            Comment

            Working...
            X