Announcement

Collapse
No announcement yet.

Error opening Com Port for RC80

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error opening Com Port for RC80

    I just got my new RC-80 wired up and everything works great using the plugin. Then I tried to add a Device so I could control the stat from the Status page and when I did, I got this error immediately:

    "11/4/2006 8:49:33 PM Warning Attempt to send to COM port 6, port is not open"


    I assume the plugin is handling the Open and Close of Com 6 and I need to open Com 6 in the Startup.txt, so I added this:

    hs.OpenComPort 6,"300,N,8,1",1,"",""


    But when startup runs, I get this error:

    "11/4/2006 8:36:51 PM Error In OpenComPort, error opening port: Unable to obtain a handle to the COM port"


    I tried different baud and other com settings, but no luck. I'm not very skilled at this stuff, so I could be making an easy rookie mistake. The plugin works perfectly controlling the RC80, but for some reason I cannot add a device and it communicate with the stat via Com 6. Any ideas?

  • #2
    If the plugin is handling the open/close of the com port and you put another statement in the startup.txt file this will cause a com port conflict. I do not use this plugin but I have to assume the plugin will open and close the com port at a minimum.
    -Rupp
    sigpic

    Comment


    • #3
      I think you're right, the pugin is opening and closing the com port correctly, because the pugin works great. Using the plugin, I can view the stat and change the setpoint and I get no errors. It's when I try to add a new device on the Status page that I get the error about not being able to open the com port.

      For those of you using the HAI plugin, have you also added a device to control the stat from the status page or are you doing all of your control from the plugin page?

      Comment


      • #4
        I think I have solved my problem. I had been adding the device from the Status page. That adds a single device that I can pass multiple parameters, which I like - but it won't work for me. Then I realized I can add devices from within the plugin for individual controls like "Set Cool Setpoint", "Set Heat Setpoint", etc. When I do that and add a device for each function I want to control, it works.

        Comment

        Working...
        X