Announcement

Collapse
No announcement yet.

Enabling Remote Communications RC-80

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enabling Remote Communications RC-80

    Hi All,

    I'm having trouble connecting to a RC-80 via serial connection. I believe I have the cabling correct. I've searched the boards and with google and all I can figure is that I need to set something on the thermostat to enable serial communications. According to the features of the thermostat:

    "4 communications modes, selectable during installation: 2 serial modes for connection to home automation systems, building management systems and personal computers, and 2 voltage signal modes for connection to time clocks, remote setback switches and many burglar alarm panels"

    and from the installation manual:

    "Your thermostat can be connected to an automation system or
    personal computer. With network software, the remote system can
    send commands to the thermostat to change mode, cool setting, heat
    setting, status of fan and hold, and other items.
    "REMOTE" will be displayed when a command is sent from the
    automation system or personal computer. You can use the arrow
    keys (<->) on the thermostat to change the temperature settings.
    When the temperature settings are changed at the thermostat,
    "REMOTE" will no longer be displayed. Press the Hold key to
    prevent thermostat programs or the remote system from changing
    temperature settings. "HOLD" will be displayed at the thermostat."

    However, I can't figure what needs to do to toggle between these modes. I think there is an installation PDF that is not available to the public.

    Anyone have any tips for me?

    Thanks,

    Jason

  • #2
    Is this what you're looking for?
    Attached Files
    Last edited by sqhughes; December 3rd, 2006, 10:48 AM.

    Comment


    • #3
      thanks sq,

      I had seen these documents. Again, they imply I need to set a mode at the thermostat but as far as I can tell they do not explain how to do this. Is this a correct assumption?

      thanks again,

      Jason

      Comment


      • #4
        Jason,


        Start with page 10 in the rci80 document.

        Scott

        Comment


        • #5
          Thanks Scott - the copy of rc80.pdf that I had did not contain this information. Making progress but now getting a lot of timeouts. Working on that in another thread I just posted.

          Comment


          • #6
            Hey Scott - not sure if you are 'listening' to this post or not but I surrender...

            I just built a totally new cable from ratshack parts and from a different diagram (possibly the same pinouts, but a different diagram nevertheless) and am experiencing the same symptoms:

            1 - lots of timeouts reading and writing to therm, using different PCs
            2 - intermittent succesful control - things on the therm may change when changed on the PC
            3 - PC does not appear to read the temp (reports -49 degrees)

            Should I suspect a bad therm? What else should I try - are there any baud settings in the OS that need to be set?

            HELP!

            Jason

            Comment


            • #7
              Jason,

              Were you ever able to get into the programming mode on the thermostat and change the settings per the manuals?
              Also, I found that on page 17 of the rci80 manual it shows that you are supposed to hook the red and black wires together on the thermostat. I found out this was Wrong for the hookup to the serial port going to the homeseer computer. Once I seperated the red and black wires and hooked them up according to the instructions I found in another thread, everything has worked fine since.
              There are port settings, but I think the plugin handles them.


              Scott

              Comment


              • #8
                Have you set the baud rate to 300 on the thermostat for pc connection?

                Andy

                Comment


                • #9
                  ....and on the serial port of the pc?

                  Comment


                  • #10
                    Thanks guys....

                    Scott - Red and Black are not connected in my setup. I'm using the attached image I found elsewhere on the boards.

                    In the programming section of the thermostat, I set:
                    Address (00) to 1
                    Communications Mode (00) to 1

                    Andy - In device manager of the host OS, I set the comm port to 300 (was 9600) but that didn't seem to do anything. The only place I see to do this on the therm is by setting Communications Mode to 1.

                    Because the two can 'communicate' I'm tempted to believe its a communications timing problem, but really what do I know...
                    Attached Files

                    Comment


                    • #11
                      Real comm port?

                      Mine wouldnt work on a serial to usb converter. From your above post with the diagram attached it seemed as if you are on an actual comm port. Just checking.

                      Later, Terry
                      Last edited by tman1; January 10th, 2007, 10:50 AM. Reason: spelling

                      Comment


                      • #12
                        Correct...this is a real comm port. no USB involved.

                        Comment


                        • #13
                          Not really sure if this will help anyone, but this is the official wireing doc from HAI.

                          Hope this helps.
                          -Skybolt
                          Attached Files
                          -Skybolt

                          Comment


                          • #14
                            Is anyone with an implemented RC-80 interested in building and testing a cable that I could buy from them? Check out my FS ad for potential trade options too. I just don't have enough time to continue to fight with this. Thanks for everyone's willingness to offer suggestions...

                            Comment


                            • #15
                              bump... anyone?

                              Comment

                              Working...
                              X