Announcement

Collapse
No announcement yet.

Auto mode button missing, other wierdness

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auto mode button missing, other wierdness

    I installed a trial a while back, never got around to troubleshooting it, bought the plugin a while ago and finally getting some time to devote to getting this working. Before on the older version, it never worked right, I didn't get the buttons to change the mode, its just empty field and it kept creating new devices named setpoint that didn't seem to do anything. I was up to about 10 or 12 before I disabled it. Fast forward to now on the latest versions, I only have 2 setpoint devices with no other information but I still don't have full functionality. I'm not sure how to log this since there's nothing to get it to do, it's just not there. I'll attach the output from the lyric tab and a screenshot and hoping we can go from there.

    The desired functionality is I want it to heat to 71 if its colder than that and cool to 74 if its hotter than that. Playing with the tstat I found an auto change over setting but that seems to only have 1 temp setting which is not going to work. I have that turned off and simulate auto turned on in the plugin.

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	81.6 KB
ID:	1292738

    let me know if you need a log or anything but like I said, not sure what it'd show.
    thanks

  • #2
    The functionality you described is exactly what simulated auto should be able to accomplish (and sort of what auto change over could do on the thermostat itself, but it's not as visible to you, so I don't use that on mine, either). However I can't really say how wonky the system might be with BOTH "Auto Changeover" and "Simulate Auto" turned on, so I recommend you pick one or the other (and I'd recommend simulate since that's what I have the most experience with).

    So request 1: Change the thermostat so it's not in Auto Changeover mode.

    The devices there look almost normal, as you have the two different setpoint devices. I wouldn't agree you have "no other information" since I see a lot of other things there, but you are missing one crucial piece of data: system mode! The Lyric data you sent me shows that "mode" is set to "Cool", just like it's supposed to be. But for some reason it appears your system mode device doesn't have the right Status Graphics configured.

    So request 2: Please go to the System Mode device details page and post a screenshot of the Status Graphics tab - I primarily want to see the top part.

    Comment


    • #3
      Thermostat already has auto change over disabled. I figured the two would conflict so I've left it off. I toyed with turning it on and when it didn't help, I set it off so that's covered.

      The setpoint devices with no information I neglected to include in the screenshot since they're in a different section. new screen shots attached showing what I'm talking about and the info you requested. Those two setpoints off on their own were what was duplicated like a dozen times originally. They kept showing up every often, was very strange.

      Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	333.5 KB
ID:	1292813Click image for larger version

Name:	Capture2.PNG
Views:	1
Size:	82.1 KB
ID:	1292814

      Comment


      • #4
        My bad on the auto changeover. I noticed the line saying it supported it and mistakenly thought that was the line saying it was active.

        Regarding the Setpoint devices, you should be able to delete those. The only time a "Setpoint" device is created is when Simulate Auto is off AND your device doesn't support auto mode. So I'll need to look at why it was creating those in your case, but I assume if you delete them now they won't come back again.

        The weirdest part is the system mode status graphics setting, though, since nothing in my code would ever create something like that; it's not even possible.

        My advice is to completely start over and make sure the whole process is recorded in the log file (which DOES tell me a TON about how the plugin is behaving, why it's creating/not creating things, etc.).

        To do that, please:

        1. On the plugin Config page Thermostat list tab, delete this thermostat.
        2. On the plugin Config page Options tab, set the Plugin Log File level to TRACE.
        3. Stop the plugin.
        4. Delete any left over devices that would have been created by this plugin.
        5. Start the plugin.
        6. On the plugin thermostat list page, add the thermostat again.
        7. Wait at least a minute or two for the process to complete.
        8. Once you see all the devices created and with values set (similar to what you see now, hopefully without the problems!) set the Plugin Log File back to INFO.
        9. On the plugin Config page Options tab, click on "Download Log File".

        Provide the log file (along with all the other information requested in the "Having problems? Follow these steps first." sticky post in this forum. (I already have the Lyric info thanks to your first post, but other info about HS version, OS, etc. would help.)

        Comment


        • #5
          Followed the steps and I was sitting on the device management page and I saw for a flash all the buttons I'd expect to see and then they were gone. Log doesn't look like much but here it is along with the other pertinent data. I do not have the erroneous setpoint devices at this point.

          I had to rename the log extension, forum wouldn't allow me to post it. I included another screenshot from the HS log that I thought might be helpful / relevant.

          HomeSeer version 3.0.0.500 Edition: HS3 Pro
          plugin 1.1.5.0
          Windows Server 2012 R2
          Lyric T5

          Click image for larger version

Name:	Capture3.PNG
Views:	1
Size:	118.3 KB
ID:	1292968

          thanks!

          Comment


          • #6
            Hi, any updates? any additional information I can provide?

            Comment


            • #7
              Ack, sorry! Didn't notice the update that you'd posted those results. I'll start looking into it again this weekend. My first thought is there's something wrong with my logic that tries to store the "ref" in the config file that isn't properly handling it when that device is no longer there. If you have access to the filesystem, you could try the steps above, but add one more thing: while the plugin is shutdown, edit the config\HSPI_SKWARE_HW_LYRIC.ini file and remove the line for the RootDevices, too, before restarting. That's the area I'll be looking at as the likely culprit for this behavior and a recently added capability to improve startup times...

              Comment


              • #8
                Originally posted by cward3321 View Post
                Followed the steps and I was sitting on the device management page and I saw for a flash all the buttons I'd expect to see and then they were gone. Log doesn't look like much but here it is along with the other pertinent data. I do not have the erroneous setpoint devices at this point.

                I had to rename the log extension, forum wouldn't allow me to post it. I included another screenshot from the HS log that I thought might be helpful / relevant.

                HomeSeer version 3.0.0.500 Edition: HS3 Pro
                plugin 1.1.5.0
                Windows Server 2012 R2
                Lyric T5

                Click image for larger version  Name:	Capture3.PNG Views:	1 Size:	118.3 KB ID:	1292968

                thanks!
                Unfortunately this log file wasn't generated using the process I listed above, since the whole startup process isn't logged. It appears you started the plugin THEN went and set it to TRACE, but by then, all the stuff I needed to see around finding the missing thermostat (or not) had already happened.

                That being said, I can see one problem just reading through the code, which is the same area calling the "RemoveHSDevices" method if your AuthState isn't completed (which it shouldn't, since I changed it in the last release to allow them to continue existing even when you're not holding a valid HW OAUTH ticket), or if the device the plugin *thinks* is the parent is missing.

                However, that doesn't explain why it doesn't have the right idea about the ref of the parent thermostat...

                Comment


                • #9
                  I could have sworn I followed the directions but clearly I did not as this log is much more involved. I redid the steps with the addition of removing the RootDevices from the ini file. Same result. Here's the proper log attached.
                  Last edited by shill; March 25th, 2019, 07:45 PM. Reason: Removed log file once retrieved.

                  Comment


                  • #10
                    Thanks! Having the log helped me figure out the problem - and it only occurs if you have a thermostat configured for emergency heat (which I do not), so I hadn't been able to recreate this until now. I think I have it fixed, but since I can't fully test it, I'm going to post the patched EXE here for you to confirm before I put it in the updater. Just stop the plugin and replace the EXE in your HS3 directory with this one.
                    Attached Files

                    Comment


                    • #11
                      OK that looks like a winner so far. I have buttons! I've set it to auto so we'll see if it gets cool enough tonight to kick in. if not, i'll adjust my setpoints to force it to do its thing and report in.

                      thanks!

                      Comment


                      • #12
                        It does appear to be functioning as desired. It switched over last night when temp dipped below 71. There are some errors in the logs (server 500) but that sounds more like honeywell having some issues. I'll see if they persist and if so, raise a new thread here.

                        thank you for getting this resolved.

                        Comment


                        • #13
                          Glad to hear that. Closing this thread now that this is resolved and will officially put this version in the updater.

                          Comment

                          Working...
                          X