Announcement

Collapse
No announcement yet.

Thermostat Communication Issues

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MichaelV
    replied
    I'm sorry, the events run in homeseer but the thermostats don't change and I get the error message.

    Leave a comment:


  • shill
    replied
    The thermostat updates every 5 minutes. Which means over that nearly five hour period, it appears to have failed 6 times out of 60 attempts.

    I don't know exactly what you mean by your events not running - can you elaborate on that part? That's almost exclusively controlled by HS3 itself; either the trigger condition was met or it wasn't.

    Leave a comment:


  • MichaelV
    replied
    Having more communication issue. Here is what the log says and my thermostat events are not running. I have tried restarting the plugin and I am not having any issues with the Honeywell web interface of my mobile devices when trying to control the thermostats.


    Honeywell WiFi Thermostat
    Failed to retrieve thermostat data - error occurred, will retry
    Mar-01 7:51:59 AM

    Honeywell WiFi Thermostat
    Error retrieving data for device 439441: Unexpected character encountered while parsing value: . Path '', line 0, position 0.
    Mar-01 7:15:00 AM


    Honeywell WiFi Thermostat
    Failed to retrieve thermostat data - error occurred, will retry
    Mar-01 6:15:22 AM

    Honeywell WiFi Thermostat
    Error retrieving data for device 2548116: The remote server returned an error: (500) Internal Server Error.
    Mar-01 5:16:57 AM


    Event
    Event Trigger "HVAC Heating Heat 1st Floor via Motion sensors"
    Mar-01 4:15:00 AM



    Honeywell WiFi Thermostat Error retrieving data for device 2548087: The operation has timed out

    Failed to retrieve thermostat data - error occurred, will retry
    Mar-01 4:08:38 AM

    Honeywell WiFi Thermostat
    Error retrieving data for device 2548116: The remote server returned an error: (500) Internal Server Error.
    Mar-01 3:01:45 AM

    Honeywell WiFi Thermostat
    Failed to retrieve thermostat data - error occurred, will retry
    Mar-01 3:01:45 AM



    Leave a comment:


  • shill
    replied
    Looks like there were a couple times overnight when the Honeywell services weren't available. But since most of the time you weren't getting errors, I'd say it's working properly and I wouldn't worry about those since there's nothing we can do about it.

    (And none of that necessarily has anything to do with events, that's the plug-in polling the Honeywell services every 5 minutes, OR when an event asks it to do something, of course.)

    Leave a comment:


  • MichaelV
    replied
    This just in. I was able to recover some of my events and here is what the log showed over night.

    See the attached.
    Attached Files

    Leave a comment:


  • shill
    replied
    Originally posted by MichaelV View Post
    Oh I can see them in homeseer alright, but I want the events to control them, not me manually changing the settings.
    Ok, glad to hear the plugin is working and you're able to connect to and see the devices. If you need any help setting up events to control it, just let me know!

    Leave a comment:


  • MichaelV
    replied
    Oh I can see them in homeseer alright, but I want the events to control them, not me manually changing the settings.

    Leave a comment:


  • shill
    replied
    Your events shouldn't have any impact on the ability to see/control your thermostat devices in HS3. If you've enabled the plugin and added the thermostats on the config page, they should show up in your list of devices.

    Leave a comment:


  • MichaelV
    replied
    Thanks for checking in. I had to restore my hometoller as for some reason, my hardrive was full. HS Tech support recommended that I do the restore and since then, last Thursday, I lost all my events so I have not been able to see what is happening with my Thermostats with regard to homeseer. I am able to control them just fine with my smartphone!!

    Leave a comment:


  • shill
    replied
    Any luck?

    Leave a comment:


  • MichaelV
    replied
    Thank you for the explanation. Everything was there when I did the back up on 1-13-2018. I am waiting for a response from HS Tech support. Hopefully, when this is all put back together, the original thermostat communication issues will be resolved.

    Thanks

    MV

    Leave a comment:


  • shill
    replied
    As I understand it, the backup is just a copy of your HS3 configuration database at a point in time, so if the backup happened with those devices and events included, they should be there after a restore. All I can really confirm is there's nothing I know about in the plugin that would keep it from working. If your backup was from before they were created, that's a different story.

    Leave a comment:


  • MichaelV
    replied
    So in your opinion, they should have restored? All my thermostat events are gone too.

    Leave a comment:


  • shill
    replied
    I can't really say why the HS restore wouldn't have restored those devices...

    Leave a comment:


  • MichaelV
    replied
    I don't see any reference to any thermostats, root or Orphaned. Should they have been restored? I lost other unrelated devices as well.

    Leave a comment:

Working...
X