Announcement

Collapse
No announcement yet.

LINUX/ZEE USERS: MONO 4.8 OR HIGHER IS REQUIRED!!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LINUX/ZEE USERS: MONO 4.8 OR HIGHER IS REQUIRED!!

    In order to support the security requirements of the Honeywell site, it's necessary to run Mono version 4.8 or higher. Detailed instructions can be found on the Mono Download Page. There are links for various flavors of Linux including the Raspberry Pi.

    NOTE: If you're using a HomeSeer Zee S2 or SEL, HomeSeer has provided these instructions to upgrade:
    If you're running your own Linux-based server, here's an abbreviated cheat sheet to get the latest version of mono installed:

    1. CHECK TO SEE IF YOU NEED TO UPGRADE. This requires SSH access to your server. If you're not comfortable or familiar with that, you can also check the log when the plugin starts, as it should report the version of Mono.

    To check for yourself, execute the following command:
    Code:
    pi@zee:~$ mono --version
    Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-10)
    If the version is below 4.8, continue. If you're already on a supported version, you can begin using the updated plugin (1.3.0 or higher) now!

    2. SHUT DOWN AND BACKUP YOUR ENTIRE SYSTEM. If you aren't sure how to do this, do not proceed until you've gotten a solid backup of your system (not just your HomeSeer config file).

    3. ADD THE MONO REPOSITORIES. See the instructions here (Step 1 on that page) for how to do this based on your OS and hardware.

    4. UPDATE MONO. Execute the following commands:
    Code:
    sudo apt-get -y install mono-complete mono-vbnc
    5. CHECK TO SEE IF THE UPGRADE WAS SUCCESSFUL. Either start the plugin (version 1.3.0 or higher) or check yourself with the same command as above:
    Code:
    pi@hslinux:~$ mono --version
    Mono JIT compiler version 5.12.0.226 (tarball Thu May  3 11:57:48 UTC 2018)
    If you have successfully updated to a recent version of mono, you can restart HomeSeer and the plugin should be working with the updated Honeywell security requirement of using TLS 1.2!
    Last edited by shill; November 1st, 2018, 01:39 PM.

  • #2
    OK, on Debian v9.5, trying to update Mono.

    When I try to add the new Mono repositories, I get this error with the first command (logged in as root):

    apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

    Executing: /tmp/apt-key-gpghome.J7S1EOIATz/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
    gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory
    gpg: connecting dirmngr at '/run/user/1000/gnupg/d.3d81ygonyup14nfjaop48a5s/S.dirmngr' failed: No such file or directory
    gpg: keyserver receive failed: No dirmngr

    Help! ^G^G^G^G^G - OK, found the culprit myself - needed to install the dirmngr package first!

    OK, now get error on the apt update:

    E: The repository 'cdrom://[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25] stretch Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    N: Skipping acquire of configured file 'main/binary-amd64/Packages' as repository 'https://download.mono-project.com/repo/debian stable-raspbianjessie InRelease' doesn't support architecture 'amd64'

    Is there a way to tell the update to allow it to go ahead even if not secure?

    Thanks,
    Last edited by amr42; November 1st, 2018, 01:23 PM.

    Comment


    • #3
      Originally posted by amr42 View Post
      OK, on Debian v4.9, trying to update Mono.

      When I try to add the new Mono repositories, I get this error with the first command (logged in as root):

      apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

      Executing: /tmp/apt-key-gpghome.J7S1EOIATz/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
      gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory
      gpg: connecting dirmngr at '/run/user/1000/gnupg/d.3d81ygonyup14nfjaop48a5s/S.dirmngr' failed: No such file or directory
      gpg: keyserver receive failed: No dirmngr

      Help! ^G^G^G^G^G - OK, found the culprit myself - needed to install the dirmngr package first!
      That's an easy fix

      Comment


      • #4
        Originally posted by shill View Post

        That's an easy fix
        Thanks (sometimes my Linux skills even amaze me!), but now I've hit another roadblock (see above)...

        Comment


        • #5
          I'm revising these instructions to send you to the Mono page (which has a better list of "if this OS and this hardware..." instructions than I have above) because mine were specific for raspbian on ARM hardware as originally typed

          Check on the instructions on https://www.mono-project.com/downloa.../#download-lin

          You'll want to install the mono-complete and the ca-certificates-mono packages.

          Comment


          • #6
            Originally posted by shill View Post
            I'm revising these instructions to send you to the Mono page (which has a better list of "if this OS and this hardware..." instructions than I have above) because mine were specific for raspbian on ARM hardware as originally typed

            Check on the instructions on https://www.mono-project.com/downloa.../#download-lin

            You'll want to install the mono-complete and the ca-certificates-mono packages.
            Thanks - that worked. Now I understand that I was following the raspbian instructions (so many Linux flavors...).

            I'm all good now (for Mono) - not to enable my Honeywell WiFi plugin!

            Comment

            Working...
            X