Announcement

Collapse
No announcement yet.

Frequent errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Frequent errors

    I'm seeing frequent errors such as these below. It seems it's every 40-50 minutes. Ideas? FWIW, nothing has changed as far as the Honeywell site and I haven't changed anything on the HS3 side. Eventually I do get the correct info because looking at the main page, the devices are correct.

    May-30 13:49:50 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:49:50 Honeywell WiFi Thermostat [2275932]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 13:04:11 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:04:11 Honeywell WiFi Thermostat [2275932]Error retrieving data: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 13:04:07 Honeywell WiFi Thermostat [2276054]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:04:07 Honeywell WiFi Thermostat [2276054]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 12:33:42 Honeywell WiFi Thermostat [2276054]Failed to retrieve thermostat data - error occurred, will retry
    May-30 12:33:42 Honeywell WiFi Thermostat [2276054]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 12:28:42 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 12:28:42 Honeywell WiFi Thermostat [2275932]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)

    PI v 1.3
    HS3 v .435

  • #2
    Originally posted by racerfern View Post
    I'm seeing frequent errors such as these below. It seems it's every 40-50 minutes. Ideas? FWIW, nothing has changed as far as the Honeywell site and I haven't changed anything on the HS3 side. Eventually I do get the correct info because looking at the main page, the devices are correct.

    May-30 13:49:50 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:49:50 Honeywell WiFi Thermostat [2275932]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 13:04:11 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:04:11 Honeywell WiFi Thermostat [2275932]Error retrieving data: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 13:04:07 Honeywell WiFi Thermostat [2276054]Failed to retrieve thermostat data - error occurred, will retry
    May-30 13:04:07 Honeywell WiFi Thermostat [2276054]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 12:33:42 Honeywell WiFi Thermostat [2276054]Failed to retrieve thermostat data - error occurred, will retry
    May-30 12:33:42 Honeywell WiFi Thermostat [2276054]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)
    May-30 12:28:42 Honeywell WiFi Thermostat [2275932]Failed to retrieve thermostat data - error occurred, will retry
    May-30 12:28:42 Honeywell WiFi Thermostat [2275932]Failed to log in: Web request failed: The remote server returned an error: (403) Forbidden. (403)

    PI v 1.3
    HS3 v .435
    I get those occasionally as well, but currently have no explanation. All my requests are made in sequential fashion and the login page itself shouldn't ever return a "Forbidden" status under normal circumstances, so I can only assume it has something to do with the fact that we're "pretending" to log in programatically in order to get access without a real API.

    Comment


    • #3
      I am also seeing LOTS of errors

      Every 5 minutes, 24 hours per day...

      Jun-06 11:56:42 Honeywell WiFi Thermostat [96546]Failed to log in: Object reference not set to an instance of an object. Jun-06 11:56:39 Honeywell WiFi Thermostat [43648]Failed to retrieve thermostat data - error occurred, will retry Jun-06 11:56:39 Honeywell WiFi Thermostat [43648]Failed to log in: Object reference not set to an instance of an object. Jun-06 11:56:42 Honeywell WiFi Thermostat [96546]Failed to retrieve thermostat data - error occurred, will retry

      Help!
      Last edited by amr42; June 6th, 2018, 10:02 PM.

      Comment


      • #4
        Originally posted by amr42 View Post
        Every 5 minutes, 24 hours per day...

        Jun-06 11:56:42 Honeywell WiFi Thermostat [96546]Failed to log in: Object reference not set to an instance of an object. Jun-06 11:56:39 Honeywell WiFi Thermostat [43648]Failed to retrieve thermostat data - error occurred, will retry Jun-06 11:56:39 Honeywell WiFi Thermostat [43648]Failed to log in: Object reference not set to an instance of an object. Jun-06 11:56:42 Honeywell WiFi Thermostat [96546]Failed to retrieve thermostat data - error occurred, will retry

        Help!
        Please see these two posts at the top of the forums:

        Please include System Profile with Posting for Help and Suggestions

        Having Problems? Follow these steps first.

        Comment


        • #5
          I'm getting the "Failed to receive thermostat data" error too, every three or four seconds. Here is the data you requested in your "try this first" post.


          Thanks

          Current Date/Time: 2/24/2019 10:41:27 AM
          HomeSeer Version: HS3 Pro Edition 3.0.0.500
          Operating System: Microsoft Windows Embedded Standard - Work Station
          System Uptime: 5 Days 0 Hours 28 Minutes 43 Seconds
          IP Address: 10.0.0.134
          Number of Devices: 866
          Number of Events: 51
          Available Threads: 200
          HSTouch Enabled: True
          Event Threads: 0
          Event Trigger Eval Queue: 0
          Event Trigger Priority Eval Queue: 0
          Device Exec Queue: 0
          HSTouch Event Queue: 0
          Email Send Queue: 0
          Anti Virus Installed:
          In Virtual Machine: No MFG: shuttle inc.
          Enabled Plug-Ins
          2.0.50.0: BLBackup
          1.4.0.1: Honeywell WiFi Thermostat
          3.0.1.9: ISYInsteon
          3.0.2.1: Napco Gemini
          Attached Files

          Comment


          • #6
            I'm sorry to hear that. Unfortunately, that log file doesn't contain the information I need, since it's a) not the log file created by my plugin (which writes .log files) and it doesn't contain TRACE level details. From this I can tell there's something it doesn't like in the response, which I'm trying to parse as JSON but something must have gone wrong, since the content contained "<" which most likely means it was HTML instead of JSON, but that's all I can tell you based on that info.

            EDIT: Also, if you're getting that every 3 or 4 seconds, something is terribly wrong and you should shut down the plugin immediately and examine your events to see what's causing the plugin to be called that frequently. There's a chance your account has been suspended with that much frequency, so please double check that you can still log in via the website manually.

            Comment

            Working...
            X