Announcement

Collapse
No announcement yet.

Setpoint Error When Auto-Switchover is Disabled for a Thermostat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setpoint Error When Auto-Switchover is Disabled for a Thermostat

    Shill

    It looks like there is a software bug in vesion 1.3.2.0 of the Honeywell WiFi Thermostat plugin that causes an error when a thermostate is set to auto-switchover disabled..

    Here's the scenario. I have two thermostats, Kitchen and Bedroom. Both have Min Cool: 72, Max Cool 99, Min Heat 40, Max Heat 76

    Bedroom is configured to allow auto-switchover between Heat / Cool modes. HomeSeer shows a separate Heat Setpoint and a Cool Setpoint. This thermostat works fine on HomeSeer.

    Kitchen, on the other hand, is configured so that auto switchover is disabled. HomeSeer shows a single setpoint. My expectation is that, in Heat Mode, you would use the single setpoint to select from the range 40-76, while in Cool Mode, you would that setpoint to select from 72-99. However, this Kitchen thermostat, when in Cool mode, only allows selection of 40-76 -- i.e., the same range as for Heating. It appears that, when a Thermostat with auto-switchover disabled is used, the plugin neglects to adjust the single setpoint's range depending on the mode and only uses the Heating mode's range. Can you take a look?

  • #2
    Originally posted by jvm View Post
    Shill

    It looks like there is a software bug in vesion 1.3.2.0 of the Honeywell WiFi Thermostat plugin that causes an error when a thermostate is set to auto-switchover disabled..

    Here's the scenario. I have two thermostats, Kitchen and Bedroom. Both have Min Cool: 72, Max Cool 99, Min Heat 40, Max Heat 76

    Bedroom is configured to allow auto-switchover between Heat / Cool modes. HomeSeer shows a separate Heat Setpoint and a Cool Setpoint. This thermostat works fine on HomeSeer.

    Kitchen, on the other hand, is configured so that auto switchover is disabled. HomeSeer shows a single setpoint. My expectation is that, in Heat Mode, you would use the single setpoint to select from the range 40-76, while in Cool Mode, you would that setpoint to select from 72-99. However, this Kitchen thermostat, when in Cool mode, only allows selection of 40-76 -- i.e., the same range as for Heating. It appears that, when a Thermostat with auto-switchover disabled is used, the plugin neglects to adjust the single setpoint's range depending on the mode and only uses the Heating mode's range. Can you take a look?
    Absolutely. Sorry about that!

    Comment


    • #3
      Originally posted by jvm View Post
      Shill

      It looks like there is a software bug in vesion 1.3.2.0 of the Honeywell WiFi Thermostat plugin that causes an error when a thermostate is set to auto-switchover disabled..

      Here's the scenario. I have two thermostats, Kitchen and Bedroom. Both have Min Cool: 72, Max Cool 99, Min Heat 40, Max Heat 76

      Bedroom is configured to allow auto-switchover between Heat / Cool modes. HomeSeer shows a separate Heat Setpoint and a Cool Setpoint. This thermostat works fine on HomeSeer.

      Kitchen, on the other hand, is configured so that auto switchover is disabled. HomeSeer shows a single setpoint. My expectation is that, in Heat Mode, you would use the single setpoint to select from the range 40-76, while in Cool Mode, you would that setpoint to select from 72-99. However, this Kitchen thermostat, when in Cool mode, only allows selection of 40-76 -- i.e., the same range as for Heating. It appears that, when a Thermostat with auto-switchover disabled is used, the plugin neglects to adjust the single setpoint's range depending on the mode and only uses the Heating mode's range. Can you take a look?
      Can you provide the JSON data from your Kitchen thermostat, please?

      EDIT: Disregard, I found the problem. (And sorry for the delay - typing and using a mouse with a broken thumb is not very easy!)

      Comment


      • #4
        Glad you found the problem!

        I assume you're trying to develop a fix for this, and you may have already recognized what I'm about to say, but just in case, I'll make the point that something to keep in mind is that over the "lifetime" of the HomeSeer setup, a user could change the thermostat between enabling the Auto-Switchover feature, and not allowing it. This impacts the number of child devices for the thermostat. Ideally, HomeSeer, and your plugin, should be able to adapt without requiring the user to remove and re-add the Thermostat when the auto-swtichover enabled mode is changed.

        I'm guessing a bit here, but it seems that, under your current implementation, the number of child devices will change depending on whether auto-switchover mode has been enabled or not (i.e., it changes to either use one shared setpoint control, or else two controls (i.e., separate heating + cooling setpoints)). I'm not sure if adjusting the number of child devices is possible after a device has been added as I haven't seen other devices where the number of child nodes can increase and then decrease back and forth over time. If you can't dynamically change the number of child devices, my preference would be to always see a separate heating and a cooling setpoint (rather than having to remove and re-add t he device so that homeseer can get the # of nodes correct).

        Thanks for taking the time to address the problem. No worries about the delay - hope the thumb heals quickly.
        Jim

        Comment


        • #5
          Yes, I've already fixed the code, but I was also in the middle of a wider update, so I need to finish that before I can publish. The child devices are dynamic, so no worries about it changing. It checks that either on the first update after plugin startup or on every update, I forget which.

          Comment

          Working...
          X