Announcement

Collapse
No announcement yet.

Support for Set Drying Mode command

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by cbabkirk View Post

    I will give that a try and get back to you. Thanks.
    Hello,

    I had two instances today captured here...

    11/24/2020 16:37:18.990 Info [------] PluginLogic.InitIO Running on Windows Version 6.2.9200
    11/25/2020 04:22:03.365 Error [5005471] HWConnection.GetData Error retrieving data: Object reference not set to an instance of an object.
    System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_SKWARE_HW_WIFI_TSTAT.HWConnection.PerformRequest(String strMethod, RequestParameters& objParms)
    at HSPI_SKWARE_HW_WIFI_TSTAT.HWConnection.GetData(String strDeviceID, ThermostatData& objCurrentData)
    11/25/2020 04:22:03.378 Error [5005471] ThermostatCommand.ProcessUpdateResults Failed to retrieve thermostat data - error occurred, will retry

    11/25/2020 15:21:56.583 Error [5005471] HWConnection.GetData Error retrieving data: Object reference not set to an instance of an object.
    System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_SKWARE_HW_WIFI_TSTAT.HWConnection.PerformRequest(String strMethod, RequestParameters& objParms)
    at HSPI_SKWARE_HW_WIFI_TSTAT.HWConnection.GetData(String strDeviceID, ThermostatData& objCurrentData)
    11/25/2020 15:21:56.587 Error [5005471] ThermostatCommand.ProcessUpdateResults Failed to retrieve thermostat data - error occurred, will retry

    Comment


      #32
      If you capture those errors with trace logging turned on, please send them to me so I can look into why it's happening.

      Comment


        #33
        Originally posted by shill View Post
        If you capture those errors with trace logging turned on, please send them to me so I can look into why it's happening.
        I am including a trace file and a PDF that has the sys info.
        Attached Files

        Comment


          #34
          There are two events. One on 11/25 about 21:22pm. The other on 11/26 about 13:22pm

          Comment


            #35
            Unfortunately the logs aren't helping, as this appears a bit deeper in the web components than in my code, but I've added some wrapping and logging to this version that might help me narrow it down. Afraid I'll need a fresh trace log if you can catch it in the act again to make use of it, though...
            Attached Files

            Comment


              #36
              Finally got around to loading this version. Will see if I can pull a new trace to try to catch it. Thanks.

              Comment


                #37
                Finally got around to capturing trace logs with errors that cause the STATUS to switch between SUCCESS and FAILURE.
                Attached Files

                Comment

                Working...
                X