Announcement

Collapse
No announcement yet.

Status graphics being overwritten

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Status graphics being overwritten

    Could you please do something about the Status Graphics being overwritten, apparently upon restarts. I keep editing them to put various icons for different child devices, and all my work keeps getting undone upon restarts.

    I put in the snowflake for cooling, flame for heating etc., and they are good only until the next restart where it reverts to the missing icon symbol.

    Thanks

    #2
    Seeing the same thing here. Was hoping there was some setting to tell the plugin not to overwrite the icon changes. Likewise, I had changed the text from "Permanent to "Perm" and that keeps getting overwritten, too.

    Click image for larger version

Name:	honeywell-wifi-icons.png
Views:	61
Size:	49.1 KB
ID:	1524380

    Comment


      #3
      Originally posted by DLONG2 View Post
      Seeing the same thing here. Was hoping there was some setting to tell the plugin not to overwrite the icon changes. Likewise, I had changed the text from "Permanent to "Perm" and that keeps getting overwritten, too.

      Click image for larger version  Name:	honeywell-wifi-icons.png Views:	0 Size:	49.1 KB ID:	1524380
      FYI, you can use the replace tag in HSTile to change to output. For example use [replace "Permanent","Perm"] after the tag that provides that text.
      Jon

      Comment


        #4
        Thanks, Jon! Works like a charm!

        Comment


          #5
          Originally posted by DLONG2 View Post
          Thanks, Jon! Works like a charm!
          Same for icon names too if you want....
          Jon

          Comment


            #6
            I was able to fix the icon issue by copying the "\images\HomeSeer\status" folder to a new folder: "\images\HomeSeer\contemporary", as the Honeywell Wi-Fi plugin's icons were pointing to a non-existent folder. But how would I have been able to swap icons within the HSTile?

            Comment


              #7
              Generally speaking, the plugin does this for some devices at startup and for others on every update because the behavior could change based on configuration changes you make to the thermostat itself. The easiest way for me was to wipe it and run the method that creates all the relevant VSP/VGP entries based on the current configuration. Someday I need to change that to be less lazy and evaluate every value independently and only add/remove if something has changed...

              Comment


                #8
                Originally posted by DLONG2 View Post
                I was able to fix the icon issue by copying the "\images\HomeSeer\status" folder to a new folder: "\images\HomeSeer\contemporary", as the Honeywell Wi-Fi plugin's icons were pointing to a non-existent folder. But how would I have been able to swap icons within the HSTile?
                [replace "\status","\contemporary"] after the image tag....
                Jon

                Comment

                Working...
                X