Announcement

Collapse
No announcement yet.

Setting the thermostat to 'program' results in 'auto'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting the thermostat to 'program' results in 'auto'

    Hi Nathan,

    I'm trying to resolve a very old issue. I'm trying to set the thermostat (2441TH) to its 'program' mode, so that the thermostat will cycle through the Leave/return/sleep/wake phases.

    When sending the command 'Insteon thermostat SetMode: 2441TH Mode = Program', it appears to proceed as per the log below, but if I poll the thermostat, it returns a mode of 'Auto'; the physical thermostat remains in the 'Auto' mode.

    Mar-18 16:26:19 Insteon Thermostat 2441TH Temp = 20
    Mar-18 16:26:16 Insteon Thermostat 2441TH Mode = Auto
    Mar-18 16:26:14 Insteon Thermostat TransmitInsteon: [2441TH] [0F] [6A] [20]
    Mar-18 16:26:12 Insteon Thermostat TransmitInsteon: [2441TH] [0F] [6B] [03]
    Mar-18 16:26:10 Insteon Thermostat TransmitInsteon: [2441TH] [0F] [6A] [60]
    Mar-18 16:26:08 Insteon Thermostat TransmitInsteon: [2441TH] [0F] [6B] [02]
    Mar-18 16:26:08 Insteon Thermostat POLL thermostat: 2441TH
    Mar-18 16:26:08 Insteon Thermostat Using saved DEVCAT and FIRMWARE so skip request for 2441TH
    Mar-18 16:26:08 Insteon Thermostat Using saved PROTCOL so skip request for 2441TH
    Mar-18 16:24:46 Insteon Thermostat TransmitInsteon: [2441TH] [1F] [6B] [0A] ((([00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [8B])))
    Mar-18 16:24:46 Insteon Thermostat SetMode: 2441TH Mode = Program

    What do I need to do to have the plugin set the physical thermostat in 'Program' mode?
    Last edited by claude; April 9th, 2018, 01:36 PM.

  • #2
    Claude,

    Sorry for the delay. I had to obtain a replacement 2441th for my test system which just arrived today.

    I can confirm that the set mode = Program is having the desired effect of setting the 2441th to the PROGRAM mode. That is the special hardware supported mode where both heat/cool setpoints are updated 4 times a day: wake, leave, return, sleep. You can confirm this on the 2441th display by looking for one of those 4 words at the right side of the display. The 2441th appears to treat this as a special version of the AUTO mode as you can still see the AUTO mode text in the bottom middle display when in PROGRAM mode.

    The behavior your are seeing during a poll request is how the 2441th is reporting status back when polled. One of the values requested during a thermostat poll is the mode via 0x6B 0x02. The response to that is used to validate or change the mode value of the plugin's virtual device based on what the thermostat is telling us. For some reason, the wired 2441th is reporting back mode = 03 which is AUTO. It is not reporting mode = 05 which is PROGRAM. I can only assume this is either a bug in the 2441th firmware or a poor design implementation by not reporting back the actual correct mode as PROGRAM.

    I also tested this on my Venstar t1700 (with integrated Insteon) and with a wireless 2441zth. Both of these thermostats also support PROGRAM mode and they behave as you would expect. They report the correct mode back as PROGRAM. The Venstar actually has a couple more modes, PROGRAM-HEAT and PROGRAM-COOL which are similar but only using one set point instead of both. In all those tests the correct mode was reported during polling.

    So, the short version of all this is that you can use an event or script or virtual device control to set the 2441th mode = PROGRAM and it does appear to be doing that correctly. Check the hardware display to confirm. After that, if you poll the 2441th, it will incorrectly report back it's in AUTO mode but if you continue to look at the display it will remain in PROGRAM mode. After a poll event, you could add a delayed event to do another set mode = PROGRAM if you want the plugin virtual device to have the mode you expect the thermostat to be in.

    Nathan
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

    Comment


    • #3
      Claude,

      Thinking about this a little more (always helps to sleep on it), I suppose we could do a adjustment specific to the DEVCAT of the 2441th. Something like, if the HS3 virtual mode device is PROGRAM and the new state received from the Insteon network is AUTO (as in a reply from Polling), then ignore this and leave the virtual device as PROGRAM. This would match the observed true state of the 2441th that is in PROGRAM mode but a poll returns AUTO.

      Thinking through mode changes, at the thermostat itself it's always forward, meaning, the next mode button push sets it to OFF. The only way to go from PROGRAM back to AUTO is if a user actively pushes the AUTO mode button inside HS3. If they do that, the plugin will set the mode to AUTO in HS3 anyway.

      Let me know what you think. I could probably test this change out either Friday evening or Saturday morning.

      Nathan
      HS 3.0.0.435 (PRO)
      Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
      Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
      Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
      http://www.kazteel.com/

      Comment


      • #4
        Hi Nathan,

        I suspect a conflict in my conditions for setting the program. More digging...

        Comment


        • #5
          Nathan,

          I am really confused now. I have an event that sets the 2441th to Program mode. It executes based on 'being away' conditions.

          If I 'force execute' the event (bypassing trigger & conditions), the physical 2441th shows Program mode. If we are all away and the event executes, the physical 2441th shows Auto mode.

          I've traced the two situations and the log shows exactly the same commands sent to the 2441th ! See attached log snippet. I know it doesn't make sense.
          Attached Files

          Comment


          • #6
            Just to close this thread off... 'set mode = Program' works fine now after a few adjustments in my logic.

            Comment


            • #7
              Thanks Claude. Sorry for the delay as I was traveling for work all last week. I didn't really have any extra to offer beyond what I observed happening in the set Mode=Program and the odd response after a poll which the 2441th thermostat answers with Auto.

              Nathan
              HS 3.0.0.435 (PRO)
              Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
              Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
              Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
              http://www.kazteel.com/

              Comment

              Working...
              X